Dir-320 no wan interface

Dir-320 A1.
Good afternoon.

I collected a lede (image builder), I stitched it, then I put it on the flash drive.

if for lan write eth0.0 - brick (no access to lede) and have to re-burn

if for wan eth0.1 - not pinging ip from wan

I had the same issue. You have to turn on vlans and play with it.

how?(in terminal)

look here - http://webapp.org.ua/dev/openwrt-chaos-calmer-15-05-on-dlink-dir-320-with-cdma-modem/

   18.550000] Broadcom 43xx-legacy driver loaded [ Features: PLD ]
[   26.610000] b44 ssb0:0 eth0: Link is up at 100 Mbps, full duplex
[   26.610000] b44 ssb0:0 eth0: Flow control is off for TX and off for RX
[   28.030000] b44 ssb0:0 eth0: Link is Up - 100Mbps/Full - flow control off
[   31.430000] jffs2_scan_eraseblock(): End of filesystem marker found at 0x0
[   31.450000] jffs2_build_filesystem(): unlocking the mtd device... done.
[   31.450000] jffs2_build_filesystem(): erasing all blocks after the end marker... ^[[A^[[A
[   34.450000] b44 ssb0:0 eth0: powering down PHY
[   34.530000] b44 ssb0:0 eth0: Link is up at 100 Mbps, full duplex
[   34.540000] b44 ssb0:0 eth0: Flow control is off for TX and off for RX
[   34.580000] device eth0.1 entered promiscuous mode
[   34.580000] device eth0 entered promiscuous mode
[   34.600000] br-lan: port 1(eth0.1) entered forwarding state
[   34.610000] br-lan: port 1(eth0.1) entered forwarding state
[   35.830000] done.
[   35.830000] jffs2: notice: (845) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
[   36.610000] br-lan: port 1(eth0.1) entered forwarding state

you can also use luci

1 Like


1 Like

no vlan configuration

what to do?

Install swconfig.

And enable wifi - even if your vlan configuration will be incorrect wifi should till work

1 Like

I install it. no changes in luci.Tell me please, in detail, what to do.

Post the result of:

swconfig dev switch0 show

Also, did you refresh the LuCI page after installation?

yes, and restart router

Global attributes:
enable_vlan: 0
ports: 0x003f
Port 0:
pvid: 0
link: port:0 link:down
Port 1:
pvid: 0
link: port:1 link:up speed:100baseT full-duplex auto
Port 2:
pvid: 0
link: port:2 link:down
Port 3:
pvid: 0
link: port:3 link:down
Port 4:
pvid: 0
link: port:4 link:down
Port 5:
pvid: 0
link: port:5 link:up speed:100baseT full-duplex

#Only the wire between the computer and the router is connected

You should see the Switch Configuration in LuCI. It appears that the Switch is simply un-configured at this time.

can luci need a package for some kind of supply for the switches?

how configure him?

  • You browse in LuCI to: Network > Switch; or
  • you edit /etc/config/network

what is there to write?

You would you how you want to setup your device. And @kofec already showed you the manual:

You would need to configure LAN ports and a WAN, I assume?