DIR-2660 can't enter recovery mode

Hello, I am tring to flash OpenWrt to DIR-2660. I have enter the recovery mode once. I enter it on linux computer and upload the openwrt image. But later I didn't see “Device is upgrading the firmware” message. And disconnectted to After that, I can't enter recovery mode. When orange light is blinking, I can't even ping to But I can enter default dlink management interface. I have try restore factory settings, but still not work. Can anyone help me or give me some suggestion.

as far as I know Linux won't work
you will have to find a windows computer
but yes you should see the recovery mode page "just won't upload"

on the chance dlink has changed something backdate your firmwar
just upload an older version & try to turn off auto update
and have another go

Hello, but if I can't enter the recovery mode, is there any other way to upload the old version firmware?

Now I reinstall firmware to version 1.00. but still can't enter recovery mode. Do you know the possible reason? I see arp reply is strange.

seems like you did it already but I did mean the normal web interface in the normal firmware
the mac address is different in recovery mode so it seems you made it back in
do try to find a windows computer "no emulated wont work"

Thanks! Now I have successfully flashed openwrt.

what was the issue ?

I can't enter the recovery mode. But after reinstall firmware in the normal web interface and reset it, the issue was solved.


the same firmware it was already running, or did you downgrade ?