DHCPv6 seems not working properly with 19.07

@trendy

SLAAC is working I think. Because I can ping6 to Google.
Only DHCPv6 seems not working.

--
eiji

And what exactly is not working with DHCP6? The client is not getting an address or some other settings?
What is the content of cat /tmp/hosts/odhcpd ?

@trendy

/tmp/hosts/odhcpd is empty.

My client PC is not getting ipv6 address with prefix 2XXX.XXXX.XXXX.YYYY which I could get with 18.06.

What should I do to check next ?

--
eiji

If the host is not getting at all a Global address then SLAAC is not working either.
Post here the output of:

uci export network; uci export firewall; \
head -n -0 /etc/firewall.user; \
ip6tables-save -c; \
ip -6 addr ; ip -6 ro ls tab all ; ip -6 ru; \

Also capture some packets to see if the transaction is correct.
tcpdump -i eth0.1 -vn icmp6 or udp port 546
Let it run for 5-10 minutes to capture router advertisements and dhcp solicitation.

1 Like

@trendy

I have followed your instruction for both 18.06 and 19.07.
Here are the results.

18.06

root@OpenWrt:~# uci export network
package network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fddb:5435:878f::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.2.254'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'eth1'
	option proto 'static'
	option ipaddr '192.168.1.2'
	option netmask '255.255.255.0'
	option gateway '192.168.1.254'
	option broadcast '192.168.1.255'
	list dns '1.1.1.1'
	list dns '1.0.0.1'

config interface 'wan6'
	option ifname 'eth1'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 0t'

root@OpenWrt:~# uci export firewall
package firewall

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	list network 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config zone
	option name 'wan'
	list network 'wan'
	list network 'wan6'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config include
	option path '/etc/firewall.user'

root@OpenWrt:~# head -n -0 /etc/firewall.user
# This file is interpreted as shell script.
# Put your custom iptables rules here, they will
# be executed with each firewall (re-)start.

# Internal uci firewall chains are flushed and recreated on reload, so
# put custom rules into the root chains e.g. INPUT or FORWARD or into the
# special user chains, e.g. input_wan_rule or postrouting_lan_rule.
root@OpenWrt:~# ip6tables-save -c
# Generated by ip6tables-save v1.6.2 on Thu Mar 12 02:18:17 2020
*mangle
:PREROUTING ACCEPT [870:200725]
:INPUT ACCEPT [171:12196]
:FORWARD ACCEPT [598:174371]
:OUTPUT ACCEPT [190:15726]
:POSTROUTING ACCEPT [780:189418]
[9:720] -A FORWARD -o eth1 -p tcp -m tcp --tcp-flags SYN,RST SYN -m comment --comment "!fw3: Zone wan MTU fixing" -j TCPMSS --clamp-mss-to-pmtu
COMMIT
# Completed on Thu Mar 12 02:18:17 2020
# Generated by ip6tables-save v1.6.2 on Thu Mar 12 02:18:17 2020
*filter
:INPUT ACCEPT [0:0]
:FORWARD DROP [0:0]
:OUTPUT ACCEPT [0:0]
:forwarding_lan_rule - [0:0]
:forwarding_rule - [0:0]
:forwarding_wan_rule - [0:0]
:input_lan_rule - [0:0]
:input_rule - [0:0]
:input_wan_rule - [0:0]
:output_lan_rule - [0:0]
:output_rule - [0:0]
:output_wan_rule - [0:0]
:reject - [0:0]
:syn_flood - [0:0]
:zone_lan_dest_ACCEPT - [0:0]
:zone_lan_forward - [0:0]
:zone_lan_input - [0:0]
:zone_lan_output - [0:0]
:zone_lan_src_ACCEPT - [0:0]
:zone_wan_dest_ACCEPT - [0:0]
:zone_wan_dest_REJECT - [0:0]
:zone_wan_forward - [0:0]
:zone_wan_input - [0:0]
:zone_wan_output - [0:0]
:zone_wan_src_REJECT - [0:0]
[0:0] -A INPUT -i lo -m comment --comment "!fw3" -j ACCEPT
[171:12196] -A INPUT -m comment --comment "!fw3: Custom input rule chain" -j input_rule
[6:681] -A INPUT -m conntrack --ctstate RELATED,ESTABLISHED -m comment --comment "!fw3" -j ACCEPT
[0:0] -A INPUT -p tcp -m tcp --tcp-flags FIN,SYN,RST,ACK SYN -m comment --comment "!fw3" -j syn_flood
[66:4647] -A INPUT -i br-lan -m comment --comment "!fw3" -j zone_lan_input
[99:6868] -A INPUT -i eth1 -m comment --comment "!fw3" -j zone_wan_input
[598:174371] -A FORWARD -m comment --comment "!fw3: Custom forwarding rule chain" -j forwarding_rule
[573:158056] -A FORWARD -m conntrack --ctstate RELATED,ESTABLISHED -m comment --comment "!fw3" -j ACCEPT
[20:15816] -A FORWARD -i br-lan -m comment --comment "!fw3" -j zone_lan_forward
[5:499] -A FORWARD -i eth1 -m comment --comment "!fw3" -j zone_wan_forward
[5:499] -A FORWARD -m comment --comment "!fw3" -j reject
[0:0] -A OUTPUT -o lo -m comment --comment "!fw3" -j ACCEPT
[190:15726] -A OUTPUT -m comment --comment "!fw3: Custom output rule chain" -j output_rule
[8:1089] -A OUTPUT -m conntrack --ctstate RELATED,ESTABLISHED -m comment --comment "!fw3" -j ACCEPT
[73:6304] -A OUTPUT -o br-lan -m comment --comment "!fw3" -j zone_lan_output
[109:8333] -A OUTPUT -o eth1 -m comment --comment "!fw3" -j zone_wan_output
[5:499] -A reject -p tcp -m comment --comment "!fw3" -j REJECT --reject-with tcp-reset
[0:0] -A reject -m comment --comment "!fw3" -j REJECT --reject-with icmp6-port-unreachable
[0:0] -A syn_flood -p tcp -m tcp --tcp-flags FIN,SYN,RST,ACK SYN -m limit --limit 25/sec --limit-burst 50 -m comment --comment "!fw3" -j RETURN
[0:0] -A syn_flood -m comment --comment "!fw3" -j DROP
[73:6304] -A zone_lan_dest_ACCEPT -o br-lan -m comment --comment "!fw3" -j ACCEPT
[20:15816] -A zone_lan_forward -m comment --comment "!fw3: Custom lan forwarding rule chain" -j forwarding_lan_rule
[20:15816] -A zone_lan_forward -m comment --comment "!fw3: Zone lan to wan forwarding policy" -j zone_wan_dest_ACCEPT
[0:0] -A zone_lan_forward -m comment --comment "!fw3" -j zone_lan_dest_ACCEPT
[66:4647] -A zone_lan_input -m comment --comment "!fw3: Custom lan input rule chain" -j input_lan_rule
[66:4647] -A zone_lan_input -m comment --comment "!fw3" -j zone_lan_src_ACCEPT
[73:6304] -A zone_lan_output -m comment --comment "!fw3: Custom lan output rule chain" -j output_lan_rule
[73:6304] -A zone_lan_output -m comment --comment "!fw3" -j zone_lan_dest_ACCEPT
[66:4647] -A zone_lan_src_ACCEPT -i br-lan -m conntrack --ctstate NEW,UNTRACKED -m comment --comment "!fw3" -j ACCEPT
[3:180] -A zone_wan_dest_ACCEPT -o eth1 -m conntrack --ctstate INVALID -m comment --comment "!fw3: Prevent NAT leakage" -j DROP
[126:23969] -A zone_wan_dest_ACCEPT -o eth1 -m comment --comment "!fw3" -j ACCEPT
[0:0] -A zone_wan_dest_REJECT -o eth1 -m comment --comment "!fw3" -j reject
[5:499] -A zone_wan_forward -m comment --comment "!fw3: Custom wan forwarding rule chain" -j forwarding_wan_rule
[0:0] -A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 128 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
[0:0] -A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 129 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
[0:0] -A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 1 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
[0:0] -A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 2 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
[0:0] -A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 3 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
[0:0] -A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 4/0 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
[0:0] -A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 4/1 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
[0:0] -A zone_wan_forward -p esp -m comment --comment "!fw3: Allow-IPSec-ESP" -j zone_lan_dest_ACCEPT
[0:0] -A zone_wan_forward -p udp -m udp --dport 500 -m comment --comment "!fw3: Allow-ISAKMP" -j zone_lan_dest_ACCEPT
[5:499] -A zone_wan_forward -m comment --comment "!fw3" -j zone_wan_dest_REJECT
[99:6868] -A zone_wan_input -m comment --comment "!fw3: Custom wan input rule chain" -j input_wan_rule
[0:0] -A zone_wan_input -s fc00::/6 -d fc00::/6 -p udp -m udp --dport 546 -m comment --comment "!fw3: Allow-DHCPv6" -j ACCEPT
[11:836] -A zone_wan_input -s fe80::/10 -p ipv6-icmp -m icmp6 --icmpv6-type 130/0 -m comment --comment "!fw3: Allow-MLD" -j ACCEPT
[0:0] -A zone_wan_input -s fe80::/10 -p ipv6-icmp -m icmp6 --icmpv6-type 131/0 -m comment --comment "!fw3: Allow-MLD" -j ACCEPT
[0:0] -A zone_wan_input -s fe80::/10 -p ipv6-icmp -m icmp6 --icmpv6-type 132/0 -m comment --comment "!fw3: Allow-MLD" -j ACCEPT
[0:0] -A zone_wan_input -s fe80::/10 -p ipv6-icmp -m icmp6 --icmpv6-type 143/0 -m comment --comment "!fw3: Allow-MLD" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 128 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 129 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 1 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 2 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 3 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 4/0 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 4/1 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 133 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[45:3240] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 135 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[1:96] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 134 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[42:2696] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 136 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -m comment --comment "!fw3" -j zone_wan_src_REJECT
[109:8333] -A zone_wan_output -m comment --comment "!fw3: Custom wan output rule chain" -j output_wan_rule
[109:8333] -A zone_wan_output -m comment --comment "!fw3" -j zone_wan_dest_ACCEPT
[0:0] -A zone_wan_src_REJECT -i eth1 -m comment --comment "!fw3" -j reject
COMMIT
# Completed on Thu Mar 12 02:18:17 2020
root@OpenWrt:~# ip -6 addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::XXXX:XXXX:XXXX:XXXX/64 scope link 
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2XXX:XXXX:XXXX:XX00:XXXX:XXXX:XXXX:XXXX/64 scope global dynamic 
       valid_lft 14377sec preferred_lft 12577sec
    inet6 fe80::XXXX:XXXX:XXXX:XXXX/64 scope link 
       valid_lft forever preferred_lft forever
6: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2XXX:XXXX:XXXX:XX10::1/60 scope global dynamic 
       valid_lft 12990sec preferred_lft 12990sec
    inet6 fddb:5435:878f::1/60 scope global 
       valid_lft forever preferred_lft forever
    inet6 fe80::XXXX:XXXX:XXXX:XXXX/64 scope link 
       valid_lft forever preferred_lft forever
root@OpenWrt:~# ip -6 ro
default from 2XXX:XXXX:XXXX:XX00::/64 via fe80::XXXX:XXXX:XXXX:XXXX dev eth1  metric 512 
default from 2XXX:XXXX:XXXX:XX10::/60 via fe80::XXXX:XXXX:XXXX:XXXX dev eth1  metric 512 
2XXX:XXXX:XXXX:XX00::/64 dev eth1  metric 256 
2XXX:XXXX:XXXX:XX10::/64 dev br-lan  metric 1024 
unreachable 2XXX:XXXX:XXXX:XX10::/60 dev lo  metric 2147483647  error -148
fddb:5435:878f::/64 dev br-lan  metric 1024 
unreachable fddb:5435:878f::/48 dev lo  metric 2147483647  error -148
fe80::/64 dev eth0  metric 256 
fe80::/64 dev br-lan  metric 256 
fe80::/64 dev eth1  metric 256 
unreachable default dev lo  metric -1  error -128
ff00::/8 dev br-lan  metric 256 
ff00::/8 dev eth0  metric 256 
ff00::/8 dev eth1  metric 256 
unreachable default dev lo  metric -1  error -128
root@OpenWrt:~# ip -6 ru
0:	from all lookup local 
32766:	from all lookup main 
4200000000:	from 2XXX:XXXX:XXXX:XX10::1/60 iif br-lan lookup unspec unreachable
4200000001:	from all iif lo lookup unspec 12
4200000003:	from all iif eth1 lookup unspec 12
4200000003:	from all iif eth1 lookup unspec 12
4200000006:	from all iif br-lan lookup unspec 12
root@OpenWrt:~# cat /tmp/hosts/odhcpd
2XXX:XXXX:XXXX:XX10::2	io
fddb:5435:878f::2	io
# br-lan 00046f6d78530d9497fef9b5e0e6726f8521 5a8076d9 io -1 2 128 2XXX:XXXX:XXXX:XX10::2/128 fddb:5435:878f::2/128
root@OpenWrt:~# tcpdump -i eth0.1 -vn icmp6
tcpdump: listening on eth0.1, link-type EN10MB (Ethernet), capture size 262144 bytes
02:26:56.146954 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
          source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
02:26:56.148639 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
02:27:41.986969 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
          source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
02:27:41.987556 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
02:28:15.666964 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
          source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
02:28:15.668138 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
02:28:49.107004 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
          source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
02:28:49.110416 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
02:29:12.134460 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::XXXX:XXXX:XXXX:XXXX
          source link-address option (1), length 8 (1): 00:23:5a:80:76:d9
02:29:12.134642 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is fe80::XXXX:XXXX:XXXX:XXXX, Flags [router, solicited]
02:29:17.186974 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::b196:dccf:ba12:c837
          source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
02:29:17.187260 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is fe80::b196:dccf:ba12:c837, Flags [solicited]
02:29:18.547025 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
          source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
02:29:18.547706 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
02:29:57.106969 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
          source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
02:29:57.107557 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
02:30:42.146969 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
          source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
02:30:42.147566 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
^C
18 packets captured
20 packets received by filter
0 packets dropped by kernel
root@OpenWrt:~# 

I wanted to attach 19.07 also, but seems too big. so I will post 19.07 result on next post.

--
eiji

@trendy

Here is the result from 19.07.

root@OpenWrt:~# uci export network
package network

config interface 'loopback'
   option ifname 'lo'
   option proto 'static'
   option ipaddr '127.0.0.1'
   option netmask '255.0.0.0'

config globals 'globals'
   option ula_prefix 'fddb:5435:878f::/48'

config interface 'lan'
   option type 'bridge'
   option ifname 'eth0.1'
   option proto 'static'
   option ipaddr '192.168.2.254'
   option netmask '255.255.255.0'
   option ip6assign '60'

config interface 'wan'
   option ifname 'eth1'
   option proto 'static'
   option ipaddr '192.168.1.2'
   option netmask '255.255.255.0'
   option gateway '192.168.1.254'
   option broadcast '192.168.1.255'
   list dns '1.1.1.1'
   list dns '1.0.0.1'

config interface 'wan6'
   option ifname 'eth1'
   option proto 'dhcpv6'

config switch
   option name 'switch0'
   option reset '1'
   option enable_vlan '1'

config switch_vlan
   option device 'switch0'
   option vlan '1'
   option ports '1 2 3 4 0t'

root@OpenWrt:~# uci export firewall
package firewall

config defaults
   option syn_flood '1'
   option input 'ACCEPT'
   option output 'ACCEPT'
   option forward 'REJECT'

config zone
   option name 'lan'
   list network 'lan'
   option input 'ACCEPT'
   option output 'ACCEPT'
   option forward 'ACCEPT'

config zone
   option name 'wan'
   list network 'wan'
   list network 'wan6'
   option input 'REJECT'
   option output 'ACCEPT'
   option forward 'REJECT'
   option masq '1'
   option mtu_fix '1'

config forwarding
   option src 'lan'
   option dest 'wan'

config rule
   option name 'Allow-DHCP-Renew'
   option src 'wan'
   option proto 'udp'
   option dest_port '68'
   option target 'ACCEPT'
   option family 'ipv4'

config rule
   option name 'Allow-Ping'
   option src 'wan'
   option proto 'icmp'
   option icmp_type 'echo-request'
   option family 'ipv4'
   option target 'ACCEPT'

config rule
   option name 'Allow-IGMP'
   option src 'wan'
   option proto 'igmp'
   option family 'ipv4'
   option target 'ACCEPT'

config rule
   option name 'Allow-DHCPv6'
   option src 'wan'
   option proto 'udp'
   option src_ip 'fc00::/6'
   option dest_ip 'fc00::/6'
   option dest_port '546'
   option family 'ipv6'
   option target 'ACCEPT'

config rule
   option name 'Allow-MLD'
   option src 'wan'
   option proto 'icmp'
   option src_ip 'fe80::/10'
   list icmp_type '130/0'
   list icmp_type '131/0'
   list icmp_type '132/0'
   list icmp_type '143/0'
   option family 'ipv6'
   option target 'ACCEPT'

config rule
   option name 'Allow-ICMPv6-Input'
   option src 'wan'
   option proto 'icmp'
   list icmp_type 'echo-request'
   list icmp_type 'echo-reply'
   list icmp_type 'destination-unreachable'
   list icmp_type 'packet-too-big'
   list icmp_type 'time-exceeded'
   list icmp_type 'bad-header'
   list icmp_type 'unknown-header-type'
   list icmp_type 'router-solicitation'
   list icmp_type 'neighbour-solicitation'
   list icmp_type 'router-advertisement'
   list icmp_type 'neighbour-advertisement'
   option limit '1000/sec'
   option family 'ipv6'
   option target 'ACCEPT'

config rule
   option name 'Allow-ICMPv6-Forward'
   option src 'wan'
   option dest '*'
   option proto 'icmp'
   list icmp_type 'echo-request'
   list icmp_type 'echo-reply'
   list icmp_type 'destination-unreachable'
   list icmp_type 'packet-too-big'
   list icmp_type 'time-exceeded'
   list icmp_type 'bad-header'
   list icmp_type 'unknown-header-type'
   option limit '1000/sec'
   option family 'ipv6'
   option target 'ACCEPT'

config rule
   option name 'Allow-IPSec-ESP'
   option src 'wan'
   option dest 'lan'
   option proto 'esp'
   option target 'ACCEPT'

config rule
   option name 'Allow-ISAKMP'
   option src 'wan'
   option dest 'lan'
   option dest_port '500'
   option proto 'udp'
   option target 'ACCEPT'

config include
   option path '/etc/firewall.user'

root@OpenWrt:~# head -n -0 /etc/firewall.user
# This file is interpreted as shell script.
# Put your custom iptables rules here, they will
# be executed with each firewall (re-)start.

# Internal uci firewall chains are flushed and recreated on reload, so
# put custom rules into the root chains e.g. INPUT or FORWARD or into the
# special user chains, e.g. input_wan_rule or postrouting_lan_rule.
root@OpenWrt:~# ip6tables-save -c
# Generated by ip6tables-save v1.8.3 on Thu Mar 12 00:28:58 2020
*mangle
:PREROUTING ACCEPT [56885:27069601]
:INPUT ACCEPT [5086:386944]
:FORWARD ACCEPT [46101:25798657]
:OUTPUT ACCEPT [5750:713810]
:POSTROUTING ACCEPT [51839:26511471]
[327:26088] -A FORWARD -o eth1 -p tcp -m tcp --tcp-flags SYN,RST SYN -m comment --comment "!fw3: Zone wan MTU fixing" -j TCPMSS --clamp-mss-to-pmtu
COMMIT
# Completed on Thu Mar 12 00:28:58 2020
# Generated by ip6tables-save v1.8.3 on Thu Mar 12 00:28:58 2020
*filter
:INPUT ACCEPT [0:0]
:FORWARD DROP [0:0]
:OUTPUT ACCEPT [0:0]
:forwarding_lan_rule - [0:0]
:forwarding_rule - [0:0]
:forwarding_wan_rule - [0:0]
:input_lan_rule - [0:0]
:input_rule - [0:0]
:input_wan_rule - [0:0]
:output_lan_rule - [0:0]
:output_rule - [0:0]
:output_wan_rule - [0:0]
:reject - [0:0]
:syn_flood - [0:0]
:zone_lan_dest_ACCEPT - [0:0]
:zone_lan_forward - [0:0]
:zone_lan_input - [0:0]
:zone_lan_output - [0:0]
:zone_lan_src_ACCEPT - [0:0]
:zone_wan_dest_ACCEPT - [0:0]
:zone_wan_dest_REJECT - [0:0]
:zone_wan_forward - [0:0]
:zone_wan_input - [0:0]
:zone_wan_output - [0:0]
:zone_wan_src_REJECT - [0:0]
[0:0] -A INPUT -i lo -m comment --comment "!fw3" -j ACCEPT
[5086:386944] -A INPUT -m comment --comment "!fw3: Custom input rule chain" -j input_rule
[131:14646] -A INPUT -m conntrack --ctstate RELATED,ESTABLISHED -m comment --comment "!fw3" -j ACCEPT
[0:0] -A INPUT -p tcp -m tcp --tcp-flags FIN,SYN,RST,ACK SYN -m comment --comment "!fw3" -j syn_flood
[763:51356] -A INPUT -i br-lan -m comment --comment "!fw3" -j zone_lan_input
[4192:320942] -A INPUT -i eth1 -m comment --comment "!fw3" -j zone_wan_input
[46101:25798657] -A FORWARD -m comment --comment "!fw3: Custom forwarding rule chain" -j forwarding_rule
[45747:25770025] -A FORWARD -m conntrack --ctstate RELATED,ESTABLISHED -m comment --comment "!fw3" -j ACCEPT
[351:28248] -A FORWARD -i br-lan -m comment --comment "!fw3" -j zone_lan_forward
[3:384] -A FORWARD -i eth1 -m comment --comment "!fw3" -j zone_wan_forward
[3:384] -A FORWARD -m comment --comment "!fw3" -j reject
[0:0] -A OUTPUT -o lo -m comment --comment "!fw3" -j ACCEPT
[5750:713810] -A OUTPUT -m comment --comment "!fw3: Custom output rule chain" -j output_rule
[183:27321] -A OUTPUT -m conntrack --ctstate RELATED,ESTABLISHED -m comment --comment "!fw3" -j ACCEPT
[1521:226224] -A OUTPUT -o br-lan -m comment --comment "!fw3" -j zone_lan_output
[4046:460265] -A OUTPUT -o eth1 -m comment --comment "!fw3" -j zone_wan_output
[3:384] -A reject -p tcp -m comment --comment "!fw3" -j REJECT --reject-with tcp-reset
[0:0] -A reject -m comment --comment "!fw3" -j REJECT --reject-with icmp6-port-unreachable
[0:0] -A syn_flood -p tcp -m tcp --tcp-flags FIN,SYN,RST,ACK SYN -m limit --limit 25/sec --limit-burst 50 -m comment --comment "!fw3" -j RETURN
[0:0] -A syn_flood -m comment --comment "!fw3" -j DROP
[1521:226224] -A zone_lan_dest_ACCEPT -o br-lan -m comment --comment "!fw3" -j ACCEPT
[351:28248] -A zone_lan_forward -m comment --comment "!fw3: Custom lan forwarding rule chain" -j forwarding_lan_rule
[351:28248] -A zone_lan_forward -m comment --comment "!fw3: Zone lan to wan forwarding policy" -j zone_wan_dest_ACCEPT
[0:0] -A zone_lan_forward -m comment --comment "!fw3" -j zone_lan_dest_ACCEPT
[763:51356] -A zone_lan_input -m comment --comment "!fw3: Custom lan input rule chain" -j input_lan_rule
[763:51356] -A zone_lan_input -m comment --comment "!fw3" -j zone_lan_src_ACCEPT
[1521:226224] -A zone_lan_output -m comment --comment "!fw3: Custom lan output rule chain" -j output_lan_rule
[1521:226224] -A zone_lan_output -m comment --comment "!fw3" -j zone_lan_dest_ACCEPT
[763:51356] -A zone_lan_src_ACCEPT -i br-lan -m conntrack --ctstate NEW,UNTRACKED -m comment --comment "!fw3" -j ACCEPT
[9:612] -A zone_wan_dest_ACCEPT -o eth1 -m conntrack --ctstate INVALID -m comment --comment "!fw3: Prevent NAT leakage" -j DROP
[4388:487901] -A zone_wan_dest_ACCEPT -o eth1 -m comment --comment "!fw3" -j ACCEPT
[0:0] -A zone_wan_dest_REJECT -o eth1 -m comment --comment "!fw3" -j reject
[3:384] -A zone_wan_forward -m comment --comment "!fw3: Custom wan forwarding rule chain" -j forwarding_wan_rule
[0:0] -A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 128 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
[0:0] -A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 129 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
[0:0] -A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 1 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
[0:0] -A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 2 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
[0:0] -A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 3 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
[0:0] -A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 4/0 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
[0:0] -A zone_wan_forward -p ipv6-icmp -m icmp6 --icmpv6-type 4/1 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Forward" -j ACCEPT
[0:0] -A zone_wan_forward -p esp -m comment --comment "!fw3: Allow-IPSec-ESP" -j zone_lan_dest_ACCEPT
[0:0] -A zone_wan_forward -p udp -m udp --dport 500 -m comment --comment "!fw3: Allow-ISAKMP" -j zone_lan_dest_ACCEPT
[3:384] -A zone_wan_forward -m comment --comment "!fw3" -j zone_wan_dest_REJECT
[4192:320942] -A zone_wan_input -m comment --comment "!fw3: Custom wan input rule chain" -j input_wan_rule
[45:10350] -A zone_wan_input -s fc00::/6 -d fc00::/6 -p udp -m udp --dport 546 -m comment --comment "!fw3: Allow-DHCPv6" -j ACCEPT
[2610:198360] -A zone_wan_input -s fe80::/10 -p ipv6-icmp -m icmp6 --icmpv6-type 130/0 -m comment --comment "!fw3: Allow-MLD" -j ACCEPT
[0:0] -A zone_wan_input -s fe80::/10 -p ipv6-icmp -m icmp6 --icmpv6-type 131/0 -m comment --comment "!fw3: Allow-MLD" -j ACCEPT
[0:0] -A zone_wan_input -s fe80::/10 -p ipv6-icmp -m icmp6 --icmpv6-type 132/0 -m comment --comment "!fw3: Allow-MLD" -j ACCEPT
[0:0] -A zone_wan_input -s fe80::/10 -p ipv6-icmp -m icmp6 --icmpv6-type 143/0 -m comment --comment "!fw3: Allow-MLD" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 128 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 129 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 1 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 2 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 3 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 4/0 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 4/1 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 133 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[608:43776] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 135 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[281:26976] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 134 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[648:41480] -A zone_wan_input -p ipv6-icmp -m icmp6 --icmpv6-type 136 -m limit --limit 1000/sec -m comment --comment "!fw3: Allow-ICMPv6-Input" -j ACCEPT
[0:0] -A zone_wan_input -m comment --comment "!fw3" -j zone_wan_src_REJECT
[4046:460265] -A zone_wan_output -m comment --comment "!fw3: Custom wan output rule chain" -j output_wan_rule
[4046:460265] -A zone_wan_output -m comment --comment "!fw3" -j zone_wan_dest_ACCEPT
[0:0] -A zone_wan_src_REJECT -i eth1 -m comment --comment "!fw3" -j reject
COMMIT
# Completed on Thu Mar 12 00:28:58 2020
root@OpenWrt:~# ip -6 addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
   inet6 ::1/128 scope host 
      valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
   inet6 fe80::XXXX:XXXX:XXXX:XXXX/64 scope link 
      valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
   inet6 2XXX:XXXX:XXXX:XX00:XXXX:XXXX:XXXX:XXXX/64 scope global dynamic 
      valid_lft 13419sec preferred_lft 11619sec
   inet6 fe80::XXXX:XXXX:XXXX:XXXX/64 scope link 
      valid_lft forever preferred_lft forever
6: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
   inet6 2XXX:XXXX:XXXX:XX10::1/60 scope global dynamic 
      valid_lft 12157sec preferred_lft 12157sec
   inet6 fddb:5435:878f::1/60 scope global 
      valid_lft forever preferred_lft forever
   inet6 fe80::XXXX:XXXX:XXXX:XXXX/64 scope link 
      valid_lft forever preferred_lft forever
root@OpenWrt:~# ip -6 ro
default from 2XXX:XXXX:XXXX:XX00::/64 via fe80::XXXX:XXXX:XXXX:XXXX dev eth1  metric 512 
default from 2XXX:XXXX:XXXX:XX10::/60 via fe80::XXXX:XXXX:XXXX:XXXX dev eth1  metric 512 
2XXX:XXXX:XXXX:XX00::/64 dev eth1  metric 256 
2XXX:XXXX:XXXX:XX10::/64 dev br-lan  metric 1024 
unreachable 2XXX:XXXX:XXXX:XX10::/60 dev lo  metric 2147483647  error -148
fddb:5435:878f::/64 dev br-lan  metric 1024 
unreachable fddb:5435:878f::/48 dev lo  metric 2147483647  error -148
fe80::/64 dev eth0  metric 256 
fe80::/64 dev br-lan  metric 256 
fe80::/64 dev eth1  metric 256 
anycast 2XXX:XXXX:XXXX:XX00:: dev eth1  metric 0 
anycast 2XXX:XXXX:XXXX:XX10:: dev br-lan  metric 0 
anycast fddb:5435:878f:: dev br-lan  metric 0 
anycast fe80:: dev eth0  metric 0 
anycast fe80:: dev br-lan  metric 0 
anycast fe80:: dev eth1  metric 0 
ff00::/8 dev br-lan  metric 256 
ff00::/8 dev eth0  metric 256 
ff00::/8 dev eth1  metric 256 
root@OpenWrt:~# ip -6 ru
0:	from all lookup local 
32766:	from all lookup main 
4200000000:	from 2XXX:XXXX:XXXX:XX10::1/60 iif br-lan lookup unspec unreachable
4200000001:	from all iif lo lookup unspec 12 4200000003:	from all iif eth1 lookup unspec 12 4200000003:	from all iif eth1 lookup unspec 12 4200000006:	from all iif br-lan lookup unspec 12 
root@OpenWrt:~# tcpdump -i eth0.1 -vn icmp6 tcpdump: listening on eth0.1, link-type EN10MB (Ethernet), capture size 262144 bytes 00:42:14.181386 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
         source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
00:42:14.181939 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
00:43:03.621388 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
         source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
00:43:03.622009 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
00:43:08.980929 IP6 (flowlabel 0x76eee, hlim 255, next-header ICMPv6 (58) payload length: 176) fe80::XXXX:XXXX:XXXX:XXXX > ff02::1: [icmp6 sum ok] ICMP6, router advertisement, length 176
       hop limit 64, Flags [managed, other stateful], pref medium, router lifetime 1800s, reachable time 0ms, retrans timer 0ms
         source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
         mtu option (5), length 8 (1):  1500
         prefix info option (3), length 32 (4): 2XXX:XXXX:XXXX:XX10::/64, Flags [onlink, auto], valid time 11429s, pref. time 11429s
         prefix info option (3), length 32 (4): fddb:5435:878f::/64, Flags [onlink, auto], valid time infinity, pref. time infinity
         route info option (24), length 24 (3):  2XXX:XXXX:XXXX:XX10::/60, pref=medium, lifetime=1800s
         route info option (24), length 24 (3):  fddb:5435:878f::/48, pref=medium, lifetime=1800s
         rdnss option (25), length 24 (3):  lifetime 1800s, addr: fddb:5435:878f::1
         advertisement interval option (7), length 8 (1):  600ms
00:43:50.181393 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
         source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
00:43:50.182616 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
00:44:37.061387 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
         source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
00:44:37.062004 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
00:45:11.861385 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
         source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
00:45:11.862010 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]

^C
11 packets captured
11 packets received by filter

I can't run "ip -6 ro ls tab all", instead, I did "ip -6 ro".
Did I do something wrong ?

--
eiji

I don't know, it works fine on mine. Try ip -6 route list table all , although it shouldn't matter.
In the tcpdump you didn't enter the whole command and didn't capture the dhcp6.
Other than that I don't see any problem, there is one router advertisement in 19.07, I suppose the addresses are correct, and neighbour solicitations get their advertisement replies, I hope they are also correct.
So the client is acquiring the SLAAC address only and not the DHCP6 one?

@trendy

I will check "ip -6 route list table all" tomorrow, but I'm using the same client to connect openwrt 18.06 and 19.07. so I don't think client is acquiring only SLAAC.

Do I have to do tcpdump much more longer time ?

--
eiji

Not necessarily, just run it and connect one device on the router to initiate the dhcp process.
The problem is that you did not run the whole tcpdump command and it wasn't capturing DHCP6 packets.

@trendy

Sorry I didn't follow your instruction exactly. I will do it again and share the result asap.

--
eiji

1 Like

@trendy

I have run tcpdump and ip -6 route again for both 18.06 and 19.07. and also captured the client pc ip addr information. I wanted to attach both log in one post, but seems too large. so I will post it separately.

openwrt 18.06

root@OpenWrt:~# cat /etc/os-release
NAME="OpenWrt"
VERSION="18.06.7"
ID="openwrt"
ID_LIKE="lede openwrt"
PRETTY_NAME="OpenWrt 18.06.7"
VERSION_ID="18.06.7"
HOME_URL="http://openwrt.org/"
BUG_URL="http://bugs.openwrt.org/"
SUPPORT_URL="http://forum.lede-project.org/"
BUILD_ID="r7976-ca47026b7d"
LEDE_BOARD="ar71xx/generic"
LEDE_ARCH="mips_24kc"
LEDE_TAINTS=""
LEDE_DEVICE_MANUFACTURER="OpenWrt"
LEDE_DEVICE_MANUFACTURER_URL="http://openwrt.org/"
LEDE_DEVICE_PRODUCT="Generic"
LEDE_DEVICE_REVISION="v0"
LEDE_RELEASE="OpenWrt 18.06.7 r7976-ca47026b7d"
root@OpenWrt: ~aroot@OpenWrt:~# ip -6 route list table all
default from 2XXX:XXXX:XXXX:XX00::/64 via fe80::XXXX:XXXX:XXXX:XXXX dev eth1  metric 512 
default from 2XXX:XXXX:XXXX:XX10::/60 via fe80::XXXX:XXXX:XXXX:XXXX dev eth1  metric 512 
2XXX:XXXX:XXXX:XX00::/64 dev eth1  metric 256 
2XXX:XXXX:XXXX:XX10::/64 dev br-lan  metric 1024 
unreachable 2XXX:XXXX:XXXX:XX10::/60 dev lo  metric 2147483647  error -148
fddb:5435:878f::/64 dev br-lan  metric 1024 
unreachable fddb:5435:878f::/48 dev lo  metric 2147483647  error -148
fe80::/64 dev eth0  metric 256 
fe80::/64 dev br-lan  metric 256 
fe80::/64 dev eth1  metric 256 
unreachable default dev lo  metric -1  error -128
local ::1 dev lo table local  metric 0 
local 2XXX:XXXX:XXXX:XX00:: dev lo table local  metric 0 
local 2XXX:XXXX:XXXX:XX00:XXXX:XXXX:XXXX:XXXX dev lo table local  metric 0 
local 2XXX:XXXX:XXXX:XX10:: dev lo table local  metric 0 
local 2XXX:XXXX:XXXX:XX10::1 dev lo table local  metric 0 
local fddb:5435:878f:: dev lo table local  metric 0 
local fddb:5435:878f::1 dev lo table local  metric 0 
local fe80:: dev lo table local  metric 0 
local fe80:: dev lo table local  metric 0 
local fe80:: dev lo table local  metric 0 
local fe80::XXXX:XXXX:XXXX:XXXX dev lo table local  metric 0 
local fe80::XXXX:XXXX:XXXX:XXXX dev lo table local  metric 0 
local fe80::XXXX:XXXX:XXXX:XXXX dev lo table local  metric 0 
ff00::/8 dev br-lan table local  metric 256 
ff00::/8 dev eth0 table local  metric 256 
ff00::/8 dev eth1 table local  metric 256 
unreachable default dev lo  metric -1  error -128
root@OpenWrt:~# tcpdump -i eth0.1 -vn icmp6
tcpdump: listening on eth0.1, link-type EN10MB (Ethernet), capture size 262144 bytes
10:17:09.781667 IP6 (flowlabel 0xaa53c, hlim 255, next-header ICMPv6 (58) payload length: 176) fe80::XXXX:XXXX:XXXX:XXXX > ff02::1: [icmp6 sum ok] ICMP6, router advertisement, length 176
	hop limit 64, Flags [managed, other stateful], pref medium, router lifetime 1800s, reachable time 0ms, retrans timer 0ms
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
	  mtu option (5), length 8 (1):  1500
	  prefix info option (3), length 32 (4): 2XXX:XXXX:XXXX:XX10::/64, Flags [onlink, auto], valid time 13137s, pref. time 13137s
	  prefix info option (3), length 32 (4): fddb:5435:878f::/64, Flags [onlink, auto], valid time infinity, pref. time infinity
	  route info option (24), length 24 (3):  2XXX:XXXX:XXXX:XX10::/60, pref=medium, lifetime=13137s
	  route info option (24), length 24 (3):  fddb:5435:878f::/48, pref=medium, lifetime=infinity
	  rdnss option (25), length 24 (3):  lifetime 6000s, addr: fddb:5435:878f::1
	  advertisement interval option (7), length 8 (1):  600000ms
10:17:22.866967 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:17:22.868282 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:18:03.586973 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:18:03.588251 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:18:41.347032 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:18:41.347706 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:19:22.467028 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:19:22.467658 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:19:58.466972 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:19:58.468242 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:20:33.346974 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:20:33.348235 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:21:18.547048 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:21:18.548443 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:22:09.427034 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:22:09.427502 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:22:54.706969 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:22:54.707553 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:23:39.747048 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:23:39.748388 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:23:46.402838 IP6 (flowlabel 0xaa53c, hlim 255, next-header ICMPv6 (58) payload length: 176) fe80::XXXX:XXXX:XXXX:XXXX > ff02::1: [icmp6 sum ok] ICMP6, router advertisement, length 176
	hop limit 64, Flags [managed, other stateful], pref medium, router lifetime 1800s, reachable time 0ms, retrans timer 0ms
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
	  mtu option (5), length 8 (1):  1500
	  prefix info option (3), length 32 (4): 2XXX:XXXX:XXXX:XX10::/64, Flags [onlink, auto], valid time 12740s, pref. time 12740s
	  prefix info option (3), length 32 (4): fddb:5435:878f::/64, Flags [onlink, auto], valid time infinity, pref. time infinity
	  route info option (24), length 24 (3):  2XXX:XXXX:XXXX:XX10::/60, pref=medium, lifetime=12740s
	  route info option (24), length 24 (3):  fddb:5435:878f::/48, pref=medium, lifetime=infinity
	  rdnss option (25), length 24 (3):  lifetime 6000s, addr: fddb:5435:878f::1
	  advertisement interval option (7), length 8 (1):  600000ms
10:24:39.106991 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:24:39.108293 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:25:24.067049 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:25:24.067730 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:26:16.787046 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:26:16.788062 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:27:07.667111 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:27:07.667971 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:27:58.306971 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:27:58.308307 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:28:18.449537 IP6 (flowlabel 0xaa53c, hlim 255, next-header ICMPv6 (58) payload length: 176) fe80::XXXX:XXXX:XXXX:XXXX > ff02::1: [icmp6 sum ok] ICMP6, router advertisement, length 176
	hop limit 64, Flags [managed, other stateful], pref medium, router lifetime 1800s, reachable time 0ms, retrans timer 0ms
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
	  mtu option (5), length 8 (1):  1500
	  prefix info option (3), length 32 (4): 2XXX:XXXX:XXXX:XX10::/64, Flags [onlink, auto], valid time 12468s, pref. time 12468s
	  prefix info option (3), length 32 (4): fddb:5435:878f::/64, Flags [onlink, auto], valid time infinity, pref. time infinity
	  route info option (24), length 24 (3):  2XXX:XXXX:XXXX:XX10::/60, pref=medium, lifetime=12468s
	  route info option (24), length 24 (3):  fddb:5435:878f::/48, pref=medium, lifetime=infinity
	  rdnss option (25), length 24 (3):  lifetime 6000s, addr: fddb:5435:878f::1
	  advertisement interval option (7), length 8 (1):  600000ms
10:28:44.866963 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:28:44.867554 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
^C
35 packets captured
35 packets received by filter
0 packets dropped by kernel

client pc information with 18.06

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fddb:5435:878f::2/128 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 2XXX:XXXX:XXXX:XXXX::2/128 scope global dynamic noprefixroute 
       valid_lft 12362sec preferred_lft 12362sec
    inet6 fddb:5435:878f:0:18a8:d857:547b:9add/64 scope global temporary dynamic 
       valid_lft 603458sec preferred_lft 85009sec
    inet6 fddb:5435:878f:0:c59f:c65e:c43c:b819/64 scope global mngtmpaddr noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 2XXX:XXXX:XXXX:XXXX:18a8:d857:547b:9add/64 scope global temporary dynamic 
       valid_lft 12362sec preferred_lft 12362sec
    inet6 2XXX:XXXX:XXXX:XXXX:c75d:1064:6af4:56a8/64 scope global dynamic mngtmpaddr noprefixroute 
       valid_lft 12362sec preferred_lft 12362sec
    inet6 fe80::b196:dccf:ba12:c837/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

Sorry for late reply, let me know if additional information is necessary.

--
eiji

@trendy

Here is the result from 19.07.

openwrt 19.07

root@OpenWrt:~# cat /etc/os-release
NAME="OpenWrt"
VERSION="19.07.2"
ID="openwrt"
ID_LIKE="lede openwrt"
PRETTY_NAME="OpenWrt 19.07.2"
VERSION_ID="19.07.2"
HOME_URL="https://openwrt.org/"
BUG_URL="https://bugs.openwrt.org/"
SUPPORT_URL="https://forum.openwrt.org/"
BUILD_ID="r10947-65030d81f3"
OPENWRT_BOARD="ar71xx/generic"
OPENWRT_ARCH="mips_24kc"
OPENWRT_TAINTS=""
OPENWRT_DEVICE_MANUFACTURER="OpenWrt"
OPENWRT_DEVICE_MANUFACTURER_URL="https://openwrt.org/"
OPENWRT_DEVICE_PRODUCT="Generic"
OPENWRT_DEVICE_REVISION="v0"
OPENWRT_RELEASE="OpenWrt 19.07.2 r10947-65030d81f3"
root@OpenWrt: ~aroot@OpenWrt:~# ip -6 route list table all
default from 2XXX:XXXX:XXXX:XXXX::/64 via fe80::XXXX:XXXX:XXXX:XXXX dev eth1  metric 512 
default from 2XXX:XXXX:XXXX:XXXX::/60 via fe80::XXXX:XXXX:XXXX:XXXX dev eth1  metric 512 
2XXX:XXXX:XXXX:XXXX::/64 dev eth1  metric 256 
2XXX:XXXX:XXXX:XXXX::/64 dev br-lan  metric 1024 
unreachable 2XXX:XXXX:XXXX:XXXX::/60 dev lo  metric 2147483647  error -148
fddb:5435:878f::/64 dev br-lan  metric 1024 
unreachable fddb:5435:878f::/48 dev lo  metric 2147483647  error -148
fe80::/64 dev eth0  metric 256 
fe80::/64 dev br-lan  metric 256 
fe80::/64 dev eth1  metric 256 
local ::1 dev lo table local  metric 0 
anycast 2XXX:XXXX:XXXX:XXXX:: dev eth1 table local  metric 0 
local 2XXX:XXXX:XXXX:XXXX:224:a5ff:feef:e8a8 dev eth1 table local  metric 0 
anycast 2XXX:XXXX:XXXX:XXXX:: dev br-lan table local  metric 0 
local 2XXX:XXXX:XXXX:XXXX::1 dev br-lan table local  metric 0 
anycast fddb:5435:878f:: dev br-lan table local  metric 0 
local fddb:5435:878f::1 dev br-lan table local  metric 0 
anycast fe80:: dev eth0 table local  metric 0 
anycast fe80:: dev br-lan table local  metric 0 
anycast fe80:: dev eth1 table local  metric 0 
local fe80::XXXX:XXXX:XXXX:XXXX dev eth0 table local  metric 0 
local fe80::XXXX:XXXX:XXXX:XXXX dev br-lan table local  metric 0 
local fe80::224:a5ff:feef:e8a8 dev eth1 table local  metric 0 
ff00::/8 dev br-lan table local  metric 256 
ff00::/8 dev eth0 table local  metric 256 
ff00::/8 dev eth1 table local  metric 256 
root@OpenWrt: ~aroot@OpenWrt:~# tcpdump -i eth0.1 -vn icmp6
tcpdump: listening on eth0.1, link-type EN10MB (Ethernet), capture size 262144 bytes
10:45:46.215095 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:45:46.216672 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:45:46.297696 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:23:5a:80:76:d9
10:45:46.297891 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is fe80::XXXX:XXXX:XXXX:XXXX, Flags [router, solicited]
10:45:51.335086 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:45:51.336093 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is fe80::XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:46:31.255091 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:46:31.256491 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:46:36.473221 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:23:5a:80:76:d9
10:46:36.473412 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is fe80::XXXX:XXXX:XXXX:XXXX, Flags [router, solicited]
10:46:41.495092 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:46:41.496108 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is fe80::XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:47:16.375080 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:47:16.376403 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:47:56.125650 IP6 (flowlabel 0xf5a7a, hlim 255, next-header ICMPv6 (58) payload length: 176) fe80::XXXX:XXXX:XXXX:XXXX > ff02::1: [icmp6 sum ok] ICMP6, router advertisement, length 176
	hop limit 64, Flags [managed, other stateful], pref medium, router lifetime 1800s, reachable time 0ms, retrans timer 0ms
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
	  mtu option (5), length 8 (1):  1500
	  prefix info option (3), length 32 (4): 2XXX:XXXX:XXXX:XXXX::/64, Flags [onlink, auto], valid time 13643s, pref. time 13643s
	  prefix info option (3), length 32 (4): fddb:5435:878f::/64, Flags [onlink, auto], valid time infinity, pref. time infinity
	  route info option (24), length 24 (3):  2XXX:XXXX:XXXX:XXXX::/60, pref=medium, lifetime=1800s
	  route info option (24), length 24 (3):  fddb:5435:878f::/48, pref=medium, lifetime=1800s
	  rdnss option (25), length 24 (3):  lifetime 1800s, addr: fddb:5435:878f::1
	  advertisement interval option (7), length 8 (1):  600ms
10:48:01.415094 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:48:01.416494 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:48:01.461110 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:23:5a:80:76:d9
10:48:01.461303 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is fe80::XXXX:XXXX:XXXX:XXXX, Flags [router, solicited]
10:48:06.535090 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:48:06.536101 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is fe80::XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:48:38.498430 IP6 (flowlabel 0x2390a, hlim 64, next-header ICMPv6 (58) payload length: 95) fddb:5435:878f::1 > fddb:5435:878f:0:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, destination unreachable, unknown unreach code (5)
	0x0000:  0105 5a3e 0000 0000 6005 f623 002f 1140
	0x0010:  fddb 5435 878f 0000 201e f3db 8719 ee74
	0x0020:  fd7a 3617 3035 0000 0000 0000 0000 0001
	0x0030:  dcb4 0035 002f 2f8e 6add 0100 0001 0000
	0x0040:  0000 0000 0675 7064 6174 650a 676f 6f67
	0x0050:  6c65 6170 6973 0363 6f6d 0000 0100 01
10:48:38.500025 IP6 (flowlabel 0x2390a, hlim 64, next-header ICMPv6 (58) payload length: 95) fddb:5435:878f::1 > fddb:5435:878f:0:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, destination unreachable, unknown unreach code (5)
	0x0000:  0105 5a3e 0000 0000 6005 f623 002f 1140
	0x0010:  fddb 5435 878f 0000 201e f3db 8719 ee74
	0x0020:  fd7a 3617 3035 0000 0000 0000 0000 0001
	0x0030:  dcb4 0035 002f fa6b 84ff 0100 0001 0000
	0x0040:  0000 0000 0675 7064 6174 650a 676f 6f67
	0x0050:  6c65 6170 6973 0363 6f6d 0000 1c00 01
10:48:43.575090 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:48:43.575290 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > fddb:5435:878f:0:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fddb:5435:878f:0:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:48:43.577456 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:48:43.577622 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) fddb:5435:878f:0:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is fddb:5435:878f:0:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:49:18.935082 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:49:18.936397 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:49:29.524902 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:23:5a:80:76:d9
10:49:29.525129 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is fe80::XXXX:XXXX:XXXX:XXXX, Flags [router, solicited]
10:49:34.535095 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:49:34.536107 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is fe80::XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:50:14.535090 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:50:14.536483 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:50:19.704632 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:23:5a:80:76:d9
10:50:19.704836 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is fe80::XXXX:XXXX:XXXX:XXXX, Flags [router, solicited]
10:50:24.775101 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:50:24.776114 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is fe80::XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:50:59.575090 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:50:59.576499 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:51:10.305826 IP6 (flowlabel 0xf5a7a, hlim 255, next-header ICMPv6 (58) payload length: 176) fe80::XXXX:XXXX:XXXX:XXXX > ff02::1: [icmp6 sum ok] ICMP6, router advertisement, length 176
	hop limit 64, Flags [managed, other stateful], pref medium, router lifetime 1800s, reachable time 0ms, retrans timer 0ms
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
	  mtu option (5), length 8 (1):  1500
	  prefix info option (3), length 32 (4): 2XXX:XXXX:XXXX:XXXX::/64, Flags [onlink, auto], valid time 13448s, pref. time 13448s
	  prefix info option (3), length 32 (4): fddb:5435:878f::/64, Flags [onlink, auto], valid time infinity, pref. time infinity
	  route info option (24), length 24 (3):  2XXX:XXXX:XXXX:XXXX::/60, pref=medium, lifetime=1800s
	  route info option (24), length 24 (3):  fddb:5435:878f::/48, pref=medium, lifetime=1800s
	  rdnss option (25), length 24 (3):  lifetime 1800s, addr: fddb:5435:878f::1
	  advertisement interval option (7), length 8 (1):  600ms
10:51:44.615093 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:51:44.616532 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:51:44.692328 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:23:5a:80:76:d9
10:51:44.692520 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is fe80::XXXX:XXXX:XXXX:XXXX, Flags [router, solicited]
10:51:49.735070 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:51:49.736159 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is fe80::XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:52:29.655090 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:52:29.656480 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:52:31.796094 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:23:5a:80:76:d9
10:52:31.796303 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is fe80::XXXX:XXXX:XXXX:XXXX, Flags [router, solicited]
10:52:36.855138 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:52:36.855698 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is fe80::XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:53:16.855143 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:53:16.855827 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:53:21.976017 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:23:5a:80:76:d9
10:53:21.976224 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is fe80::XXXX:XXXX:XXXX:XXXX, Flags [router, solicited]
10:53:27.015127 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:53:27.016176 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is fe80::XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:54:01.895140 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:54:01.896539 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:54:46.935141 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:54:46.935995 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:54:46.964068 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:23:5a:80:76:d9
10:54:46.964288 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is fe80::XXXX:XXXX:XXXX:XXXX, Flags [router, solicited]
10:54:51.975140 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:54:51.975617 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is fe80::XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:55:31.975134 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:55:31.975869 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
10:55:37.139851 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:23:5a:80:76:d9
10:55:37.140065 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is fe80::XXXX:XXXX:XXXX:XXXX, Flags [router, solicited]
10:55:42.215134 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
10:55:42.215406 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is fe80::XXXX:XXXX:XXXX:XXXX, Flags [solicited]
^C
74 packets captured
74 packets received by filter
0 packets dropped by kernel

client pc information with 19.07

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fddb:5435:878f:0:70b0:3335:adef:c36b/64 scope global temporary dynamic 
       valid_lft 604797sec preferred_lft 86066sec
    inet6 fddb:5435:878f:0:c59f:c65e:c43c:b819/64 scope global mngtmpaddr noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 2XXX:XXXX:XXXX:XXXX:70b0:3335:adef:c36b/64 scope global temporary dynamic 
       valid_lft 13404sec preferred_lft 13404sec
    inet6 2XXX:XXXX:XXXX:XXXX:c75d:1064:6af4:56a8/64 scope global dynamic mngtmpaddr noprefixroute 
       valid_lft 13404sec preferred_lft 13404sec
    inet6 fe80::b196:dccf:ba12:c837/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

--
eiji

Again you are not entering the full command for tcpdump:
tcpdump -i eth0.1 -vn icmp6 or udp port 546
You stop copying at icmp6.

1 Like

When you remove:

option src_ip 'fc00::/6'
option dest_ip 'fc00::/6'

from /etc/config/firewall
Rule: Allow DHCPv6
Does it start to work then?

2 Likes

@trendy

I'm really sorry I didn't follow your instruction exactly. I misunderstood your instruction.

This time, I have copied everything including "or udp port 546" and here is the result.

root@OpenWrt:~# tcpdump -i eth0.1 -vn icmp6 or udp port 546
tcpdump: listening on eth0.1, link-type EN10MB (Ethernet), capture size 262144 bytes
22:05:12.521740 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
22:05:12.533084 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
22:06:08.841688 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
22:06:08.843064 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
22:07:15.401677 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
22:07:15.403064 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
22:07:23.635449 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:23:5a:80:76:d9
22:07:23.635650 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is fe80::XXXX:XXXX:XXXX:XXXX, Flags [router, solicited]
22:07:28.681693 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has fe80::XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
22:07:28.682705 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) fe80::XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is fe80::XXXX:XXXX:XXXX:XXXX, Flags [solicited]
22:08:10.681676 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
22:08:10.682296 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
22:08:44.121750 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
22:08:44.122525 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
22:08:48.947055 IP6 (flowlabel 0xb0146, hlim 255, next-header ICMPv6 (58) payload length: 176) fe80::XXXX:XXXX:XXXX:XXXX > ff02::1: [icmp6 sum ok] ICMP6, router advertisement, length 176
	hop limit 64, Flags [managed, other stateful], pref medium, router lifetime 1800s, reachable time 0ms, retrans timer 0ms
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
	  mtu option (5), length 8 (1):  1500
	  prefix info option (3), length 32 (4): 2XXX:XXXX:XXXX:XX10::/64, Flags [onlink, auto], valid time 7239s, pref. time 7239s
	  prefix info option (3), length 32 (4): fddb:5435:878f::/64, Flags [onlink, auto], valid time infinity, pref. time infinity
	  route info option (24), length 24 (3):  2XXX:XXXX:XXXX:XX10::/60, pref=medium, lifetime=1800s
	  route info option (24), length 24 (3):  fddb:5435:878f::/48, pref=medium, lifetime=1800s
	  rdnss option (25), length 24 (3):  lifetime 1800s, addr: fddb:5435:878f::1
	  advertisement interval option (7), length 8 (1):  600ms
22:09:30.601676 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
22:09:30.603006 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
22:10:00.441679 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
22:10:00.442305 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
22:10:51.401752 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
22:10:51.402536 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
22:11:42.281751 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
22:11:42.282533 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
22:12:30.841668 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
22:12:30.842048 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
22:13:15.881682 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
22:13:15.883002 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
22:13:49.641680 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
22:13:49.642299 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
22:14:40.521680 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
22:14:40.522325 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
22:15:31.001679 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
22:15:31.002300 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
22:16:06.441679 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 32) fe80::XXXX:XXXX:XXXX:XXXX > 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor solicitation, length 32, who has 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX
	  source link-address option (1), length 8 (1): 00:24:a5:ef:e8:a6
22:16:06.442617 IP6 (hlim 255, next-header ICMPv6 (58) payload length: 24) 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX > fe80::XXXX:XXXX:XXXX:XXXX: [icmp6 sum ok] ICMP6, neighbor advertisement, length 24, tgt is 2XXX:XXXX:XXXX:XX10:XXXX:XXXX:XXXX:XXXX, Flags [solicited]
^C
35 packets captured
35 packets received by filter
0 packets dropped by kernel
root@OpenWrt:~# 

--
eiji

Did any client try to connect with DHCP? I only see ICMP6 solicitations and advertisements.

@shm0

Many thanks for your advice. After removing the two line, I have rebooted the route and checked /tmp/hosts/odhcpd.

root@OpenWrt:~# cat /tmp/hosts/odhcpd 
2XXX:XXXX:XXXX:XX10::2    io
fddb:5435:878f::2       io
# br-lan 00046f6d78530d9497fef9b5e0e6726f8521 5a8076d9 io -1 2 128 2XXX:XXXX:XXXX:XX10::2/128 fddb:5435:878f::2/128

Seems working now, but in my client PC, I could not see this assigned IPv6 address. Also strange.

ematsu@io:~$ ip -6 addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fddb:5435:878f::2/128 scope global dynamic noprefixroute 
       valid_lft 8589743sec preferred_lft 8589743sec
    inet6 fddb:5435:878f:0:8928:70ae:a67a:a992/64 scope global temporary dynamic 
       valid_lft 604609sec preferred_lft 85968sec
    inet6 fddb:5435:878f:0:c59f:c65e:c43c:b819/64 scope global mngtmpaddr noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 2XXX:XXXX:XXXX:XX10:8928:70ae:a67a:a992/64 scope global temporary dynamic 
       valid_lft 13326sec preferred_lft 13326sec
    inet6 2XXX:XXXX:XXXX:XX10:c75d:1064:6af4:56a8/64 scope global dynamic mngtmpaddr noprefixroute 
       valid_lft 13326sec preferred_lft 13326sec
    inet6 fe80::b196:dccf:ba12:c837/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

I mean, I'm missing the address "2XXX:XXXX:XXXX:XX10::2" , that I can see in "/tmp/hosts/odhcpd".

Again, did I do something wrong ?

--
eiji

@trendy

I thinks so, because with the same client pc, I got the DHCPv6 address when I connect 18.06 router.

Should I tcpdump also on the client PC ?

Do you get a delegated prefix now?
Does it show up on the routers overview page when you log into webinterface?
I think the default firewall rule is wrong.
Isn't the dhcp solication send via multicast? (ff02::1:2)

I can see it here that the br-lan got a /60

It is not necessary to run it on the PC, but if we don't see any DHCP6 on the router and you think that the PC is requesting it, then maybe you should run it on the PC as well.