DHCP Requests don't get into VLAN-based Wifi

I find some similar threads, but so far can't tell what issue my config really has.

For example this one looks similar, but is closed already: DHCP Requests not working in Wifi with VLAN

At a customer we run 3 D-Link DAP 2610 appliances. Around 2 years ago I spent quite a lot of time figuring out how to configure VLAN-based Wifi on these boxes. I built our own images (Gitlab CI/CD) with 22.02 back then, added some Packages ... and the stuff worked great since then.

Around 2 weeks ago something happened, since then we couldn't get DHCP into Wifi anymore. Checked the switches, the VLANs, the WRT-conf ... we see requests, but no replies.

I flashed recent upstream images etc etc

Here the config that worked so far, could anyone tell me if there are mistakes or something that should be done differently?

The main issue back then with the hardware was that I had to tag the VLANs on the internal switch as well. This seems to be my thread from 2021: D-Link DAP 2160: vlans and wifi ... (newbie) - #11 by sgw


config interface 'loopback'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
	option device 'lo'

config globals 'globals'

config interface 'lan'
	option delegate '0'
	option proto 'dhcp'
	option stp '1'
	option device 'br-lan'

config switch 'switch0'
	option enable_vlan '1'
	option name 'switch0'
	option reset '1'

config switch_vlan 'switch0_vlan10'
	option device 'switch0'
	option ports '0t 5t'
	option vid '10'
	option vlan '10'

config switch_vlan 'switch0_vlan11'
	option device 'switch0'
	option ports '0t 5t'
	option vid '11'
	option vlan '11'

config switch_vlan 'switch0_vlan12'
	option device 'switch0'
	option ports '0t 5t'
	option vid '12'
	option vlan '12'

config interface 'vlan10'
	option stp '1'
	option delegate '0'
	option proto 'dhcp'
	option device 'br-vlan10'

config interface 'vlan11'
	option stp '1'
	option delegate '0'
	option proto 'none'
	option device 'br-vlan11'

config interface 'vlan12'
	option stp '1'
	option delegate '0'
	option proto 'none'
	option device 'br-vlan12'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

config device
	option name 'br-vlan10'
	option type 'bridge'
	list ports 'eth0.10'

config device
	option name 'br-vlan11'
	option type 'bridge'
	list ports 'eth0.11'

config device
	option name 'br-vlan12'
	option type 'bridge'
	list ports 'eth0.12'

hi,

could you please elaborate what happened? e.g. due to power outage APs restarted? or you changed something? is there any hardware related problem: e.g. faulty power supply, old device and/or running under stressed environment (too cold, too hot, too dirty)? have you checked cabling?

after or before "something happened"? recent means which version exactly?

  1. do you happen to know if recent upstream image is using DSA switch mode, or still on legacy swconfig? because your config is old style and there was several recommendation in the release notes and across the forum threads that it is better to do a fresh installation then re-create configuration. not import from backup or keep settings during sysupgrade but using the backup as a guide only and re-configure as there can be changes. e.g. swconfig to DSA was a major change resulting a whole different network stack and related configuration.

  2. if you set static ip on your client can you use network as expected? only DHCP is not working?

Try removing the stp and delegate lines. Typically, the stanzas corresponding to a bridge with proto none do not include these two lines.

will try soon. maybe after long needed vacation .... thanks so far!

This project was paused for a while. Now we want to start a new try.
I will remove the stp and delegate lines for all the vlan-interfaces and try to build a new image in my CI/CD pipeline.