DHCP replies not getting through

I've got a Linksys WRT3200ACM set up as a bridged access point. I have a Linux server, plugged in to one of the lan1 - lan4 ethernet ports. WRT3200ACM is running OpenWrt 23.05.3, r23809-234f1a2efa. It appears that DHCP offers and ACKs don't get from the Linux server to WiFi clients.

tcpdump on the linux server says that DHCP requests/solicitations get to the server and that the kea-dhcp4 daemon answers them. tcpdump on the WRT3200ACM says that the DHCP ACKs and offers get to the bridged LAN. tcpdump on my WiFi client (linux laptop) says the DHCP ACKs and offers don't get through for a very long time.

I have plugged my laptop into one of the LAN ethernet ports (not the one labeled "Internet") on the WRT3200ACM. The laptop acquires an IP address for its ethernet port very rapidly, in a few seconds.

As a WiFi client, it takes upwards of a minute. During the period between authenticating to the WiFi radio, and getting an IP address via DHCP, I can run things like dhtest or dhcping. They timeout without getting any kind of response.

I have tried USB WiFi dongles. They, too, take more than a minute to get an IP address. It's not my laptop. It gets an IP address from another WiFi access point very rapidly.

Here's dhcpcd journal from my laptop. "wlp1s0" is the WiFi network interface.

May 20 19:24:17 hazard kernel: wlp1s0: associated
May 20 19:24:17 hazard dhcpcd[400]: wlp1s0: carrier acquired
May 20 19:24:17 hazard dhcpcd[400]: wlp1s0: IAID 71:30:21:86
May 20 19:24:17 hazard dhcpcd[400]: wlp1s0: adding address fe80::9402:3c1e:566d:957b
May 20 19:24:17 hazard dhcpcd[400]: wlp1s0: soliciting an IPv6 router
May 20 19:24:18 hazard dhcpcd[400]: wlp1s0: soliciting a DHCP lease 
May 20 19:24:18 hazard systemd[1]: systemd-rfkill.service: Deactivated successfully.
May 20 19:24:31 hazard dhcpcd[400]: wlp1s0: no IPv6 Routers available
May 20 19:25:17 hazard dhcpcd[400]: wlp1s0: offered 172.24.0.7 from 172.24.0.1
May 20 19:25:17 hazard dhcpcd[400]: wlp1s0: probing address 172.24.0.7/16
May 20 19:25:23 hazard dhcpcd[400]: wlp1s0: leased 172.24.0.7 for 3600 seconds
May 20 19:25:23 hazard dhcpcd[400]: wlp1s0: adding route to 172.24.0.0/16
May 20 19:25:23 hazard dhcpcd[400]: wlp1s0: adding default route via 172.24.0.1

Here's the various configurations usually asked for in this forum:

ubus call system board
{
	"kernel": "5.15.150",
	"hostname": "OpenWrt",
	"system": "ARMv7 Processor rev 1 (v7l)",
	"model": "Linksys WRT3200ACM",
	"board_name": "linksys,wrt3200acm",
	"rootfs_type": "squashfs",
	"release": {
		"distribution": "OpenWrt",
		"version": "23.05.3",
		"revision": "r23809-234f1a2efa",
		"target": "mvebu/cortexa9",
		"description": "OpenWrt 23.05.3 r23809-234f1a2efa"
	}
}

cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdc2:15dd:1471::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'dhcp'

config device
	option name 'wan'
	option macaddr '32:23:03:dc:86:48'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'


cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option disabled '0'
	option country 'US'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'bongrips4jesus42069'
	option encryption 'psk2'
	option key 'redacted'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option disabled '0'
	option country 'US'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'bongrips4jesus42069'
	option encryption 'psk2'
	option key 'redacted'

config wifi-device 'radio2'
	option type 'mac80211'
	option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
	option channel '34'
	option band '5g'
	option htmode 'VHT80'
	option disabled '1'

config wifi-iface 'default_radio2'
	option device 'radio2'
	option network 'lan'
	option mode 'ap'
	option ssid 'bongrips4jesus42069'
	option encryption 'none'


cat /etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option cachesize '1000'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'
	option filter_aaaa '0'
	option filter_a '0'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option ignore '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'


cat /etc/config/firewall
config defaults
	option syn_flood	1
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
# Uncomment this line to disable ipv6 rules
#	option disable_ipv6	1

config zone
	option name		lan
	list   network		'lan'
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT

config zone
	option name		wan
	list   network		'wan'
	list   network		'wan6'
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
	option masq		1
	option mtu_fix		1

config forwarding
	option src		lan
	option dest		wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
	option name		Allow-DHCP-Renew
	option src		wan
	option proto		udp
	option dest_port	68
	option target		ACCEPT
	option family		ipv4

# Allow IPv4 ping
config rule
	option name		Allow-Ping
	option src		wan
	option proto		icmp
	option icmp_type	echo-request
	option family		ipv4
	option target		ACCEPT

config rule
	option name		Allow-IGMP
	option src		wan
	option proto		igmp
	option family		ipv4
	option target		ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
	option name		Allow-DHCPv6
	option src		wan
	option proto		udp
	option dest_port	546
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-MLD
	option src		wan
	option proto		icmp
	option src_ip		fe80::/10
	list icmp_type		'130/0'
	list icmp_type		'131/0'
	list icmp_type		'132/0'
	list icmp_type		'143/0'
	option family		ipv6
	option target		ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Input
	option src		wan
	option proto	icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	list icmp_type		router-solicitation
	list icmp_type		neighbour-solicitation
	list icmp_type		router-advertisement
	list icmp_type		neighbour-advertisement
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Forward
	option src		wan
	option dest		*
	option proto		icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-IPSec-ESP
	option src		wan
	option dest		lan
	option proto		esp
	option target		ACCEPT

config rule
	option name		Allow-ISAKMP
	option src		wan
	option dest		lan
	option dest_port	500
	option proto		udp
	option target		ACCEPT


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option dest		wan
#	option proto	tcp
#	option target	REJECT

# block a specific mac on wan
#config rule
#	option dest		wan
#	option src_mac	00:11:22:33:44:66
#	option target	REJECT

# block incoming ICMP traffic on a zone
#config rule
#	option src		lan
#	option proto	ICMP
#	option target	DROP

# port redirect port coming in on wan to lan
#config redirect
#	option src			wan
#	option src_dport	80
#	option dest			lan
#	option dest_ip		192.168.16.235
#	option dest_port	80
#	option proto		tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#	option src		wan
#	option src_dport	22001
#	option dest		lan
#	option dest_port	22
#	option proto		tcp

### FULL CONFIG SECTIONS
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port	80
#	option dest		wan
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp
#	option target	REJECT

#config redirect
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port		1024
#	option src_dport	80
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp

It is a bit strange that your "lan" is set as DHCP client, by default it was dhcp server with static IP.

1 Like

Where is your DHCP server running? I assume in the main router?
What port on this device connects to the upstream?
What address is this device getting from the DHCP server?
Does the problem occur with other devices (i.e. a different computer, phone, etc.)?

1 Like

I have OpenWrt acquiring an IP address by DHCP because I was moving it from one server (running kea-dhcp4) to another (running dhcpd) and I got tired of forgetting to change the static address.

The DHCP server is running on a Linux server. It has a single cable from the port for network interface enp7s0 to the upstream. enp7s0 has address 10.0.40.70.

It has a single cable going from enp4s0 to the WRT3200ACM, RJ45 socket labeled "1". enp4s0 has address 172.24.0.1, OpenWrt's br-land has address 172.24.0.14

As far as other devices: I'm going to apologize. I thought I had covered that, and tried several USB WiFi dongles, but it looks like a Macbook Air, a Google Pixel 6a and a different Arch laptop (from the scrap heap) acquire an address from DHCP rapidly. tcpdump on the Macbook and scrap laptop show DHCP replies instantly.

This is a problem with my laptop, not OpenWrt, or the config I've got.

Sorry, and I appreciate your patience and forcing me to answer completely.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.