DHCP doesn't work on new bridged iface

I'm just starting to use OpenWrt and I'm not a network specialist (understand some things though). I have a problem with setting up the DHCP on a new bridged interface.

I created a new bridge device connected to all my lan ports and removed all these ports from the default bridge device (left only wifi adapters there). Then I created the static address interface and linked it to this new device. Set up a different IP subnet (192.168.0.0/24) for it. I have one device with static 192.168.0.7 address and it works fine but the other device seems not receiving addresses by DHCP (I don't see them in active DHCP leases tab).

Configs:

root@OpenWrt:~# cat /etc/config/network 

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd45:b0bd:2a8d::/48'

config device
	option name 'br-lan'
	option type 'bridge'

config device
	option name 'lan1'
	option macaddr '94:83:c4:a3:f7:5e'

config device
	option name 'lan2'
	option macaddr '94:83:c4:a3:f7:5e'

config device
	option name 'lan3'
	option macaddr '94:83:c4:a3:f7:5e'

config device
	option name 'lan4'
	option macaddr '94:83:c4:a3:f7:5e'

config device
	option name 'lan5'
	option macaddr '94:83:c4:a3:f7:5e'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option delegate '0'

config device
	option name 'eth1'
	option macaddr '94:83:c4:a3:f7:5c'

config interface 'wan'
	option device 'eth1'
	option proto 'pppoe'
	option username '121451'
	option password '9647877519'
	option ipv6 'auto'

config interface 'wan6'
	option device 'eth1'
	option proto 'dhcpv6'

config device
	option type 'bridge'
	option name 'br-lan-wired'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'lan5'
	option mtu '1500'
	option macaddr '94:83:C4:A3:F7:5E'
	option ipv6 '0'

config interface 'lan_wired'
	option proto 'static'
	option device 'br-lan-wired'
	option ipaddr '192.168.0.1'
	option netmask '255.255.255.0'
	option delegate '0'
root@OpenWrt:~# cat /etc/config/dhcp 

config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option cachesize '1000'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option localservice '1'
	option ednspacket_max '1232'
	list interface 'lan'
	list interface 'lan_wired'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config dhcp 'lan_wired'
	option interface 'lan_wired'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'

Thanks in advance for any help.

The lan is the default interface using the default br-lan device.
The lan_wired is my interface using my br-lan-wired device.

And yes, my goal is to have different subnets for wi-fi and wired clients. I don't need VLANs for this, do I?

It seems that the devices just remembered their old IPs from the default subnet and that's why they didn't acquire new ones via DHCP. Seems to be working now.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.