DGA 4131 and Wake on Wan on cascade router LAN LAN

hi,

i have a rooted dga4131 with a firmware based on OpenWRT.

I put it in cascade LAN-LAN to the main router, which is provided by my ISP. In this way I can extend my network wifi and program the arp table for WoW, which I can't do in the main one.

On the main router I set port mapping (UDP / TCP 9). In the secondary I turned off DHCP, opened the same ports and inserted a fixed value in the ARP Table:

ip neighbor add 192.168.1.xxx lladdr 00:xx:xx:xx:xx:xx dev br-lan nud permanent

The wake on wan doesn't work but Wake on lan does even if the computer is turned off for many hours (it means that the arp table is correctly set).

If i use tcpdump:

tcpdump -i br-lan port 9

i can see the magic packet:

root@OpenWrt:~# tcpdump -i br-lan port 9
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on br-lan, link-type EN10MB (Ethernet), capture size 262144 bytes
19:39:36.297848 IP 94-35-24-124.client-mvno.myISP.it.43379 > 192.168.1.(router2ip).discard: UDP, length 102
19:39:36.304727 IP 94-35-24-124.client-mvno.myISP.it.43379 > 192.168.1.(PC-ip).discard: UDP, length 102
19:39:36.311500 IP 94-35-24-124.client-mvno.myISP.it.43381 > 192.168.1.(router2ip).discard: UDP, length 102
19:39:36.318202 IP 94-35-24-124.client-mvno.MYISP.it.43381 > 192.168.1.(PC-ip).discard: UDP, length 102
19:39:36.323219 IP 94-35-24-124.client-mvno.tiscali.it.43374 > 192.168.1.(router2ip).discard: UDP, length 102
19:39:36.324575 IP 94-35-24-124.client-mvno.tiscali.it.43374 > 192.168.1.(PC-ip).discard: UDP, length 102

6 packets captured
6 packets received by filter
0 packets dropped by kernel

I tried stopping the firewall

/etc/init.d/firewall stop

or inserting rules in /etc/init.d/firewall, but it still does not work.

I also tried to install etherwake and use it to send a magic pocket from the secondary router with:

root@OpenWrt:~# /usr/bin/etherwake -D -i 'br-lan' -b '00:xx:xx:xx:xx:xx'

The target station address is 0:xx:xx:xx:xx:xx. (Why only 1 zero?)
Packet is  ff ff ff ff ff ff 00 xx xx xx xx xx xx xx ff ff ff ff ff ff 00 (right mac address 16x).

but no magic packet reaches the computer (I see it with Wolsniffer).

How can I leave the Magic Pocket pass or redirect it to the pc? I have tried many different solutions but without solve the problem.

Thanks

Now it works, I'm posting the solution here to help anyone who might have the same problem.

I disabled the network connections created by Windows Sandbox, Hyper V and VMware workstation player. I think the problem was caused by them.

I created a rule and a forwarding in the firewall whit an unused lan ip like 192.168.1.60

config redirect 'WakeOnWan'
	option family 'ipv4'
	option dest_ip '192.168.1.60'
	option dest 'lan'
	option src 'wan'
	option target 'DNAT'
	option src_dport '9'
	option proto 'udp'
	option dest_port '9'

config userredirect 'userredirect1234'
	option family 'ipv4'
	option dest_mac 'xx:xx:xx:xx:xx:xx'
	option enabled '1'
	option target 'DNAT'
	option src 'wan'
	option dest_port '9'
	list proto 'tcpudp'
	option name '9'
	option src_dport '9'
	option dest 'lan'

and added:

ip neigh add 192.168.1.60 lladdr ff:ff:ff:ff:ff:ff nud permanent dev br-lan

or (I don't know which one is correct.)

ip neighbor add 192.168.1.60 lladdr ff:ff:ff:ff:ff:ff nud permanent dev br-lan