Devices won't get DHCP from my Mikrotik AP over OpenWrt router, but works only when static IP given into devices


#1

Hello, first of all i'm completely Newbie, so i'm not sure that this answer already given or not... i tried to find the solution and tried to setup the configuration, but nothing worked... below is described my problem..

I'm using Openwrt LEDE Reboot 17.01.6 r3979-2252731af4 on my TP-Link TL-MR3420 v2 router .. I have Mikrotik Routerboard as Access Point.. But because of the poor signal i decided to use this router as Extender which will connect with my Mikrotik RouterBoard.. I want to connect my router as Extender of my main Mikrotik Router.. Also the Extender name will be different .. For example my main Router AP Name "HZ_Mikrotik" and the Openwrt Router AP Name will be "HZ_Mikrotik_Repeater"... The devices will connect to the Openwrt router , but they will take the DHCP IP from the main router(Mikrotik Routerboard)..

After watching some tutorial and viewing post i tried to setup my router as repeater, i can connect my devices only via static IP..for Example:

Main Router SSID : HZ_Mikrotik
Main Router DHCP Server : 192.168.100.1/24
Pool : 192.168.100.100-192.168.100.254

OpenWRT SSID : HZ_Mikrotik_Repeater
OpenWRT DHCP : Disable
OpenWRT LAN IP : 192.168.1.1/24(I didn't change, just disabled)
OpenWRT Client IP: 192.168.100.51/24
Subnet : 255.255.255.0
Gateway: 192.168.100.1
DNS : 192.168.100.1

Bridge Realy: Client virtual Interface(conenct with HZ-Mikrotik) + LAN(LAN ports + new AP which i made with the name "HZ_Mikrotik_Repeater" )

If i just connect my devices with my openwrt router it can't get the IP address from main router, but if i give static IP address, gateway and DNS it works and i can get reply by pinging the device's ip from my main router.. also i get the ip address from ARP list..

02

Want: How can i also get the DHCP list when i will connect my device via Openwrt.. The same environment works when i used my TP-Link Extender 850RE without any problem.. i didn't use any WDS system but it worked.. but i don't have the repeater no more and i just want to setp my OpenWRT Router...


#2

A "range extender" works very differently than a "router".

A range extender generally connects its clients transparently to the original AP.

A router often provides new subnets, accepting packets on one interface and sending them off to either the final destination or the next hop in getting there.

DHCP discovery and initial lease is a "link-local" or "on-link" protocol. It only works for clients that are directly connected, or connected through a "Layer 2" bridge. Your range extender probably provided a Layer 2 bridge.

There are a few ways to accomplish your goals. Best would be hard wire Ethernet cable between the two devices, then something like power-line modems, finally some kind of WDS or other wireless connection.

Have you already flashed OpenWrt on your Mikrotik device?


#3

no, i didn't ... actually i want to keep the mikrotik with it's original os, just wanted to use my unused router, however it's signal is better than my Range Extender, i wanted to use this router instead of the extender... if there's no way to do that maybe i will just use it as repeater :frowning:


#4

i thought if it works with given Static IP, maybe i configured it wrong and was looking for a professional's guide..

currently i used with my configuration and also turned on the hcp from my openwrt router.. no if i give static ip address onto device, then the devices can be rechable from my mikrotik router, but if i select automatic IP settings, it takes openwrt router's dhcp lease and also internet works, but from openwrt router ...


#5

If you can run Ethernet cable or use power-line modems (or similar), you could configure your OpenWrt router as a "dumb AP" which will let the Mikrotik manage Internet routing, NAT, DHCP, DNS, and the like. This would be my preferred path, though I understand the challenges with running cable. One description of how to configure a dumb AP is https://openwrt.org/docs/guide-user/network/wifi/dumbap

I don't know the Mikrotik software at all, but if it supports WDS in a "flavor" that OpenWrt can interoperate with, then configuring them similarly as described in https://openwrt.org/docs/guide-user/network/wifi/atheroswds will allow your OpenWrt router to behave much as your repeater did.


#6

i will definately try this.. thnx everyone for giving ur suggestion :slight_smile: