Devices on PowerLAN not accessible


after switching to OpenWrt, the devices on my network connected to PowerLAN adapters are no longer accessible. Same goes for the adapters themselves.

With the router manufacturer's firmware, PowerLAN access was completely transparent. But now, the PowerLAN part of the network is "cut off".

I use adapters from Devolo; The control software "Devolo Cockpit" no longer shows the existing adapters, instead it shows a message "No local PLC device found".

It would be great to get some advice how to troubleshoot this.

What did you use to connect the PowerLAN adapters to?
Are you using the same cables?
Have you tried with crossover cables?

The "master" PowerLAN adapter is connected directly to an Ethernet port on the router by cable.
Networking traffic goes from router through master adapter and power lines to second adapter, which has a network printer connected to it.

Yes. Regarding networking devices and cabling, nothing has changed since upgrading to OpenWrt firmware.

How would that aid in troubleshooting?


What I meant was what was connected to the PowerLan before you switched to OpenWrt and the problem appeared.

It depends on what was connected before the OpenWrt router.
And by the way which router is it and which OpenWrt version are you running?

I hope my previous answer was sufficent?

The router is a WNDR3700v1 running OpenWrt 18.06.2 r7676-cddd7b4c77.

The PowerLAN adapter was recognized again by the router when I connected it with a crossover cable (fortunately I still had one lying around in a drawer...)

Do you know if there is a setting in OpenWrt that controls this behavior? Because I would like to be able to use a regular Ethernet cable as it was possible with the manufacturer's firmware.

Not as far as I know. This is usually auto-detected and it seems strange that the conversion to OpenWrt changed something. Hence my belief that something else was connected before the problem occurred. You can check if there is any setting in swconfig command, but since I don't own the same device I cannot help any further.

If your problem is solved, feel free to mark the relevant post as the solution; and edit the title to add "[SOLVED]" to the beginning (click the pencil behind the topic).