Developer Firmware not available for Xiaomi Mi 3Gv1


I need this firmware but cannot find it, all links are broken. Can somebody upload it or find a link? I’ve searched for hours already and no success.


It probably makes more sense to look into using the PPP exploit as already used by the redmi ac2100 and xiaomi ac2100.

1 Like

Oh alright, thanks for mentioning it. Will look into.

Is there a safe instruction what to do on the 3Gv1? If so, can you explain how to do it?(will be my first openwrt installation)

I couldn’t find anything where it says that it works on the 3gv1

Are we talking about this device?

Which links exactly are broken? Where did you find these links?


the links everywhere to the dev firmware, like this one on the wiki page:

Hi everyone

I'd like to install OpenWRT on my Xiaomi R3G V1 router.
I just followed all the steps listed in :

I already got my ssh.bin an password but i can't access to nor downloading through .

I seen that thread too but mediashare link is dead : Xiaomi Router 3G dev firmware request

all links seems to be down.

can anyone please share his miwifi_r3g_firmware_c2175_2.25.122.bin with me (and probably some more future users).

Best regards

EDIT // after a couple hours of searching i found that firmware here :slight_smile:

there is a copy :

best regards


I tried with soldering, was my first time but after two days searching for an error it worked after I restarted gtkterm on Ubuntu. I set the env stuff and then restarted it, but now I can’t see anything again. No matter what I did, anybody any idea? I just wanted to install the firmware with uart..

I got a Multimeter and the voltages seems to be there, I just don’t know why it doesn’t work again.

Anybody an idea? Did I something wrong? I mean, I measured the connections and they seem like fine. I resoldered it and it didn’t change. I can’t get any output of the router.

Does anyone have information about bigota link for downloading firmware from miwifi


I'm getting "Access denied"

<Message>Access Denied</Message>

Hello everybody, after couple of days, a Training as electrician, and several frustrating hours I got it working. There are weird and unexplained stuff going on, it is not newbie friendly, so I will try to explain what happened to me and how you can achieve it with soldering(btw it is not that hard to establish a connection/solder).

-First I tried soldering some wires directly to the serial position but bought some pins and stuff to do it properly and sort it out as a potential problem(it was not a problem, you can do it if you want)
-Second I started UART as described and powered the device and for multiple days got no output on my console, no matter what I did. This was the frustrating part, since 1 time it somehow worked(might be a connection problem which was in my favor, explaining incoming:).
-I spent really many hours on this but today somehow I figured it out how I can get the output as it should. So it worked only once, I tried to redo all ways what could have happened. It worked after I plugged my usb serial device, configured everything, than don’t make a connection to the serial port of the device, power it on, wait for the electrical noises and plug the cables in immediately, so you get almost all output as it should. This worked everytime after my initial Discovery.
-It is only necessary to set the env 1 stuff, after that just press „reset“ and let it boot as it would(or choose 3).

Now why is there no console like Linux? Hmm.

After rewatching some YouTube videos, I figured it out that it was the only thing the dude did. So I pressed a key and the console showed up! Voila, just do the flash commands after you prepared your usb device and plugged it in. Now you have openwrt!

In the end i learned a lot about electronics or Multimeter in instance(because I thought there was a connection problem), so I am grateful for my experience even though it was stressful and I got no support.

Just look some comments above.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.