Degraded 5Ghz WiFi Signal on AVM FRITZ!Box 7530

I recently Installed OpenWRT 22.03 on my Fritz!Box 7530.

Got everything up and running fine but I'm noticing degraded performance on 5GHz WiFi compared to stock firmware.

I normally get a signal strength of around -68dBm and a speed of over 200Mbps down & up on the stock Fritz!Box firmware. This is around the maximum bandwidth provided by my ISP.

OpenWRT is showing a signal strength of -92dBm with download never going above 120Mbps and upload never goes higher than 70Mbps.

I'm not sure what to do to solve this as I've already tried changing country codes, boosting signal strength to 23dBm and using a channel that's not congested.

OpenWRT reports the radio as a Qualcomm Atheros IPQ4019 802.11acn

I accept that OpenWRT isn't going to perform quite as well as stock firmware since it's not optimized for my hardware but I wouldn't of expected the difference to be this drastic. Especially when 2.4Ghz and wired performance seems to be more or less the same between stock and OpenWRT.

wlan1 ESSID: "FRITZ!Box_5Ghz"
          Access Point:
          Mode: Master  Channel: 52 (5.260 GHz)  HT Mode: VHT80
          Center Channel 1: 58 2: unknown
          Tx-Power: 20 dBm  Link Quality: 17/70
          Signal: -93 dBm  Noise: -109 dBm
          Bit Rate: 325.0 MBit/s
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11ac/n
          Hardware: 168C:003C 168C:4019 [Qualcomm Atheros IPQ4019]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy1

Are there any other settings I should be looking at?

Another problem which could be related is that I cannot get WPS pushbutton working either.

Removed package: wpad-basic-wolfssl

Installed packages: wpad & hostapd-utils

I now have the WPS checkbox option in Luci but if I enable it on either radio it just disables the WiFi and I get a message saying Wireless is not associated.

Are Qualcomm Atheros chipset's known to be a problem with OpenWRT? Is there anyone willing to help me get to the bottom of this?

Recently, there have not been many updates for IPQ4019 as you can see here:, but it might still be worth a shot sysupgrading to the newest master snapshot, because of following commit: IPQ4019: AVM FRITZ!Box 7530: Remove NAND ECC restrictions from DTS. I am not sure, if that commit has been backported to 22.03. Who knows, maybe it will help?

Upgrading to snapshot seems to be a good idea for other reasons as well:

Checking open issue at github i found this one: AVM Fritzbox 7520/7530 switch config error on boot #11644

Comment by Robimarko:

Doubt this is gonna get fixed as the driver that is used in 22.03 and anything before is fundamentally broken.
You should probably try snapshots which have DSA support so that switch can be properly used.

Thanks for the suggestion.

Unfortunately I loose internet connectivity when installing the snapshot build despite using the same configuration settings from the release build.

This prevents me from installing luci via opkg.

DSA requires different configuration syntax, so using same config as with 22.03 is not advised. Instead start from a clean state. Tabula rasa.

You can customize your image to include Luci by default with the firmware selector. Just add luci to "installed packages".

1 Like

Thanks for the tip, used the firmware selector and got the snapshot build up and running with Luci. Would of been a headache configuring via command line as I'm not familiar with the DSA syntax and I had to setup one of the LAN ports as a WAN port with a specific VLAN tag required by my ISP.

Unfortunately it didn't solve the issues with WiFi signal or WPS but I appreciate the suggestion all the same.

Ended up using a spare ISP provided router as a dumb AP for 5Ghz. My speeds are back to normal and I can use the WPS from the ISP router to connect my wireless printer.

This setup will have to do until I find a good router that works well with OpenWrt.

1 Like

Fair enough!

I just noticed something in your settings: You said you tried 23 dBm, but in your settings it's 20 dBm using channel 58. Some channels are limited to lower dBm. In many countries, channel 58 often is reserved for radar. A so called "DFS" channel. See

Btw., have you set the country code? You can see the max dBm for each channel in the regulatory database (regdb), depending on country. (Please set the countrycode of your ACTUAL country. Setting any other country is illegal and there are heavy fines.)

Yes if you look at my original post I tried changing country codes. Setting it to US allows me to pick 23dBm or setting the channel to 149. 20dBm is the default setting when my home country of the UK is selected.

You are right. I missed that. Sorry.

What's the maximum throughput you can reach if you are right next to the router? What's the dBm then?

With my phone almost touching the router the best I recorded was -40dBm but only for a second or two. It was constantly fluctuating anywhere from -40dBm to -68dBm.

On a positive note I managed to get WPS working on the 2.4Ghz radio. Not 100% sure what I did to get it to work. Perhaps setting a dedicated channel instead of auto? Or enabling krack countermeasures?

That's all I changed.

Don't want to turn it off again to verify encase I can't get it to enable again.