Debuging APU4D4 with LTE modem

Hello folks !

I am trying to debug an LTE connexion and pulling my hair a bit.
So far the modem seems to be properly detected and I can talk to the 4G card using AT commands.

But I don't seem to be able to pass the point where I can connect.
My provider is Orange in France.

SIM has been bypassed and is "ok" (= not causing problem anymore).

root@OpenWrt:/# uqmi -d /dev/cdc-wdm0 --get-signal-info
        "type": "wcdma",
        "rssi": -81,
        "ecio": 25
root@OpenWrt:/# uqmi -d /dev/cdc-wdm0 --get-data-status
root@OpenWrt:/# uqmi -d /dev/cdc-wdm0 --start-network internet --autoconnect
"Call failed"

and usbmode does not seem to be answering :

root@OpenWrt:/# usbmode -l
root@OpenWrt:/# usbmode -s

The interface is like this :

8: wwan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN qlen 1000
    link/ether 7e:e1:99:72:ae:06 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::7ce1:99ff:fe72:ae06/64 scope link
       valid_lft forever preferred_lft forever

Any help on where to go from there would be nice to have!

thx :wink:

uqmi -d /dev/cdc-wdm0 --get-serving-system ?

Thanks for your reply here is the output:

root@OpenWrt:/# uqmi -d /dev/cdc-wdm0 --get-serving-system
        "registration": "registered",
        "plmn_mcc": 208,
        "plmn_mnc": 1,
        "plmn_description": "Orange",
        "roaming": false

What is the LTE modem model?

It is a SIMCom SIM7600E-H LTE mPCIe EU

From the PoV of the modem things seems quite ok AFAICT :

Everything seems quite "OK"… ??




+COPS: 0,0,"Orange F Orange F",2

+CGREG: 0,2

+CGDCONT: 1,"IP","","",0,0,0,0
+CGDCONT: 4,"IPV4V6","orange","",0,0,0,0


+CGACT: 1,0
+CGACT: 4,0

But still when I am trying to connect, I got :

root@OpenWrt:/# uqmi -d /dev/cdc-wdm0 --start-network internet --autoconnect
"No effect"

Snif :frowning:


You need to add --apn infront of your apn:

uqmi -d /dev/cdc-wdm0 --start-network --apn internet

Do you have trouble to start your modem from Luci - Network - Interfaces ?
I have a modified uqmi at:

If you need help to compile I can try to help. I need to know your version of Openwrt.

Hello and happy NY to all !

You need to add --apn infront of your apn:

uqmi -d /dev/cdc-wdm0 --start-network --apn internet

This has no effect unfortunately :

root@OpenWrt:/# uqmi -d /dev/cdc-wdm0 --start-network --apn internet
"No effect"

My version of OpenWRT is the following : OpenWrt 21.02.1, r16325-88151b8303

I have never been able to start the modem using the GUI or to get it connected in any way.
But all commands seems to go through using direct access to the modem on /dev/ttyUSB2.

If you think that your modified kernel has a chance to solve my issue, I'd be happy to give it a try.

Happy new year!

I have uploaded a x86_64 version to Install luci-proto-qmi first.
Download and then install it manually with opkg install uqmi_2021-12-22-0.3_x86_64.ipk.
You may need to add --force-downgrade to opkg command.

Then configure your wwan interface from Luci - Network - Interfaces. Restart interface.

You will see what happens in the System Log or logread | grep 'netifd: wwan'

Good luck :slight_smile:

Thanks a lot for all this support !

I have installed the luci-proto-qmi then downloaded and tried to install the uqmi_2021-12-22-0.3_x86_64.ipk

But this has ended-up with a segfault:

root@OpenWrt:/tmp# opkg install uqmi_2021-12-22-0.3_x86_64.ipk
[54854.099837] opkg[4557]: segfault at 7f61c40ed000 ip 00007f61c40c96b6 sp 00007f61c4055a38 error 4 in[7f61c408d000+49000]
[54854.111443] Code: e9 c7 ff ff ff 90 48 89 f8 48 83 fa 08 72 14 f7 c7 07 00 00 00 74 0c a4 48 ff ca f7 c7 07 00 00 00 75 f4 48 9
Segmentation fault

Should I force downgrade ?
Or is it a problem with the driver ?

Thanks for your help.

Sorry, I had compiled a version for 21.02.0 :frowning:
A new version for 21.02.1 is available at

We are nearly there… but there is "Malformed package file".

root@OpenWrt:/tmp# opkg install uqmi_2021-12-22-0.3_x86_64.ipk
Collected errors:
 * pkg_init_from_file: Malformed package file uqmi_2021-12-22-0.3_x86_64.ipk.

Thanks for your precious help.

I will look in to it, but I´m on holiday until Sunday.

So please enjoy your holiday !

This can wait.


BTW, which target verson of x86 are you using? x86_64?

I think so :

root@OpenWrt:/# uname -a
Linux OpenWrt 5.4.154 #0 SMP Sun Oct 24 09:01:35 2021 x86_64 GNU/Linux


I have uploaded a new compiled file. I tried it in my in my PC Engines APU1 and it was OK.

root@OpenWrt:/tmp# opkg install uqmi_2021-12-22-0.3_x86_64.ipk
Upgrading uqmi on root from 2020-11-22-0a19b5b7-3 to 2021-12-22-0.3...

root@OpenWrt:/tmp# uname -a
Linux OpenWrt 5.4.154 #0 SMP Sun Oct 24 09:01:35 2021 x86_64 GNU/Linux

Unfortunately on my APU 4C4 it doesn't:

root@OpenWrt:/tmp# opkg install uqmi_2021-12-22-0.3_x86_64.ipk
[  103.804126] opkg[3677]: segfault at 7f149959d000 ip 00007f14995796b6 sp 0000]
[  103.815684] Code: e9 c7 ff ff ff 90 48 89 f8 48 83 fa 08 72 14 f7 c7 07 00 09
Segmentation fault

I have also tried with the "force" flag, but it didn't change.
I have upgrade all package to their latest release, no luck either.

Thx for your help.

Just a last try. I updated my "compiling" machine and a new version is uploaded.
What will you get if you add -V2, or higher, to opkg? This will change the verbosity level of opkg.

Thanks again.
Here is my last trial with the last image you have uploaded and the -V2 debug:

root@OpenWrt:/tmp# opkg -V2 install uqmi_2021-12-22-0.3_x86_64.ipk
opkg_conf_parse_file: Loading conf file /etc/opkg.conf.
opkg_conf_parse_file: Loading conf file /etc/opkg/customfeeds.conf.
opkg_conf_parse_fi[85764.031200] opkg[4930]: segfault at 7ff55b96c000 ip 00007ff55b9486b6 sp 00007ff55b8d4a38 error 4 in[7ff55b90c000+49000]
le: Loading conf[85764.043949] Code: e9 c7 ff ff ff 90 48 89 f8 48 83 fa 08 72 14 f7 c7 07 00 00 00 74 0c a4 48 ff ca f7 c7 07 00 00 00 75 f4 48 89 d1 48 c1 e9 03 <f3> 48 a5 83 e2 07 74 05 a4 ff ca 75 fb c3 48 89 f8 9
 file /etc/opkg/distfeeds.conf.
Segmentation fault

And the file in question :

root@OpenWrt:/tmp# cat /etc/opkg/distfeeds.conf
src/gz openwrt_core
src/gz openwrt_base
src/gz openwrt_luci
src/gz openwrt_packages
src/gz openwrt_routing
src/gz openwrt_telephony