Debricking UniElec U7623-06

during the update to openwrt 21.02.01 I did a lot of mistakes... to make it short: The Router is not Booting at all. Now I'm trying to debrick the router with the SP flash tool like the Wiki describes, but I really don’t now how to get/generate the preloader.bin file for the process.

Can somebody explain me how to make or get the preloader file? or maybe

I'm also interested in the mistakes. Upgrading from the vendor's 14.04 to 21.02.1 should be simple: use the normal sysupgrade to the 'legacy' image, then sysupgrade again into the full image. If that didn't work, we should fix it.

Thanks for the bin Files. I will be back home on Tuesday and directly try to flash the them.

To the mistake I made during the update process: I already had the 19.07. on the router since over one year and everything worked fine. I try to updated with the sysupgrade file 21.02. from the wiki. The flash worked well and I could connect to Luci. The system asked me a lot to convert the old configuration files and the most settings were transferred but the WiFi!! The WiFi didn't show up at all... I guess no wifi modules were regcognized from Linux. Than I wanted to go back to 19.07. but just took the kernel.bin and flashed it due Luci by ignoring all warnings... Bahm that's it no connection to the Router anymore. Also I don't get any signals though the serial pins and PuTTY. Just with SP flash tool something happens when I power up.

So again thanks for the Files and I hope I can now bring it back to live and find out what went wrong wit the WiFi and 21.02. I will definitely give you an update. :+1:

Debricking Woks!!!

I used your second link for the .bin file and renamed it:

and the scatter and the img from the official 21.02.1 release:

Now I can access to Luci and ssh as usual... May its a good idea to rename and upload the .bin file to the official Release path???

BUT: still no WIFI --> I will open a new topic for that. Thanks anyway for your help until now.

Yes, we should make the preloader available for download even though it's only a binary.
I'll look at doing that.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.