Debricking RAVPower RP-WD03 using serial?


unfortunately I bricked my RP-WD03 using wrong files via TFTP method. Now my device only shows a green light instead of blue (which meant somehow that the device can be booted into TFTP etc.) and won't respond to any kind of Power-On-Reset combo.

Now I am curious if anyone ever sucessfully recovered such a state e.g. using an UART USB adapter. The device has corresponding connectors inside as a start...

Any hint would be appreciated!

Best regards,

Hey, me too, i bricked mine using sysupgrade.bin for kernel in tftp, while using serial monitor at (57600 baud rate) I could access the test menu and there is an option to boot kernel from the SPI, its pins are just above the sdcard holder(Not sure tho but it makes sense) or from ram, the ram option didn't work for me and gave Bad Magical Number Error Code, using SPI option without connecting any flash, it went looking for tftp server (which was not possible to enable using the button combination), I guess it is just the matter of creating the tftp server with correct file.


Using UART port with (57600 baud rate)

Press (i) at the correct time to enter this mode and use SPI Flash upgrade in the menu option(U).
Use the menu to upload the kernel and rootfs (squashfs files). Prior to that, host a tftp server with ip with the files needed to upload and is connected to rpwd03 via lan cable, after flashing both files reboot the device.
FYI the initram kernel didn't work for me. and wifi was disabled, follow the second part of this if so

@grishnkrj Thanks a lot for your reply! It took me some time to try it out, but today I soldered some cables to the connectors and checked if I could get any response on the serial console, but no success.
I guess I bricked even the bootloader since I can't get the machine to respond no matter what combination of Power On and Reset I tried. The WLAN LED remains green all the time.
I think I have to accept that this thing is now degraded to be a power bank only.

Thanks again and if you have another idea I can try... Highly appreciated.

Best regards,

1 Like

One thing, you used Uart like modem TX ->Rx adapter and modem Rx->Tx adapter right?, When i started out, i made this mistake and thought my GPS module was broken lol. And try changing ur usb to TTL adapter(3.3v), use the one with the ftdi chip.

and don't connect the Vcc pin, three wires only.

Thank you for replying on my issue!

I'm pretty new to serial console and funny stuff like soldering cables to my devices, so I am unsure about the details of your posts. I attached the current setup, the stick used and a detail of the chip on the usb stick.

Is the stick okay for my endeavour?
The Vcc pin is the 3.3V pin, I assume?

Best regards,

yup, disconnect it.

the USB TTL looks just fine.

May I ask one more: What was the procedure to get there in combination with the TTL?

I assume Putty is the way to go. Which are the correct Putty settings?
Speed: 57600
Flow control: XON/XOFF

And what procedure led to success on your end?

  1. Connecting the USB TTL to the WD-03
  2. Connecting the USB to the PC (USB-TTL shows green LED on RX, but never the red one for TX)
  3. Starting up Putty
  4. Powering on the WD-03 (while pressing the Reset Button?)

I'm ending always with an empty putty console and the WD-03 only showing the green light on the WLAN indicator. I think it should at least turn to blue if the bootloader kicked in as this was the behaviour before bricking it...

don't know about speed, but you should never need flow control.

if the speed was wrong, you'd still see garbage in Putty (yes, it's the right tool for this).

even without pressing the reset button, you should get some kind of output, unless the
device's completely dead.

you can verify the USB TTL functionality by shorting its TX and RX pins, you should see
your own typing in Putty, while doing it.

Hey frollic,

thanks again for taking this up.

I tested the stick before by shortening the TX and RX and everything worked as expected, but I don't get any feedback from the device.
Therefor I think this device is simply gone and will transform to his 2nd life as power bank only.
I'm not relying on it anyway. I was just curious if I could fix this thing spending 5 bucks for the USB-TTL (which could come in handy for some tasmota stuff etc. anyway) and learn something.
But it seems this is a dead end.

Thank you all so much for replying on my old thread and keep up the good spirit here!

Thanks again,