Debrick Archer C60 v2

I don't speak English, I'm using Google Translate, I'm sorry if I typed something wrong.

I upgraded to version 19.07.0 but my internet didn't work, my connection is pppoe.
I tried to go back to old version 18.06.4
but it didn't work, now it doesn't even connect through the network cable.
Someone help me?

Alguém me ajuda? eu atualizei para versão 19.07.0 mas minha internet não funcionou, minha conexão é pppoe, tentei fazer downgrade para versão antiga 18.06.4 mas não deu certo, agora não consigo nem conectar pelo cabo de rede, é como se meu pc não tivesse ligado ao roteador, já tentei pelo endereço 192.168.1.1 mas não deu certo. apenas uma luz fica acesa no roteador. Meu inglês não é muito bom.

my router is archer c60 v2

Have you read manual https://openwrt.org/docs/guide-user/network/wan/wan_interface_protocols#protocol_pppoe_ppp_over_ethernet ?

1 Like

no, after i tried to go back to the old version, my router doesn't work even by network cable, it's like it has no connection, 192.168.1.1 doesn't work and my computer can't find it.

I think you need to read the manual. The reason is likely because you need to reinstall the PPPoE packages.

Screenshot from 2020-01-14 12-24-47

1 Like

It looks like he bricked it. It may be possible to fix it, but it can be difficult.

Did you try setting static IP for your computer like 192.168.1.20 and try to ping 192.168.1.1?

What's your native language?

Brazilian Portuguese

OK check my question above about pinging it.

If it doesn't work then then must probably you bricked your router (means you can access it from the GUI or the command line).

It can be possible to debrick (fix or recover).

The easy way can be found here so you can try it. https://www.tp-link.com/eg/support/faq/1482/?utm_medium=select-local. This will revert to TP-Link stock firmware and then you can flash OpenWrt again.

If this way doesn't work with you then the other option will probably be to open thing router and use a TTL adaptor.

The forum language is English, but if your English is not good enough, you can also include the question in your native lemnos in addition to English translation. That way, if translation is not good enough, and someone speaks your language, they can help.

Great idea, I will also add in my language.

Ok if you didn't change any IPs on the router, then I think you bricked your router. Refer to my previous message.

Please also edit the subject line of this post (using the pencil icon at the top) to be Debrick Archer C60. This makes it easier for other people to find your post of they know about your router.

Also search the forum gor Debrick C60. You will find other people who had the same problem and hoe they solved it.

Not that some details can be different between revisions and region. So not all V2 is the same. Be careful about that, especially if you use TP-Link firmware to recover. Read what's at the bottom of your router to see if it says EU, BR, US.

Thanks so much for the help, I got it, I used the TFTP program and will restore to the previous version of openwrt.

If I were you I would try 19.07 and see why it didn't work.

I'll try it later.

1 Like

Hi there
Have you debricked your router?
I had the same problem and returned back to version 18.6 via TFTP
changed the TFTP server port to 22 instead of 69 then rename recovery image (openwrt-18.06.6-ar71xx-generic-archer-c60-v2-squashfs-factory.bin) to tp_recovery.bin set ip address as 192.168.0.66
let me know if you're done successful with that

1 Like

thanks, that's how i did it.

And results?