DDNS not working with PPPoE interface

Hi friends!

One of my ISP uses PPPoE to connect:

config interface 'want'
	option ifname 'eth3'
	option proto 'pppoe'
	option username 'cliente@cliente'
	option password 'cliente'
	option peerdns '1'
	option dns ','
	option ipv6 '1'
	option delegate '0'
	option metric '10'

I'm trying to get ddns to work, but it keeps using curl with eth3, which fails:

# /usr/bin/curl -RsS --interface eth3 -4 --noproxy '*' 'http://v4.ipv6-test.com/api/myip.php'
curl: (7) Failed to connect to v4.ipv6-test.com port 80: Host is unreachable

It must use pppoe-want. I tried messing with the config but found no way for making it use proper interface parameter.

config service 'option_name'
	option enabled '1'
	option service_name 'no-ip.com'
	option domain 'domain.com'
	option lookup_host 'domain.com'
	option username 'login'
	option password 'pass'
	option interface 'ppoe-want'
	option bind_network 'want'
	option force_ipversion '1'
	option force_interval '2'
	option ip_source 'web'
	option ip_url 'http://v4.ipv6-test.com/api/myip.php'

typo? did you get that right in your test?

1 Like

Indeed it was, but that doesn't affect it. I never made it use pppoe-want, it keeps using eth3.

Well I tried to find where it builds the request string and sets curl parameter and am unable to. But it was easy to find noip's URL.

So I just added it to my monitor and am directly sending addr updates there.

Indeed it's pretty easy, most of ddns's complexity is for being able to support multiple devices and noip services and LuCI.

I think OpenWRT PPPoE support should be improved. There are many ppl having routing issues, ping and traceroute getting permission error, and the change on interface's name while not accepting original interface makes harder to support for other softwares like ddns.

After installing 21.02RC1 I started having the same problem, and I fixed it be reverting this change from last October: https://github.com/openwrt/packages/pull/13183 and added some comments there but have not got a response yet.

Can this commit be reverted? https://github.com/openwrt/packages/commit/5b362932a7df5ce44ca3a8f4cf1d2b225ca8d5ae

1 Like