DDNS "dynu.com" configuration troubleshooting

I'm trying to setup DDNS for dynu.com, but I had no luck, via LUCI neither via config file in /etc/config/ddns.

According to this I should put this info in /etc/config/ddns
however, when I config via LUCI there is one more line in that file, which is
option lookup_host ' '
I'm not sure what to put in here, since the [DOMAIN] parameter is set in the other line, but I filled it with my domain as well...

Anyway it doesn't work. The IP should be different, and this error appears at the top of the page:

my /etc/config/ddns is like this:

config ddns 'global'
	option ddns_dateformat '%F %R'
	option ddns_loglines '250'
	option ddns_rundir '/var/run/ddns'
	option ddns_logdir '/var/log/ddns'

config service 'dynu'
	option enabled '1'
	option lookup_host '*MYDOMAIN*'
	option use_ipv6 '0'
	option service_name 'dynu.com'
	option domain '*MYDOMAIN*'
	option username '*MYUSER*'
	option password '*MYPW*'
	option ip_source 'network'
	option ip_network 'wan'
	option interface 'wan'
	option use_syslog '2'
	option check_unit 'minutes'
	option force_unit 'minutes'
	option retry_unit 'seconds'

config service 'myddns_ipv6'
	option update_url 'http://[USERNAME]:[PASSWORD]@your.provider.net/nic/update?hostname=[DOMAIN]&myip=[IP]'
	option lookup_host 'yourhost.example.com'
	option domain 'yourhost.example.com'
	option username 'your_username'
	option password 'your_password'
	option use_ipv6 '1'
	option interface 'wan6'
	option ip_source 'network'
	option ip_network 'wan6'
	option enabled '0'

Still no luck

lookup_host is probably the host, on internet, telling you what public IP you're using.

1 Like

Check the log first!

1 Like

on the log, right after the url request there is the issue:

121505       : DDNS Provider answered:

but the request should be good:

122623       : #> /usr/bin/curl -RsS -o /var/run/ddns/dynu.dat --stderr /var/run/ddns/dynu.err --interface pppoe-wan --capath /etc/ssl/certs --noproxy '*' 'https://api.dynu.com/nic/update?hostname=XXXXX&myip=XXX.XXX.XXX.XXX&username=XXXXX&password=***PW***'

I've already tried with plain text password or md5sum..

can I increase the log level to be more verbose?

... and if you run the curl command manually, from the prompt ?

1 Like

The folowing does work for me as a test
curl "https://api.dynu.com/nic/update?hostname=host.domain.tld&password=md5hash"

where md5hash is MD5 hash of IP Update Password

1 Like

fwiw, have you logged into dynu website to check whether the IP address has actually updated?

Is your router connected directly to the internet, or is it sitting behind another ISP facing router?

fwiw, I witnessed a bizarre issue when LuCI would not report the 'correct' IP address when I installed OpenWrt 19.07 on a new box last week along with the DDNS packages. I don't know exactly what I did, but rebooting the router and closing restarting the web browser resolved the problem with LuCI for both duckdns and dynu DDNS.

config service 'dynu_ipv4'
	option retry_count '3'
	option use_syslog '0'
	option use_logfile '0'
	option service_name 'dynu.com'
	option lookup_host 'myhost.ddnsfree.com'
	option domain 'myhost.ddnsfree.com'
	option username 'username'
	option password 'password'
	option enabled '1'

ps. the above is from another working router. Only difference between the two routers is I increased the retry_count.

Just tried curl, the ip is not changed on dynu website (nor on luci). Still receive badauth


it's directly connected to internet, no ISP router behind.

I've tryed your minimal conf, adapted with my data, but is not working.

Strange thing is LUCI is showing IP is updated, but it is not :frowning:

OMG I just realized I was using wrong password :weary:

thank you all

Please mark thread as solved.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.