DDNS do not start when reboot

root@OpenWrt:~# service list | grep ddns
/etc/init.d/ddns                   enabled         stopped
root@OpenWrt:~# logread -e ddns
root@OpenWrt:~#

I can run the service without problem if I run it manually.
Please tell me if you need more info.

Try putting

sleep 5
/etc/init.d/ddns restart

In your local startup script.

Is there any reason? I haven't seen error log.

There might be a race condition.

Are you sure the ddns service is enabled?

But I'm not aware of any issues, so it's just a possible workaround.

1 Like

I'm pretty sure it's enabled. at least from:

root@OpenWrt:~# service list | grep ddns
/etc/init.d/ddns                   enabled         stopped

I also executed /etc/init.d/ddns enable and service ddns enable

Is there anything in the logs about ddns after you reboot your router?

1 Like

nothing there.

root@OpenWrt:~# logread -e ddns
root@OpenWrt:~#

Looks like a race condition, see:

ls -1 /etc/rc.d

It's usually related to DNS encryption or VPN.

root@OpenWrt:~# ls -1 /etc/rc.d
K10ddns
K10gpio_switch
K15openclash
K21wpad
K50dropbear
K85odhcpd
K89log
K90boot
K90network
K90sysfixtime
K90umount
S00sysfixtime
S00urngd
S10boot
S10system
S11sysctl
S12log
S12rpcd
S19dnsmasq
S19dropbear
S19firewall
S19wpad
S20network
S35odhcpd
S50cron
S50uhttpd
S60etherwake
S80ucitrack
S94gpio_switch
S95ddns
S95done
S96led
S98sysntpd
S99bootcount
S99openclash
S99set-irq-affinity
S99urandom_seed

I'm not that familiar with Linux, is there any keyword I should use to search on google?

1 Like

openclash doesn't appear to be part of the openwrt repository, are you running a 3rd party FW ?

it starting after ddns could also be the reason why the latter fail.

Oh god, I just deleted openclash, then everything is crashed, so I restore to factory default and set ddns again, but it still can't start automatically.