DD-WRT to OpenWrt LAN ports not working on WRT350N v1

I'm tinkering with an old Linksys WRT350N v1.
I began by flashing from stock firmware to DD-WRT and all was fine then I wanted to try Gargoyle but couldn't get it to boot after flashing, but still was able to get ttl=100, so I flashed back to DD-WRT then thought I would try OpenWrt. I tftp flashed openwrt-19.07.7-brcm47xx-generic-linksys-wrt350n-v1-squashfs waited about 10 minutes then did a 30-30-30 reset and the router seemed to have bricked..ping replied with a general failure.Tried all the LAN ports and none are working.
Soldered up a serial cable and it boots to a point that says something about a bus error press F for failsafe (which i tried with no luck) then it boots further until it shows the OpenWrt wireless freedom screen.
I tried the " Barryware Instructions for Linksys" serial recovery guid from the DD-WRT wiki with no luck.
With the LAN ports not working is it possible to tftp through the serial connection itself?

Is there anu way to fix this? I am a linux and router newb, but we all got start somewhere lol


Likely still an unresolved bug on that model.


Older Broadcom hardware is dd-wrt's wheelhouse, the WRT350 will probably do best running that instead of OpenWrt.

I wouldn't mind going back to dd-wrt I'm just not sure how to do it.
what do I need to do to go back to dd-wrt?


Most CFE has web-based recovery which you could use to flash stock, then boot up the stock and install dd-wrt.

Hold down the reset button while turning the power on, and keep holding until the LEDs do something unusual. Then look for a recovery page at You may need to static IP the PC.

1 Like

Thanks for the reply.
I've tried every trick I could find posted on the internet to get to a recovery web page with no luck.
Since the LAN ports are dead (windows doesn't show a cable plugged in and ping returns with general failure) Is it possible to transfer a firmware to the router via the serial cable itself?
Or is there a way to activate the LAN ports at the CFE prompt when connected through serial?


I finally got it working and flashed back to DD-WRT.
There probably isn't many people tinkering with such an old router, but just in case the solution was to open a serial connection, plug router in and Ctrl+C to get to the CFE prompt.
Then enter these 2 commands nvram set boot_wait=on and nvram commit.
Router became pingable and I finally got a ttl=100 and was able to tftp dd-wrt.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.