Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds


#1599

I did some experimenting on a WRT1900AC V1 since the LAN Marvell Switch Marvell 88E6172 is very similar to the WRT3200ACM LAN Switch Marvell 88E6352 (same port numbers etc.)

I am focusing on the LAN LEDs as I seem to be able to set the other LEDs via LUCI LED Configuration page.

I tried your recommendation to add a switch command in the network config file (/etc/config/network) but I tried a lot of combinations and no effect at all. I added the following in the config file:

config switch_port                                                 
        option device 'switch0'
        option port '3'                                            
        option led '0'

According to the switch setup Port 3 is LAN 1 on the router but I tried Port 1 to Port 6, restarted the network on each change and no effect at all on the LAN LED.

I then tried another logic and left it on Port 3 and changed "option led" from 0 to 10 and restarted the network on each change. Still no effect at all.

Does anyone have any ideas on what else i should try to control the LAN LEDs on a WRT3200ACM or WRT1900AC V1?


#1600

Nothing special, just cake/layer_cake for the queueing discipline, ethernet with 18 byte overhead for the link layer adaptation (recommended setting for a cable modem) and manually tweaked upload and download (11430/207000) after a few passes through http://www.dslreports.com/speedtest to get the best settings. Oh, and make sure QoS service is disabled; no point running SQM QoS and QoS at the same time.

This was the best run I had with these settings last summer, pretty good for a service that's sold as 200 down / 12 up:


#1601

I just found this link but i am not sure if there is any useful information regarding LEDs. I'm still missing the possibility to turn off all LEDs on my WRT1900ACSv2 in openwrt as well :frowning:

https://wiki.dd-wrt.com/wiki/index.php/Linksys_WRT1900AC#LEDs_and_GPIO_pins

//Edit:
Maybe also https://wiki.dd-wrt.com/wiki/index.php/LED_Scripts#Linksys_WRT1900AC
https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1066496&sid=a9943c0dfcf882ca51c95d529a02e84d

i've succeeded to turn off WAN led with "gpio disable 6" Smile but not the WLAN leds... i've tried also examples from the link supplied in LED scripts of DD-WRT it didnt work unfortunately...


#1602

First off I apologize if I missed this from this post or David's site itself. I did do some searching but came up short. Feel free to light me up if there is already a location for this.

Question is.. is there a quick list of differences provided in David's build versus the standard openwrt images? I have a mamba and venom and really like openwrt. Trying to determine if I should be running David's build over the standard openwrt image.


#1603

Unfortunately, the GPIO does not seem to work for the LAN LEDs, at least I could not figure it out.

Concerning your issue:

I am using a WRT1900 for trials and yours should be similar. Use the "System - LED Configuration" in Davidc502 build where you can setup the following LEDS:
image

You can add/delete/modify as you need. I recommend that you setup an entry for all selections (11) and set to "Trigger" = "Always On" and then "Always OFF" to ensure you have control of the LEDs. Save & Apply in-between the changes. Save the original "/etc/config/system" so you can go back to it.

On my WRT3200ACM I could control all LEDs except the 4 LAN LEDs.

On the WRT1900AC V1 the 2.4 & 5 GHz did not work and the eSata turned on the Internet LED. Seems to be a mix-up of the LED controls on the WRT1900AC V1.

This is well beyond my expertise to figure out why.


#1604

https://davidc502sis.dynamic-dns.net/releases/lede-mvebu-cortexa9.manifest

The packages in the manifest are in addition to the daily snapshots.


#1605

Hi,

Been running Davids version for the WRT1900AC v1

It really saved me from the dreaded reboots on the other "open versions"...

Today I decided to update the firmware (the old one worked great, but for security reasons I decided that it was not smart to use a year-old firmware), and it worked fine with flashing the bin-file for Mamba within the browser-GUI (I'm not an SSH kind of guy).

The router rebooted, and my Ubiquity AP works fine, and I have internet, and wireless connection through my AP.
However I have always been running wireless networks from the router also (different SSID from my primary SSID provided by the the AP), but none of the wireless LED on the front of the router is lit.

Inside the GUI I can se, that the following message is displayed under both 2,4 and 5 ghz wifi (my old SSID and settings is there): " Wireless is not associated"

I tried to restart with the button next to each wifi status. But that doesn't help.

Any idea what is up, and is there a fix?

Edit: My old settings used radio0 (2,4) and radio1 (5 ghz)..
I tried to disable those, and then change the settings at radio2 and radio3 with the SSID used with radio0 and radio1.

Everything seems to work now.. And i have just Radio0 and Radio1 as diabled, and Radio2 and Radio3 running.


#1606

Thanks David


#1607

What's the default openwrt kernel timer frequency?


#1608

Hmmm.....

root@TTrollstation:/sys/class/leds# ls
mmc0::                      pca963x:0:68:15             pca963x:rango:white:usb2    rango:white:sata
pca963x:0:68:10             pca963x:0:68:2              pca963x:rango:white:usb3_1  rango:white:wlan_2g
pca963x:0:68:11             pca963x:0:68:3              pca963x:rango:white:usb3_2  rango:white:wlan_5g
pca963x:0:68:12             pca963x:0:68:4              pca963x:rango:white:wan
pca963x:0:68:13             pca963x:rango:amber:wan     pca963x:rango:white:wps
pca963x:0:68:14             pca963x:rango:amber:wps     rango:white:power

It's my 3200. I'm a bit away from it last days, but check pca's leds then return back.

PS: Did you read the first link i send? Don't use trigger (firmware will enable it again), use brightness instead.


#1609

100Hz as found in the config files under ./target/linux/generic/config-*. Mvebu inherits this value (however, some chipsets override this setting to 250Hz, like Lantiq).

Changing this might not be as useful as you think given that CONFIG_SCHED_HRTICK and CONFIG_HIGH_RES_TIMERS are enabled in the generic profile (and MVEBU inherits these values too). This means that only schedule_timeout() or anything else that uses jiffies for time accounting are the only things really affected by changing this value


#1610

Thanks! I had a hunch it was but was unsure.


#1611

I think I tried all suggestions without success but which one do you mean?

BTW the LED files in "/sys/class/leds" are symbolic links to various locations:

root@FIREBASEROUTER:/sys/class/leds# ls -la
drwxr-xr-x    2 root     root             0 Jan  1  1970 .
drwxr-xr-x   41 root     root             0 Jan  1  1970 ..
lrwxrwxrwx    1 root     root             0 Jan  1  1970 mmc0:: -> ../../devices/platform/soc/soc:internal-regs/f10d8000.sdhci/leds/mmc0::
lrwxrwxrwx    1 root     root             0 Jan  1  1970 pca963x:0:68:10 -> ../../devices/platform/soc/soc:internal-regs/f1011000.i2c/i2c-0/0-0068/leds/pca963x:0:68:10
lrwxrwxrwx    1 root     root             0 Jan  1  1970 pca963x:0:68:11 -> ../../devices/platform/soc/soc:internal-regs/f1011000.i2c/i2c-0/0-0068/leds/pca963x:0:68:11
lrwxrwxrwx    1 root     root             0 Jan  1  1970 pca963x:0:68:12 -> ../../devices/platform/soc/soc:internal-regs/f1011000.i2c/i2c-0/0-0068/leds/pca963x:0:68:12
lrwxrwxrwx    1 root     root             0 Jan  1  1970 pca963x:0:68:13 -> ../../devices/platform/soc/soc:internal-regs/f1011000.i2c/i2c-0/0-0068/leds/pca963x:0:68:13
lrwxrwxrwx    1 root     root             0 Jan  1  1970 pca963x:0:68:14 -> ../../devices/platform/soc/soc:internal-regs/f1011000.i2c/i2c-0/0-0068/leds/pca963x:0:68:14
lrwxrwxrwx    1 root     root             0 Jan  1  1970 pca963x:0:68:15 -> ../../devices/platform/soc/soc:internal-regs/f1011000.i2c/i2c-0/0-0068/leds/pca963x:0:68:15
lrwxrwxrwx    1 root     root             0 Jan  1  1970 pca963x:0:68:2 -> ../../devices/platform/soc/soc:internal-regs/f1011000.i2c/i2c-0/0-0068/leds/pca963x:0:68:2
lrwxrwxrwx    1 root     root             0 Jan  1  1970 pca963x:0:68:3 -> ../../devices/platform/soc/soc:internal-regs/f1011000.i2c/i2c-0/0-0068/leds/pca963x:0:68:3
lrwxrwxrwx    1 root     root             0 Jan  1  1970 pca963x:0:68:4 -> ../../devices/platform/soc/soc:internal-regs/f1011000.i2c/i2c-0/0-0068/leds/pca963x:0:68:4
lrwxrwxrwx    1 root     root             0 Jan  1  1970 pca963x:rango:amber:wan -> ../../devices/platform/soc/soc:internal-regs/f1011000.i2c/i2c-0/0-0068/leds/pca963x:rango:amber:wan
lrwxrwxrwx    1 root     root             0 Jan  1  1970 pca963x:rango:amber:wps -> ../../devices/platform/soc/soc:internal-regs/f1011000.i2c/i2c-0/0-0068/leds/pca963x:rango:amber:wps
lrwxrwxrwx    1 root     root             0 Jan  1  1970 pca963x:rango:white:usb2 -> ../../devices/platform/soc/soc:internal-regs/f1011000.i2c/i2c-0/0-0068/leds/pca963x:rango:white:usb2
lrwxrwxrwx    1 root     root             0 Jan  1  1970 pca963x:rango:white:usb3_1 -> ../../devices/platform/soc/soc:internal-regs/f1011000.i2c/i2c-0/0-0068/leds/pca963x:rango:white:usb3_1
lrwxrwxrwx    1 root     root             0 Jan  1  1970 pca963x:rango:white:usb3_2 -> ../../devices/platform/soc/soc:internal-regs/f1011000.i2c/i2c-0/0-0068/leds/pca963x:rango:white:usb3_2
lrwxrwxrwx    1 root     root             0 Jan  1  1970 pca963x:rango:white:wan -> ../../devices/platform/soc/soc:internal-regs/f1011000.i2c/i2c-0/0-0068/leds/pca963x:rango:white:wan
lrwxrwxrwx    1 root     root             0 Jan  1  1970 pca963x:rango:white:wps -> ../../devices/platform/soc/soc:internal-regs/f1011000.i2c/i2c-0/0-0068/leds/pca963x:rango:white:wps
lrwxrwxrwx    1 root     root             0 Jan  1  1970 rango:white:power -> ../../devices/platform/gpio-leds/leds/rango:white:power
lrwxrwxrwx    1 root     root             0 Jan  1  1970 rango:white:sata -> ../../devices/platform/gpio-leds/leds/rango:white:sata
lrwxrwxrwx    1 root     root             0 Jan  1  1970 rango:white:wlan_2g -> ../../devices/platform/gpio-leds/leds/rango:white:wlan_2g
lrwxrwxrwx    1 root     root             0 Jan  1  1970 rango:white:wlan_5g -> ../../devices/platform/gpio-leds/leds/rango:white:wlan_5g

#1612

https://davidc502sis.dynamic-dns.net/
says " The 1900ac has the cpu idle (Reboots on latest kernels) issue resolved"

I have been having reboot issues for a little while now (WRT1900AC - Random reboots) and just wondering if that comment could be the cause.

im running 18.06.01 openwrt on wrt1900ac (mamba) with the latest mwlwifi drivers (from: https://github.com/eduperez/mwlwifi_LEDE/releases) would/could it apply?

on that website it links to an img file, to flash lede, is there any equivalent patch for openwrt?


#1613

Not that I'm aware.

18.06.01 is from Fri Aug 17 2018. I recommend going to 18.06.02 OR download and flash the image from the davidc502 site. Ether of those are patched to resolve the reboot issue.


WRT1900AC - Random reboots
#1614

Has anyone tested at 1000hz kernel timer? Specifically refering to sqm for any relatable differences in performance on the 3200ACM...


#1615

It's probably best if you start a new topic instead of hijacking this one since kernel timer frequencies are done at compile time and I don't think @davidc502 or his users will or have had changed MVEBU's kconfigs.

I will say this though, I've tried running these kernel configurations on my 1900ACSv2:

  1. PREEMPT_NONE; HZ=100 - Ethernet has tight latencies with SQM but wifi will have a max latency of +20-40ms from the average (depending on number of clients connected).
  2. PREEMPT_FULL; HZ = 100 - Ethernet displays the same behaviors as standard config but wifi is incredibly jittery. I was experiencing quite a bit of packet loss and the max latency would randomly go up to the +100ms (for either upload/download/idle). Other tasks running on the device could have probably caused some important wireless/bufferbloat related irqs to pause.
  3. PREEMPT_VOLUNTARY; HZ = 250 - Again, ethernet displays the same behavior as in the default standard configuration. Wifi's max latencies is around +10-20ms from average (even with tens of clients).
  4. PREEMPT_VOLUNTARY; HZ = 1000 - Same behavior as (3).

Testing was mostly done with just dslreports, so take it all with a grain of salt. WAN speed at 30/30Mbps. Wireless tests were conducted from a distance of 2.4GHz and 5GHz at 10-15m away with an RSSI of -58 to -62 (noise -90) on a mid-2015 rMBP. I couldn't really be bothered to setup iperf on two machines. I didn't try PREEMPT_FULL; HZ = 1000 because that would have probably sacrificed throughput quite a lot (and may have been a bit unstable). So with this really crude method, ethernet latencies aren't affected, but wifi could be. However, I'd hesitate to state any conclusion given n=1 and a lack of a complete and proper testing tool/methodology.

Also, apologies to anyone reading this as it's unrelated to @davidc502's build.


#1616

@davidc502 : how come you use this config:
CONFIG_KERNEL_MIPS_FPU_EMULATOR=y

All Linksys WRT has built in hardware FPU, i never used that (only on my D-LINK D860L B1 - which needs FPU emulator), so how come you enable this?

(I found it in you config.seed file)
https://davidc502sis.dynamic-dns.net/releases/config.seed

If it was not built in (#CONFIG_KERNEL_MIPS_FPU_EMULATOR is not set) it would not worked at with NodeJs 11 (based on https://github.com/nxhack/openwrt-node-packages) and it works.

It is ARM, so i guess it is not used in the build?


#1617

Had been looking for a list of packages you added but never asked... Is there any benefit to us removing packages we don't need from your builds once installed? For example, I have the WRT32X and don't need all the mwlwifi firmwares you have, just the 8964. Or is the extra stuff not hurting anything being there?Thanks.


#1618

If you need the space, remove them. Otherwise.... eh :slight_smile: