Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds


#1579

Ohh... In fact, it's not so bad news for me - i work with Foxconn for some of my projects.
I'll ask them about plans... And maybe give some suggestions.

PS: I'm admiring about 802.11ax - it's really cool stuff. Hope it will be possible to add it by firmware for our hardware.


#1580

got it, thanks.


#1581

WRT32X's driver is buggy.
It doesn't accept custom mac address (option macaddr) for both 2.4 and 5ghz.
Also the issues with ESP8266 - ESP8285 (eg Sonoff Devices).
Linksys' driver works flawlessly. Any way to extract the driver from the Linksys firmware?
I can extract their .img and see the filesystem (Which also has a lot of trash inside from previous versions)


#1582

"Should" be no issues. I mean he might be right, but that doesn't really sound like a concrete answer or that anyone has tried a proof-of-concept to see if it is indeed vulnerable or not.

I don't mean this in any way as a criticism of yuhhaurlin, but it's pretty obvious that English is not his first language, so I don't think you should read to much into the subtleties of his use of "should" as opposed to "will" in that context.


#1583

Gotcha, thanks for keeping me grounded. Hopefully I didn't come off as too harsh / rude because after re-reading what I wrote it kind of seemed that way. I just don't want to blow over a potential security issue without knowing to the best of my ability that it has been taken care of so tried to put in my due diligence to understand what's going on.


#1584

There is nothing wrong with ringing the bell to make everyone aware. Cyber security is a very important facet in almost everyone's lives these days, so awareness is everything.


#1585

Just wanted to say a thank you to @davidc502 for his build and the wider OpenWrt project. What prompted this? I'm currently saturating my 200mb/s cable broadband (actually peaking at around 210mb/s) with five big bittorrent downloads and watching a 4k Netflix stream at the same time. The WRT32X isn't breaking a sweat and SQM is doing a fantastic job of stopping the buffer bloat and keeping the video flowing perfectly.

Seriously impressive :+1:t2:


#1586

Appreciate the thanks, but really all the thanks goes to the developers who do the work to keep the OpenWrt project going.

Around 3 years ago I flashed Openwrt on the 1900ac V1, and started learning about the project. Eventually, compiled OpenWrt firmware because I wanted to add certain packages trunk didn't provide by default as well as the satisfaction of just doing it myself. I mentioned to a few people, after my first build, that I had flashed the firmware, and there was interest from other people they wanted to try it. Initially, I just put the images on my ISP's provided website, and people started giving mostly positive reviews, and encouraged me to expand a bit. So, I stood up a very basic web server and started uploading builds about once every 2 weeks to continue sharing. Over the past 3 years I've had multiple offers of money including donations, but have turned all of it down as I'm not doing this for money. Unfortunately, I don't get to spend a lot of time on this project, but it is enough to help keep certain skills from going too dull, and I get to continue to learn as time goes by which is a win win for the I.T. work I do.


#1587

@WiteWulf
Can you please share your SQM config?


#1588

No problems here setting different MAC address. What are you trying to set it to?


#1589

New builds have been uploaded to the server and are ready for download.
There have been no changes in the wifi driver since the last build.
There are a couple of kernel "bumps".

Kernel version = 4.14.98
WiFi driver = 10.3.8.0-20181210
Build = r9287

https://davidc502sis.dynamic-dns.net


#1590

I have 3 different SSIDs on my 2.4 radio.
When i set one mac the specific network works, but the others get unaccessible prompting "wrong password", although clearly the password is unchanged.
The exact same behavior with the 5ghz also.


#1591

David,
Thanks for the new build. I'm going to show how lazy I am and request that it'd be nice if your dnscrypt-proxy2.sh scipt installed the binary that has been through compression with upx rather than the uncompressed version. :grinning:


#1592

Thank you very much for your work.


#1593

What MAC specifically are you using?
My theory being that you are setting the “group address” bit without realising.

Make sure that the second digit i.e. the second “1” in the following:
11:22:33:44:55:66
Is an even number e.g. 0,2,4,6,8,A,C or E


#1594

@davidc502 installed the last release. The menù list won't open on rosy.
The material theme i've installed from repository it's now with fixed style, don't know if they did fix it long time ago.


#1595

Looks like rogue AP attack prevention for me. Did you try to remove saved network then connect again for this SSIDs?


#1596

https://wiki.wireshark.org/SnapLen


#1597

For example i tried setting one to dc:0d:ac:fc:ac:71 and the other to dc:0d:ac:fc:ac:32


#1598

Thanks a lot. That was useful.
PS: the solution wasn't working. Still WMM only solution.