Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds

It's amusing, I too was a little concerned something happened to David. I'm running r9028 now on my WRT1900ACS. Thanks for the new build. I'm happy to use the updated adblock which now can provided statistics.

Thanks -- It was time for a vacation :wink:

1 Like

I have been unable to complete an upgrade the past month or so, Upon flashing, the window just hangs and then goes back to the main screen without upgrading or rebooting. Any idea what's going on? Tried multiple downloads to ensure it wasn't a bad file. I read back a few pages and tried searching for similar problems but perhaps I am blind if there was a simple solution :D.

Thanks in advance.

As always, thanks for your great work and contribution.

I upgraded to r9028 from the command line from r8614. Upgrade went fine. However, when I try to run 'opkg update' I get errors such as:

* opkg_download: Failed to download https://davidc502sis.dynamic-dns.net/snapshots/r9028/targets/mvebu/cortexa9/packages/Packages.gz, wget returned 5.

If I check in Chrome, your LetsEncrypt certificate is valid.

Thanks for any insight.

I just had the same thing happen. The 2019-01-13 image SHA-128 was correct when verified via a utility. The image SHA-128 for the same file was NOT correct during the upgrade of the router. I advanced rebooted to my router the the alternate partition. This time the SHA-128 was correct when reported during the update and the upgrade to the 2019-01-13 image was a success.

Possibly related to all of this download failed / checksum failed madness, there's been several times where I've tried to download something with wget on the command line over HTTPS and have it bomb out (it was an IPK I was trying to grab). Ended up just SCPing the file over from my PC directly to OpenWrt and then install and sure enough, worked great.

I also had all of the pre-reqs installed for HTTPS such as the ca-certificates and ca-bundles at the time.. and it let me download it, but the size of the file did not entirely line up with the file I copied over locally with SCP and by association the checksum was also wrong (file was corrupted).

I don't think this is a problem with your build in particular, but something with OpenWrt and HTTPS is my theory. Thought I'd throw my $0.02 in here with my experiences so far, and best of luck nailing this annoying bug down.

5 is a SSL error. Make sure you have the SSL libraries needed for the connection. The build will have these by default. Were they removed?

I didn't intentionally remove any packages :slight_smile: I did run the dnsproxy2 script. For wget, it looks like all dependencies are installed:

root@Wrt3200acm:~# opkg list wget
wget - 1.20.1-1

root@Wrt3200acm:~# opkg list-installed |grep libopenssl
libopenssl - 1.0.2p-1

Same is true for other packages:
wget depends on:

Thanks for any further insight.

HELP! I'm running r8873 on a WRT1900AC. I've been running David builds for roughly 1.5 years. Suddenly today I'm unable to to upgrade to the newest release as I am out of space on the router. I have no idea how that happened, or how to fix. Any suggestions? I run ZERO additional packages.. Just a straight David install..



Good news is you're not out of space. /rom always shows 100%

root@lede:~# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                15.0M     15.0M         0 100% /rom
tmpfs                   249.5M      5.1M    244.4M   2% /tmp
/dev/ubi0_1              45.8M      4.6M     38.9M  10% /overlay
overlayfs:/overlay       45.8M      4.6M     38.9M  10% /
ubi1:syscfg              70.2M    472.0K     66.1M   1% /tmp/syscfg
tmpfs                   512.0K         0    512.0K   0% /dev

What is the error message when trying to sysupgrade?

Well, that was strange...

/dev/ubi0_1 and overlayfs/overlay were both at 100%... I rebooted and they went to 30% (when I took the screen shot)... I got the BIN file copied and did the sysupgrade... It SEEMS ok for now!?

1 Like

what happens when you run the following command manually?

wget https://davidc502sis.dynamic-dns.net/snapshots/r9028/targets/mvebu/cortexa9/packages/Packages.gz

Works like a charm... everything is running fine now.

I get certificate error, Summarized output as I can't put in several links.

wget ....

--2019-01-13 09:00:49--
Resolving ..
Connecting to ||:443... connected.
ERROR: no certificate subject alternative name matches
requested host name 'davidc502sis.dynamic-dns.net'.
To connect to davidc502sis.dynamic-dns.net insecurely, use `--no-check-certificate'.

Appears to not be resolving the IP address properly.

Please run the following command - #nslookup davidc502sis.dynamic-dns.net

It should resolve to

C:\Users\davidc502>nslookup davidc502sis.dynamic-dns.net
Server:  lede.lan

Non-authoritative answer:
Name:    davidc502sis.dynamic-dns.net

Yes, that seems to be my problem: (modifying output so the post goes through)

root@Wrt3200acm:/etc# nslookup davidc502sis...net

Name: davidc502sis...net
Address 1:
*** Can't find davidc502sis....net: No answer

The 162,150.21.51 address seems to be an incorrect Xfinity DNS server, I think.
Devices attached to my router have no problem. (Again, I did run the dnscrypt-proxy2.sh script).

It's unclear to me what settings to check or changes, so thanks again for any insight.

On the WAN interface uncheck the box that says to use advertised ISP dns servers, and try again.

I appreciate the help. At this point, am I better off flashing *_squashfs_factory.img to reset, then restoring a backup file of settings?

I unchecked the box "Use DNS servers advertised by pee.r" If I try nslookup, I get, e.g.,:
root@Wrt3200acm:~# nslookup http://google dot com

** server can't find google_dot_com: NXDOMAIN
Name: google_dot_com

I also tried setting "Use DNS servers advertised by peer" to 1 dot 1 dot 1 dot 1, but get same error."

Forwarding is not working. Since you are using dnscrypt-proxy V2, check the forward. Under DHCP DNS tab, make sure the for DNS forwarding says

Stick with this a little while longer before resetting or restoring.


Looking at this again.... You are getting a return of Non Existent Domain... , so that means a dns server is found.

I'm not sure if you were just typing out "dot com" or if you actually used .com ????