Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds


#1397

On the WAN interface uncheck the box that says to use advertised ISP dns servers, and try again.


#1398

I appreciate the help. At this point, am I better off flashing *_squashfs_factory.img to reset, then restoring a backup file of settings?

I unchecked the box "Use DNS servers advertised by pee.r" If I try nslookup, I get, e.g.,:
root@Wrt3200acm:~# nslookup http://google dot com
Server: 127.0.0.1
Address: 127.0.0.1#53

** server can't find google_dot_com: NXDOMAIN
Name: google_dot_com

I also tried setting "Use DNS servers advertised by peer" to 1 dot 1 dot 1 dot 1, but get same error."


#1399

Forwarding is not working. Since you are using dnscrypt-proxy V2, check the forward. Under DHCP DNS tab, make sure the for DNS forwarding says 127.0.0.1#5300

Stick with this a little while longer before resetting or restoring.

EDIT

Looking at this again.... You are getting a return of Non Existent Domain... , so that means a dns server is found.

I'm not sure if you were just typing out "dot com" or if you actually used .com ????


#1400

I can't post if I include more than two web addresses, so I'm using "shorthand" in the posts.

The DNS forward under DHCP DNS is correct. For computers connecting to the router, DNS is working fine, and it's correctly using Cloudflare (according to dnsleaktest_dot_com).

The problem seems to only be from the router itself. From nslookup, the router seems to use the DNS server listed in resolv.conf - which are bogus.

In case it's useful info, here's the top of the output for "uci show dhcp"

dhcp.@dnsmasq[0]=dnsmasq
dhcp.@dnsmasq[0].domainneeded='1'
dhcp.@dnsmasq[0].localise_queries='1'
dhcp.@dnsmasq[0].rebind_protection='1'
dhcp.@dnsmasq[0].rebind_localhost='1'
dhcp.@dnsmasq[0].local='/lan/'
dhcp.@dnsmasq[0].domain='lan'
dhcp.@dnsmasq[0].expandhosts='1'
dhcp.@dnsmasq[0].authoritative='1'
dhcp.@dnsmasq[0].readethers='1'
dhcp.@dnsmasq[0].leasefile='/tmp/dhcp.leases'
dhcp.@dnsmasq[0].noresolv='1'
dhcp.@dnsmasq[0].nonwildcard='1'
dhcp.@dnsmasq[0].server='127.0.0.1#5300'
dhcp.@dnsmasq[0].serversfile='/tmp/adb_list.overall'
dhcp.@dnsmasq[0].localservice='1'
dhcp.lan=dhcp
dhcp.lan.interface='lan'
dhcp.lan.limit='150'
dhcp.lan.leasetime='12h'
dhcp.lan.start='150'
dhcp.lan.ra='disabled'
dhcp.lan.dhcpv6='disabled'
dhcp.lan.ra_management='1'
dhcp.wan=dhcp
dhcp.wan.interface='wan'
dhcp.wan.ignore='1'
dhcp.odhcpd=odhcpd
dhcp.odhcpd.maindhcp='0'
dhcp.odhcpd.leasefile='/tmp/hosts/odhcpd'
dhcp.odhcpd.leasetrigger='/usr/sbin/odhcpd-update'
dhcp.odhcpd.loglevel='4'

#1401

Yeah, that's odd because it should forwarding to dnscrypt proxy which is listening on port 5300.

Try editing /etc/resolv.conf and set the value to 127.0.0.1#5300 and try again.

If that doesn't work, I'm running out of ideas :wink:


#1402

Latest status: "opkg update" works (I get Signature check passed.) and I can wget an https page (e.g., google). This is good, of course.

However, if I run (replace . with _):

nslookup https://google_com
Server:         127_0_0_1
Address:        127_0_0_1#53

** server can't find https://google_com: NXDOMAIN
Name:      https://google_com

This seems weird to me. (Same error if I run " nslookup https://google_com 127_0_0_1#5300)

I didn't want to break the link for /etc/resolv.conf, so I set "option peerdns 0" for wan in /etc/config/network (and not setting custom dns server). I didn't realize before that even though nslookup fails, that wget, opkg work.


#1403

to run dnscrypt-proxy2.sh script

i'm not in town to test it out ..are command below correct?

cd /tmp
chmod +x dnscrypt-proxy2.sh
./dnscrypt-proxy2.sh

and how do i remove the old dnscrypt-proxy tab from luci Gui?


#1404

The script should remove all remnants of the old dnscrypt-proxy. Let me know if it doesn't as I may need to adjust the script.


#1405

Thanks for the information. I'll need to check this out tonight as it could be the source of other issues I was unaware of.

Thanks again.


#1406

just try it on my dad router and it does not seem to remove the gui,Thank


#1407

I'll check it out. Thanks for the info.

try this command... opkg remove luci-app-dnscrypt-proxy


#1408

David, sorry about asking but I'm afraid to install the latest update since i have activated dnscrypt proxy v2 using your script (which is working perfectly)

Is there anything i need to do after upgrading to the latest version? Just exectute the script again and activate ipv6 in the config? Or do i need to take care of something else before?
I think i read it somewhere here but i cannot find it anymore. Sorry but my girlfriend would kill me about any downtime :wink: THANKS

BTW:
Linksys replaced my second 1900 after talking about 20x times to the hotline (annoying!). Now the reboots are gone. They told me that there has been a faulty series of devices with corrupted memory.


#1409

Congratulations on having a router that doesn't reboot :laughing:

Yes, you will need to execute the script again. The best thing to do is to download the script to the /root directory, and then in LuCi go to Backup /Flash Firmware, and then click the "configuration" tab. From there make sure the /root directory is added to the "backup file list", and then you never have to download the script again because it will be there after every upgrade.

After you upgrade just execute the script and that should be it. As for ipv6, you shouldn't have to activate it again after an upgrade, but go ahead and check it to be sure. If something doesn't go right and you want to revert, then in LuCi, just go to Advanced Reboot, and reboot to the previous image and everything will be as it was.


#1410

I'm update my rig to 9028 recently via sysupgrade, no issues so far.
But interesting fact - according to the logs, seems like it's now possible to run rootfs from usb/esata attached drive, not only from MTD. Let me check it deeper, it's good for experiments/recover.


#1411

Such a mistake, what to do, how to fix it?

Thu Jan 17 12:58:53 2019 daemon.err miniupnpd[8410]: Failed to convert hostname '1111::210:20ff:fe30:4050' to ip address
Thu Jan 17 12:58:53 2019 daemon.err miniupnpd[8410]: Failed to convert hostname '1111::210:20ff:fe30:4050' to ip address

#1413

Gurus,

I have switched to AC on my WRT 1900 ACS just now ( due to distance limitations, I was stuck on 802.11n ) , and I'm very dissapointed with the speed I'm getting ...

This are my wireless settings

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
        option country 'US'
        option legacy_rates '1'
        option htmode 'VHT80'
        option noscan '1'
        option bursting '1'
        option ff '1'
        option compression '1'
        option txpower '20'
        option channel 'auto'
        option __toggle 'Enable'

The router is just 4 meters from the notebook I'm using, with no brick walls in between, just one of those "soft walls" that are hollow ...

Testing with IPERF3 -s on the router, I'm just getting 110 mbps / 16 mbps ...

Any ideas?


#1414

It doesn't always matter the distance or what's in-between when it comes to Wifi (Within reason of course).

Download a wifi analyzer, to your phone, and look to see how many wifi SSIDs are using the same channel/with width. People generally have a lot more issues with interference and never know it.

I need to upload a screen shot of competing signals in my neighborhood... It's almost comical and sad at the same time.

EDIT

Unfortunately, everyone is using 80Mhz widths now, which means there are only 2 Non DFS channels on 5Ghz AC. Either the channel is going to be at the high or low end of the 5Ghz spectrum.


#1415

@davidc502 Loving your firmware, slowly getting everything setup nicely.

I am running on a WRT32x without issues however i have noticed that restoring a backup doesn't restore everything and brings back crud that was removed before the backup was even made, for example dnscrypt v1, or themes are no longer there. New to OpenWRT

The other question is i am running the partitions in

boot_part 1 = Stock
boot_part 2 = OpenWRT

is there anyway to update the firmware from R8810 to the latest version you have built without erasing the stock firmware?

Thanks for any reply.


#1416

Before posting, I tried several channels manually, and now I'm on "auto" ... and the signal is -85 / -84 dBm to my notebook , which sucks. I thought even with such an ammount of interference the speed would be better. But you're right, I'll do the network analysis.

Any tool for windows that's free that you would recommend? I used one that had a trial but expired already...


#1417

You could try WiFi Commander : https://www.microsoft.com/en-gb/p/wifi-commander-3d-analyze-monitor/9nblggh20fr1#activetab=pivot:overviewtab

I use that or there is inSSIDer / Vistumbler or Meraki WiFi Stumbler (Google is your friend on this)