Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds


#1336

@davidc502

How I can get git clone of r8873? for cloning last 18.06.1 branch I used this, but it has r7258 version

git clone https://git.openwrt.org/openwrt/openwrt.git
cd openwrt
git checkout v18.06.1
git reset --hard 70255e3d624cd393612069aae0a859d1acbbeeae

I was a bit surprised that openwrt's LuCI web interface doesn't have some simple functionality in official release, like captive portal app, speedtest app, portstate, usb printer management, guest wifi creating, internet access control, etc.
I compiled some of them, luci-app-usb-printer works fine for me, luci-app-guest-wifi broke Lua interpreter. Will try to fix sourcecode and create custom feed on Github with additional packages.

%D0%91%D0%B5%D0%B7-%D0%B8%D0%BC%D0%B5%D0%BD%D0%B8-1


#1337

Why is there still no release?
https://davidc502sis.dynamic-dns.net/snapshots/r8873/


#1338

Look in subfolders
https://davidc502sis.dynamic-dns.net/snapshots/r8873/targets/mvebu/cortexa9/


#1339

Sorry, I'm new here, so I'm sure I'm missing something obvious, but I have a new wrt32x running stock firmware, and I want to flash Davidc502's OpenWrt build because custom DNS server setting seems to be broken on stock.

When I access the web ui through a browser and try to flash the .img file on davidc502's site, it says "invalid firmware." Is there a step somewhere I'm missing?


#1340

Why is this version missing from the main page?


#1341

Add in .img
openssh-sftp-server
please!


#1342

Someone please explain to me how I can do a upgrade? R8873 is not upgrading. I'm trying to upgrade from r8614. Is the problem with r8614? Would it be less trouble to boot into the other partition with the stock linksys firmware and install the openwrt factory.img?


#1343

Please read the readme.

Best regards


#1344

Hey david,
Just wondering what the reason is why the image loses it's integrity when uploading via the web-ui (and to make this a known issue). this is regarding upgrading caimin on a 1200ac via the web interface, never had the issue before.

Also should mention that using wget from the shell also yielded a corrupt image (i used the root home, didn't try it with /tmp/ as the destination).
succeeded in getting a proper sha-256 checksum using winscp to upload to /tmp/, and then using sysupgrade -v lede-mvebu-cortexa9-linksys-wrt1200ac-squashfs-sysupgrade.bin
i suspect wget would've worked as well if the image was downloaded to /tmp/

regardless, thanks for posting your builds!!


#1345

Good that this thread knows the answer, you just need to read it, if you're interested in the details.


#1346

+1
One of my favorite one, especially with the combo with SFTP Net Drive - sometimes even faster, then Samba.


#1347

Hi david, thank you for all the hard work you've put in. i've flashed the factory image to my wrt32x and it seems to be working ok but i seem to be having a problem with the sysupgrade.bin, luCI reports its flashing the firmware but after a few seconds goes back to the Flash operations screen and the router doesn't seem to have updated. overview is still reporting i'm on 4.14.82.


#1348

Hello all, may I ask is there any guide to install DNS over TLS to cloud flare? I tried directnupe's getdns stubby unbound but can't get it to work in wrt32x


#1349

This worked for me (not with 32x, but it shouldn't matter):
https://candrews.integralblue.com/2018/08/dns-over-tls-on-openwrt-18-06/


#1350

thanks, I'm getting the same results as a commentor when i retart the 'dnsmasq'
udhcpc: no lease, failing


#1351

Did you try rebooting the router?

The dnsmasq section of my /etc/config/dhcp looks like:

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option nonwildcard '1'
        option localservice '1'
        option noresolv '1'
        list server '127.0.0.1#5453'
        option dnssec '1'
        option dnsseccheckunsigned '1'

I don't recall if the last two entries were originally there. I also set up DNSSEC as referenced in the second paragraph of the referenced post (but it was not required for this to work).


#1352

Problem with firewall status
/cgi-bin/luci/admin/status/iptables
I previously published a screenshot


#1353

bOcy,
I used the following guide on my WRT1900ACS:

DNS over TLS works well for me and cloudflare is one of the resolvers.


#1354

I tried this https://forums.torguard.net/index.php?/topic/1509-updated-guide-for-getdns-142-2-stubby-023-3-and-unbound-181-2/ since it is newer post

i'll try again if it doesnt work then I'll try this, thanks!

edit: it seems the author prefers the method mentioned by you so i'll go ahead and try your link


#1355

@davidc502 checking your website there is a wrong link in the menu Forums>DavidC502 Thread< it should link to this thread,not the index of forum.openwrt.org.