Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds

just updated, wrt1900AC v2, no graphs on statistic page but that does not matter to me since I don't use it. As for wifi signal, it seems to improve a bit on my nexus player which is at the far end of the house but this may be because nobody is using wifi during early morning.

Once again, thank you very much for your hard work.

1 Like

I just installed today builds r8312 on a wrt3200, luci statistics works probably it was fixed.


1 Like


Thanks for testing... Tonight, I'll try uninstalling LuCi and installing LuCi Material from the daily snapshots and see if that fixes the issue. If not, I'll try swapping the collectd packages too.

Please let us know when it's fixed and please provide a fresh build with fixed collectd/statistics. I really like the collectd statistics and use them quite often. Thanks.

This afternoon I installed the latest build for my 1900ACS by backing up the config, flashing with clearing all config and then restoring the config. As part of that, my OpenVPN was also configured again. I activated AdBlock for the winspy list. I also re-installed VPN Bypass (which needed dnsmasq-full).

About 20 minutes ago, 2 systems did a DHCP renew. DNSMasq thought it was funny to completely ignore my IP reservations and give both systems an IP from the random pool, while at the same time having the DNS resolution still resolve to the reserved IP.
As you can understand, everything went belly up at that point.

All that the log states is that it won't give out the DNS name because it already exists. Duh, that's the reservation. The wireless clients seem to get the correct IP even after a reboot of the router, so far only the two wired systems that also have IPv6 addresses seem to have the issue.

I set them to static for now, but I would really like to know what's causing this and how I can fix it.

The affected systems are a Linux and a Windows 10 host. Another Windows 10 just renewed correctly after I unplugged it. The only difference being that the 2 affected systems are the only ones with an IPv6 lease as well as an IPv4. And for some reason one of them has an unlimited IPv6 lease time, while the other only has 12 hours.

David, thanks. I installed r8289 on my Linksys WRT1900ACS v2 and all works well except for statistics. The Graphs LuCI page now simply reports " The statistics package uses Collectd to gather data and RRDtool to render diagram images. You can install additional collectd-mod-* plugins to enable more statistics."

1 Like

@davidc502 Could you please stop including more and more services into this rom!? This is a ROUTER. If someone wants some media/upnp/autoconfig/ECT crap installed on it, then they can optionally do so. A router needs as less services on it it as possible, for security reasons. There are now at least 15 services which has to be disabled after an update for this rom... 15!!!

Forgive me for asking the ignorant question, but why not install the base OpenWRT rom then? Then you have to enable the things you want instead. Isn't the whole idea behind choosing David's rom that he includes extra services?



There is something going on with the build that's causing this issue as I've already tried compiling a new one and it is still broke.

Does anyone here build on a Linux guest within Virtualbox on a Mac host? The last few days when I've tried to build, both the Linux guest and the Mac host lock up during compilation. I tried limiting the cores used in the guest from 3 to 1, as well as changing the make command from -j3 to -j1, and still have the issue. Never experienced this one before.

Which services are you talking about?

Hi, just use the standard base image of OpenWRT...and build/install the things you want to have on your router yourself with the features you like....like I did.. i dont mean that provocative or so...just my thought/opinion Peace


Can anybody help with my issue please? DNSMasq just keeps giving out random IP's and completely ignores my static leases. When I disable dynamic IP's, it won't give out any IP address at all. The mac address is correct, same as it has been for months.

Hey folks.

I've been reading a ton about my wrt1200ac v2 and I've used openwrt before but I still can't seem to figure out whether openwrt will work on it. The main openwrt page says something about it needing a newer wifi driver, and most threads seem to be of people with problems. Does this David build work on it without issue?

Thanks a lot!

openWRT ist fully supported on the WRT1200AC. running smoothly with this build.

Anybody else seeing stuttering & latency issues (5ghz) with a wrt1900ac using r8289. My wrt3200acm is great with r8289, but my wrt1900ac (v1) stutters and lags for clients on 5ghz, to the point of being unusable. I rolled back my wrt1900ac to r7938, and now no problems.

Hi David
hope you're well. Ive just installed the latest version for the v1 WRT1900.
Unfortunately the minidlna package is missing. The luci app for it, along with the translations are present but not the package itself.
Can this be fixed? or must I revert to the previous version?

all the best

Hi David (me again)
Has anyone reported issues with dnscrypt through Luci? When I change the default to my usual resolved I lose all network connectivity, and there seems no easy way of backing out other than reinstalling from scratch.
I haven't tried the old fashioned route of editing the actual files over SSH - it might work as this has the mark of a LuCi bug somewhere, but i'm a bit scared to do so until ive seen if anyone has any feedback or experiences on this.
EDIT => actually this is probably the Lord giving me a signal to try v2. Ive just seen the instructions on your site David and will give it a go. One question, My ISP uses IPV6 - is that an issue?

It does need to be fixed. Unfortunately the daily snapshots have already kernel bumped so going back to the older build may be the only option.