Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds

Glad wifi is working well for you. Generally, I don't recommend the opensource wifi on the wrt series.

Everything you need to build your own custom version of this build will be found in this directory.

https://dc502wrt.org/snapshots/r11398/targets/mvebu/cortexa9/

Is it possible to make the change when i have it installed ?

No, that the change is pre-compiled. However, for example, if you want to use OpenWrt Stable build, as long as it has the same kernel version as the build here, you can download and install it on stable. It works the same way vice versa.

@davidc502
Hi David - Sorry for the delayed response on this.
I finally got some time to run the command you asked me to run.
Before I ran the command, I reset to default settings then I upgraded to the latest build " r11398" and made the following changes
I edited the .toml file and changed the listen_addresses = ['127.0.0.1:5300'] and server_names = ['cloudflare']
Then I restarted /etc/init.d/dnscrypt-proxy restart
Then I edited /etc/config/dhcp and added list dhcp_option '6,192.168.1.1' under LAN and added list server '127.0.0.1#5300' under "config dnsmasq"
and I restarted /etc/init.d/dnsmasq restart

Then when I ran the command "dnscrypt-proxy -config /etc/dnscrypt-proxy2/dnscrypt-proxy.toml -check" and the output was as shown int he screenshot below:

Screenshot%20at%202019-11-11%2017-16-26

Dear Dave,
As always - you are simply the best - and I do not overstate my sentiments regarding how you treat us all whenever we ask you for your assistance and expertise. Together we all make each other better - so I appreciate your thanks for my bringing this to your attention. However, I do count my blessings in that you are dedicated and kind enough to devote your time and effort to this outstanding project of yours which benefits so many. Long Live Davidc502 Builds - Peace My Brother

2 Likes

No, dnsmasq does not support it.

Looks like a firewall rule is keeping dnscrypt proxy from getting out.

Can you ping the following 2 IP's please - 1.1.1.1 and 1.0.0.1

Also, from Windows command line run the following

nslookup cnn.com 1.1.1.1

Upgraded to r11398, still having the collectd errors at boot.


Find another thread regarding this issue:

Tried the suggested fix whitout success, any other idea ? It's not really bothering for now as I just disable collectd but might need it in the future

Sorry I don't have any idea however collects seems to run fine as well as rrd so you can safely ignore the errors.

Generally, I don't recommend the opensource wifi on the wrt series

Ouch, is it really that bad? Generally I've had very results across the board with OpenWrt builds dated 2019 onward for my WRT32X. Maybe I should have gone with the R7800 after reading this :slight_smile:

As to the R7800... The grass is always greener on the other side right? I recommend going through the R7800 threads if you do believe it is "greener" :slight_smile: Don't get me wrong, it is all + and - so, depending on your needs it might be greener.

Cheers,

1 Like

Somewhere around r11430 @hnyman provided solution to errors I was seeing and at least on R7800 that works without glitches now.

@davidc502

When I ping 1.1.1.1 or any other valid IP address I do not get an responses.

Also, I noticed that even before I make the changes to DNSCrypt as per your instructions, I do not have internet access to begin with. I started fresh with your latest build and the moment my router starts there is no internet access.

If I flash an earlier build, for example r10726, I would have internet access out of the box. I am really confused about what is causing this.

I also noticed in the latest build under "Interfaces" that the STOP button for WAN and WAN6 is grayed out and I cannot even stop it. It only allows me to restart, edit and delete.

Any help here would be much appreciated. Thanks

Before you Fire, Identify your Target...

Question: What would it take to just build/develop wifi drivers from scratch instead of relying on firmware blobs from vendors?

Two strictly separate teams (clean-room reverse engineering) with at least ~5 experienced members each (with at least 3-4 hours a day to spare, more on weekends; at least one certified ham operator), at least ~2 years time, regular access to a well-equipped hf lab.

/this is a rather optimistic estimate
//success not guaranteed
///Edit: all members of the reverse engineering team will need job security in a field quite different from wifi development for at least 5-10 years beyond the completion of their work, as they're considered to be tainted with proprietary IP

1 Like

A very optimistic estimate, in my humble opinion, if you consider that there is zero documentation available about the chipset.

1 Like

Sounds like you've been hit with one of the bugs dealing with the latest build. Just hang on r10726 until the next build comes out and then try it.
By what you mentioned, I don't believe dnscrypt-proxy is having an issue because there isn't internet access.

I'm thinking this should be cleared up on the next sysupgrade.

Thanks,

David

Interesting comments. Still sounds do-able quite honestly. True open source would be a dream brought to life. No bull or red tape (at least concerning development right), just community driven folks doing exactly what you guys do now but no restrictions to all the code.

Anyone can help me to get right dotnet version for OpenWRT to run on my WRT3200ACM?

arm package are returning error:
bash: ./dotnet: No such file or directory

file dotnet
dotnet: ELF 32-bit LSB executable, ARM, EABI5 version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux-armhf.so.3, for GNU/Linux 2.6.32, BuildID[sha1]=bd72497b1835e8aae811d5ce5836002803645470, stripped

i had so many issues with the r7800 a few months ago. The WRT series seems to be more stable with a faster internet connection (400mbps+). At least for me... Now i only use davids build for me and my family and friends... no issues (beside 5ghz wifi and dfs in some cases...).

2 Likes