Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds

when i click te "Rebot to Alternative par.." router go black dont respond to ping cmd

Another problem I'm having is that OpenWrt appears to be partially installed as I am missing the usual navigation bars containing the OpenWrt menu options when pulling up the WebUI. I had hoped "opkg update/opkg install luci" would get me past this problem.

@anomeome I agree with your points. So going back to my "opkg update" issue, what are my options? Revert back to the OEM firmware and go forward with 21.02.0-rc2? Or is there a config file, for example, that I can edit so that I can complete the install with 21.02.0-rc2? It seems that I was hardcoded to a dc502wrt's snapshot right now.

@EXREYFOX looks to be an issue to ping stangri in the relevant thread.

@Coolblade you do not have to go OEM (unless you want to keep it for some reason), you can just flash a 21.x RC2, but do not keep config; you will have to install your desired packages of course.

Wonder if anyone knows what is going on with the site https://dc502wrt.org/ looks like it is down. so not possible to get the builds.

There hasn't been a new davidc502 build in about 1 year, it's very out of date at this point. He probably took the site down. Use Divested or install regular OpenWrt 21.02-rc2 and just add all the packages it takes 5 minutes. I even posted the opkg command to SSH in and automate it for you.

The mvebu routers work fantastic with base OpenWrt after installing those packages and adding a couple tweaks no real need for a community build anymore. Let's move on.


@davidc502 could you please show me the mwlwifi Makefile and patches that is working with Kernel above v5 and the wifi is working? as in v21-rc2 is not working with wifi, probably your setup in wifi with Kernel 5.4 is working, i want to build that mwlwifi package that you have, please, thank!

for reference: 21.02.0-rc2 WRT3200ACM wireless is broken - #16 by WildByDesign

It seems dc502wrt.org is on hiatus as it hasn't been putting out new builds since last year. However, when it was up on Sunday for a few hours, at our request, i managed to download and installed the mvebu-cortexa9 release for my WRT3200ACM. The results were less than satisfactory, as I was missing the OpenWrt menu bars in the WebUI. Perhaps the download I used was not a complete build.

However, I ended up downloading release 19.07.7 from https://firmware-selector.openwrt.org/?version=19.07.7&target=mvebu%2Fcortexa9&id=linksys_wrt3200acm and it installed perfectly for my router model.

Before 19.07.7, I also tried 21.02.0-rc2 and the results were a bit better. I see the menu bar in the WebUI this time but it was missing the Network > Switch item. I needed that to configure VLANs.

Of course RC2 uses DSA, there are new GUI screens in support of same, swconfig is dead as are the GUI screens.


I have been using Davids last build r13342 for over a year now with no problems on a WRT3200. The only added features I use are DNSCrypt and Adblock.

Since DNSCrypt was such a pain to setup I could live with out it. I would just use Cloudflare for DNS going back to the basic OpenWRT image. So with that said. What would I gain? Anybody know of any pressing security issue that needs to be addressed right now? Thanks

No nothing major, but I'd encourage you to do a clean upgrade once OpenWrt 21.02 is released.

Check the gitlog, CVE ..., and decide.


I noticed many people asking about Davidc502's firmware and todates firmware using same Software that Davidc502 put into his.

Some of you might benefit from using ImageBuilder, but before you do that.. Log into your Router.

ssh -l root

Then enter below command. This will give you a current list of all packages installed.
echo $(opkg list_installed | awk '{ print $1 }')

the bottom 2 commands, one or the other will work, but they give you a standard line by line list. Really not needed for imagebuilder.

# ls /overlay/upper/usr/lib/opkg/info/*.list | sed -e 's/.*\///' | sed -e 's/\.list//'
ls /usr/lib/opkg/info/*.list | sed -e 's/.*\///' | sed -e 's/\.list//'

Then when you have your list, comb through it, remove unneeded stuff and shorten the version string packages to just the package name or you will run into future issues if you are to do this again.

Make sure you have latest imagebuilder for your Router.

My command that I use:

make image PROFILE=linksys_wrt3200acm FILES=files/ PACKAGES="6in4 adblock alsa-lib attr avahi-dbus-daemon base-files bcp38 block-mount busybox ca-bundle ca-certificates cgi-io collectd collectd-mod-cpu collectd-mod-interface collectd-mod-iwinfo collectd-mod-load collectd-mod-memory collectd-mod-network collectd-mod-rrdtool collectd-mod-sensors collectd-mod-thermal coreutils coreutils-sort curl dbus ddns-scripts dmesg dnscrypt-proxy2 dnsmasq dropbear etherwake firewall fstools fwtool getrandom gzip haveged hostapd-common htop ifstat iftop igmpproxy ip6tables iperf3 ipset iptables iptables-mod-conntrack-extra iptables-mod-ipopt iw iwinfo jansson jshn jsonfilter kernel kmod-asn1-decoder kmod-bluetooth kmod-bonding kmod-btmrvl kmod-cfg80211 kmod-crypto-aead kmod-crypto-authenc kmod-crypto-cmac kmod-crypto-crc32c kmod-crypto-ecb kmod-crypto-ecdh kmod-crypto-hash kmod-crypto-hmac kmod-crypto-kpp kmod-crypto-manager kmod-crypto-md5 kmod-crypto-null kmod-crypto-sha1 kmod-crypto-sha256 kmod-crypto-sha512 kmod-crypto-user kmod-cryptodev kmod-fs-ext4 kmod-fs-msdos kmod-fs-ntfs kmod-fs-vfat kmod-fuse kmod-gpio-button-hotplug kmod-hid kmod-hwmon-core kmod-hwmon-pwmfan kmod-i2c-core kmod-ifb kmod-input-core kmod-input-evdev kmod-ip6tables kmod-ipt-conntrack kmod-ipt-conntrack-extra kmod-ipt-core kmod-ipt-ipopt kmod-ipt-ipsec kmod-ipt-ipset kmod-ipt-nat kmod-ipt-offload kmod-ipt-raw kmod-iptunnel kmod-iptunnel4 kmod-lib-crc-ccitt kmod-lib-crc16 kmod-lib-crc32c kmod-lib-textsearch kmod-mac80211 kmod-mmc kmod-mwlwifi kmod-nf-conntrack kmod-nf-conntrack6 kmod-nf-flow kmod-nf-ipt kmod-nf-ipt6 kmod-nf-nat kmod-nf-nathelper-extra kmod-nf-reject kmod-nf-reject6 kmod-nfnetlink kmod-nls-base kmod-nls-cp437 kmod-nls-iso8859-1 kmod-nls-utf8 kmod-ppp kmod-pppoe kmod-pppox kmod-regmap-core kmod-sched kmod-sched-cake kmod-sched-connmark kmod-sched-core kmod-scsi-core kmod-sit kmod-slhc kmod-sound-core kmod-tun kmod-usb-core kmod-usb-ehci kmod-usb-ohci kmod-usb-ohci-pci kmod-usb-storage kmod-usb-storage-extras kmod-usb-uhci kmod-usb2 kmod-usb2-pci kmod-usb3 krb5-libs libarchive libatomic1 libattr libavahi-client libavahi-dbus-support libblobmsg-json libbz2 libc libcap libcomerr0 libcurl4 libdaemon libdbus libelf1 libevent2 libexif libexpat libffmpeg-mini libflac libgcc1 libgcrypt libgmp10 libgnutls libgpg-error libhavege libiconv-full2 libid3tag libintl-full8 libip4tc2 libip6tc2 libipset13 libiwinfo-lua libiwinfo20210430 libjpeg libjson-script libldns libltdl7 liblua5.1.5 liblucihttp-lua liblucihttp0 liblzma liblzo2 libmbedtls12 libmnl0 libnatpmp1 libncurses6 libnetsnmp libnl-tiny libogg0 libopenssl-afalg_sync libopenssl-conf libopenssl1.1 liboping libpam libpcap1 libpci libpcre libpopt0 libpthread libreadline8 librrd1 librt libsensors5 libsodium libss2 libsysfs2 libtasn1 libtirpc libubox libubus-lua libubus libuci-lua libuci20130104 libuclient libuuid1 libvorbis libwolfssl libxtables12 lm-sensors logd lua luci luci-app-adblock luci-app-advanced-reboot luci-app-bcp38 luci-app-ddns luci-app-firewall luci-app-openvpn luci-app-opkg luci-app-qos luci-app-samba4 luci-app-sqm luci-app-statistics luci-app-uhttpd luci-app-upnp luci-app-watchcat luci-app-wol luci-base luci-compat luci-lib-httpprotoutils luci-lib-ip luci-lib-ipkg luci-lib-iptparser luci-lib-jsonc luci-lib-nixio luci-mod-admin-full luci-mod-network luci-mod-status luci-mod-system luci-proto-ipv6 luci-proto-ppp miniupnpd mtd mwifiex-sdio-firmware mwlwifi-firmware-88w8864 mwlwifi-firmware-88w8897 mwlwifi-firmware-88w8964 nano netifd ntfs-3g odhcp6c openssl-util openvpn-easy-rsa openvpn-openssl openwrt-keyring opkg ppp ppp-mod-pppoe procps-ng procps-ng-pmap procps-ng-ps procps-ng-pwdx procps-ng-slabtop procps-ng-snice procps-ng-tload procps-ng-vmstat procps-ng-watch px5g-mbedtls qos-scripts rpcd rpcd-mod-file rpcd-mod-iwinfo rpcd-mod-luci rpcd-mod-rrdns rrdtool1 samba4-libs samba4-server samba4-utils sqm-scripts sysfsutils sysstat tcpdump-mini terminfo ubi-utils uboot-envtools ubox ubus ubusd uci uclibcxx uclient-fetch uhttpd uhttpd-mod-ubus urandom-seed urngd usign watchcat wget wireless-regdb wsdd2 zlib kmod-fs-exfat e2fsprogs usbutils libuclient20201210 gdisk fdisk openssh-sftp-server luci-app-nft-qos kmod-crypto-pcbc luci-theme-bootstrap luci-theme-material luci-theme-openwrt-2020 luci-theme-openwrt luci-theme-argon luci-theme-opentomato luci-app-argon-config bind-host luci-app-log luci-app-serverchan luci-app-cpufreq luci-app-mqos"

then when all said and done, you will have very close to what Davidc502 has released in the past. His personal fixes and settings you will not have. Unless you saved that somehow.. but as for the packages, you will have them all.. Do not use my list.. because I have extra packages that are not on openwrt.. Just thought I would share this info since I see so many people asking about it..

1 Like

There are a lot of uncessary packages there though. I'd recommend going with the smaller list I posted above to install on 21.02-rc2. At least add in irqbalance and enable it on yours. This helps offload a couple things to the other core and has been shown to improve wifi performance under load.

1 Like

Thanks for the input, I thought it was like an overkill too. but I took the software that came from
a fully running DavidC502 firmware on a LinksysWRT3200ACM.. and that is what came up. plus many more that I did remove..

I have now modded a github Action Script that will auto build latest snapshots for me now..
If you have a fully working .config with LUCI and all enabled, I could give it a try under my Actions Script in the workflow.

I will not post the link here, out of respect for DavidC502's thread and the other people here.
but if interested send me a DM/PM and ill send you the link.

I know my builds are working because im currently running them. but since my Main Linux system is Arch Linux, building OpenWRT is next to impossible do to (bleeding edge software development) that arch uses.. haha sorry, Just using the same line OpenWRT used..

But using Microsoft's GITHUB Action Scriping to create a fully VM and build OpenWRT from ground up. best way to go for me. I modded the script. Didnt create original.. someone else did that.
I did rewrite alot of it though.. to make it more user friendly to customize and change alot on the fly.

Anyways, thanks again for the input.

Ok. Thanks.


I've been using Linux ever they since tried to convert Win7 to the data mining Win10. With that said I'm not a noob but I am not a Linux pro.

What is the difference between using the basic OpenWRT image and adding the few packages I really use? And me building an image? If I need to build a package where can I go to read up on it? Thanks

You might take a look at:

David told us to go forward over a year ago and I’ve stuck with this since it arrived.

Straight forward how-to and a great video step by step process on how to build yourself.

I’ve got pretty well exactly what I use, no bloat, secure! plug n play.

A really good jump in if you’re considering a “roll your own” on this platform.

See: https://openwrt.org/docs/guide-developer/quickstart-build-images

Anyone know if 802.11s WDS support was ever added to mwlwifi before the driver was abanonded? I'm currently running OpenWrt 21.02-rc3 but haven't tried enabling WDS yet, I might need it. Thanks.

Great! Thanks a lot. Appreciate it.