Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds

Very much so, I have roughly the same router (WRT32X). WiFi work with mwlwifi driver has been abandoned so there have been no changes in over a year but everything is working fine for me, same as davidc502's build more or less. OpenWrt 21.02-rc1 is coming very soon if you want to give that shot.

1 Like

Installed OpenWrt 21.02-rc1 on my WRT32X yesterday (it was just posted). It's great so far and stable. I don't recommend it yet if you do DSA config changes since the commits are still not in for LuCI. Should be by release I read. Also the default theme (no offense to the excellent team) is dated looking visually compared to the theme in davidc502, I gotta switch to that theme if it gets updated for all the LuCI changes. Anyway the following is all working great:

  1. Default install is barebones. Install the following to bring it close to davidc502, will add more as needed:
    opkg install nano irqbalance iperf3 luci-app-advanced-reboot luci-app-sqm luci-app-wireguard luci-app-adblock luci-app-upnp luci-app-samba4 block-mount kmod-usb-storage kmod-usb-storage-uas kmod-usb-ohci-pci kmod-usb-ohci kmod-usb-uhci kmod-ata-marvell-sata kmod-usb3 kmod-usb2 kmod-usb2-pci ntfs-3g fdisk luci-app-hd-idle

  2. SQM: Cable modem internet rated at 500 / 35 Mbit: speedtest at 518 / 36 Mbits but with ping fluctuations from 15-75ms under full load. Enabled SQM Cake (set to 500,000 / 33,000) I get 504 / 34 Mbits with full load ping fluctuation of 1-5ms. Amazing improvement, this is must use.

  3. Samba4 + USB 3.0 storage: 120 MB/s read/write on my 3TB external drive from my Win10 machine over the wired network.

  4. Adblock working perfectly. Using 4 'small' lists.

  5. DSA working on default settings, again LuCI config isn't in 21.02 yet, only in master.

  6. Wireguard working well, haven't tested performance yet. I don't leave this on most of the time.

  7. WiFi 5GHz: band set at 80MHz working great, didn't test performance yet, but feels very fast and responsive on ThinkPad and iPhones. Rest of network is wired.

4 Likes

Hi ,

wonder if you can answer some questions regarding the 21.02 release .

I currently have version r12121 of Davids builds ( so quite an old build ) I've been waiting for the stable 21.02 release to arrive so that I could swap to that as I'm aware david has paused his builds (which I can't blame him , he needs a break from it ).
my router is the 1900ACS version 2 , I see that there is release for my model on the firmware selector although the hardware table hasn't been updated to show the release yet.

I don't use 95% of the features on davids build , I have a very simple use case , I have a couple of port forwards and all my devices have static IP's that is literally all I change ( oh! and I change the theme to tomato )

My first question is you recommend not sys-upgrading to this release but can I use the factory.bin file from an existing install, to do a fresh install , or do I need to use the sysupgrade.bin file and just not keep the settings ?

second question is do I need to change the Wifi driver on the stable build as I know david made some tweaks to his build and on the stable build I installed originally( before davids builds) the wifi was terrible .

My final question is based on my simple use case is there any of your recommended additional packages you think I would benefit from apart from nano and advanced reboot

thanks in advance for your help

regards

  1. Do a clean install. You actually can't sysupgrade from older swconfig builds to new DSA based builds there is a warning about compatibility. I recommended rebooting into your other partition (if you still have it) via advanced-reboot and flashing the factory image.

  2. Regarding recommended packages, the ones I listed are all good, but at minimum I'd say: ipqbalance (I think it works on a few procs for mvebu), luci-app-advanced-reboot, and luci-app-sqm. Enable SQM, it makes a big difference to latency under load, effectively beating every high end 'gaming' router on the market at latency. Setting the theme to tomato will have bugs in 21.02 since it hasn't been updated for DSA and some other changes. You could also install dnscrypt but I don't bother with that just don't see the value in it.

  3. Wifi works great, you don't need to change the driver, but you might need a setting change on yours. Davdic502's build states: "5. Custom Wifi has the AMSDU option disabled. This keeps latency low for the 1200ac/1900acx models. The 3200acm model is unaffected." I think you just need to disable AMSDU but I never looked into how to do that because my WRT32X is unaffected.

  4. If you waited this long you might want to wait for the final 21.02 release. Make sure you update to the latest packages if you install rc1 because there is an ipv6 fix. So far I have a 6 day uptime on rc1 though and it's been rock solid.

1 Like

brilliant ,

thanks for the advice this is seriously helpful.

unfortunately I don't have the OEM firmware on there still how to do I clean install when both partitions are Openwrt I've only ever sysupgraded ?

do I need to flash the OEM firmware first and then do a clean install of Openwrt from it, to ensure the cleanest install ?

or do I use the sysupgrade.bin file and start from scratch adding all my devices again and setting up port forwarding ( i.e keep no settings, do not restore from backup and set up as if its a first install )

in the past how many release candidates did they have before a stable final release ? just so I can gauge time .

You can just use sysupgrade, do not keep config, or follow the advice in the 21.x post.

See post to disable AMSDU.

2 Likes

thank you so much , really appreciate the advice, this clarifies things for me

In my case i have one partition with openwrt and the others with the linksys oem firmware.
Can i install a new fresh instalation "openwrt _factury_file" by switch the partition to oem firmware??

Yes that's what I did, just use advanced reboot (or SSH in) and have it reboot to OEM then flash the "factory" OpenWrt firmware. It'll override your current OpenWrt partition and reboot to it.

1 Like

Hi.

Have been running Davidc502 build on a WRT1900AC v1 for a couple of years and thought it was time for an update.

Current Firmware Version OpenWrt SNAPSHOT r13059-9fac9168c6 / LuCI Master git-20.116.42735-f44ba48. Current Kernel Version 4.19.115

Having been greeted with "At this time, there has been a stoppage of new builds." I thought I would drop in and ask which STABLE version should I update to?

Thanks

This, but still RC.

Should I switch to OEM firmware partition, if it's still there, or should I reinstall the OEM firmware and then install 21.02.0 RC

Thanks.

Entirely up to you, personally I have no idea why people keep OEM hanging about. I would just sysupgrade but...

Should also mention there is this, and images to be found off the link on my avatar, but those are both based off master at whatever point in time.

1 Like

Posting to keep the topic open. Closes after 10 days.

1 Like

Hi Guys,

I have a problem with 1900acsv2 somehow i cannot get PPPOE working, it does connect with the stock partition and also with OpenWRT DHCP .
I did the following
Factory reset the device and re-created everything without using any backups - no success
I get PADO timeouts

on Feb 15 17:43:17 2021 daemon.info dnsmasq-dhcp[2302]: read /etc/ethers - 0 addresses
Mon Feb 15 17:43:18 2021 daemon.err odhcp6c[1836]: Failed to send DHCPV6 message to ff02::1:2 (Permission denied)
Mon Feb 15 17:43:19 2021 daemon.err odhcp6c[1836]: Failed to send RS (Permission denied)
Mon Feb 15 17:43:23 2021 daemon.err odhcp6c[1836]: Failed to send RS (Permission denied)
Mon Feb 15 17:43:26 2021 daemon.err odhcp6c[1836]: Failed to send DHCPV6 message to ff02::1:2 (Permission denied)
Mon Feb 15 17:43:27 2021 daemon.warn pppd[1877]: Timeout waiting for PADO packets
Mon Feb 15 17:43:27 2021 daemon.err pppd[1877]: Unable to complete PPPoE Discovery
Mon Feb 15 17:43:27 2021 daemon.info pppd[1877]: Exit.
Mon Feb 15 17:43:27 2021 daemon.notice netifd: Interface 'wan' is now down
Mon Feb 15 17:43:27 2021 daemon.notice netifd: Interface 'wan' is setting up now
Mon Feb 15 17:43:27 2021 daemon.err insmod: module is already loaded - slhc
Mon Feb 15 17:43:27 2021 daemon.err insmod: module is already loaded - ppp_generic
Mon Feb 15 17:43:27 2021 daemon.err insmod: module is already loaded - pppox
Mon Feb 15 17:43:27 2021 daemon.err insmod: module is already loaded - pppoe
Mon Feb 15 17:43:27 2021 daemon.info pppd[2363]: Plugin rp-pppoe.so loaded.
Mon Feb 15 17:43:27 2021 daemon.info pppd[2363]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Mon Feb 15 17:43:27 2021 daemon.notice pppd[2363]: pppd 2.4.7 started by root, uid 0
Mon Feb 15 17:43:33 2021 daemon.err uhttpd[1635]: luci: failed login on / for root from 192.168.1.128
Mon Feb 15 17:43:38 2021 daemon.err uhttpd[1635]: luci: accepted login on / for root from 192.168.1.128
Mon Feb 15 17:43:42 2021 daemon.warn pppd[2363]: Timeout waiting for PADO packets
Mon Feb 15 17:43:42 2021 daemon.err pppd[2363]: Unable to complete PPPoE Discovery
Mon Feb 15 17:43:42 2021 daemon.info pppd[2363]: Exit.
Mon Feb 15 17:43:42 2021 daemon.notice netifd: Interface 'wan' is now down
Mon Feb 15 17:43:42 2021 daemon.notice netifd: Interface 'wan' is setting up now
Mon Feb 15 17:43:42 2021 daemon.err insmod: module is already loaded - slhc
Mon Feb 15 17:43:42 2021 daemon.err insmod: module is already loaded - ppp_generic
Mon Feb 15 17:43:42 2021 daemon.err insmod: module is already loaded - pppox
Mon Feb 15 17:43:42 2021 daemon.err insmod: module is already loaded - pppoe
Mon Feb 15 17:43:42 2021 daemon.info pppd[2461]: Plugin rp-pppoe.so loaded.
Mon Feb 15 17:43:42 2021 daemon.info pppd[2461]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Mon Feb 15 17:43:42 2021 daemon.notice pppd[2461]: pppd 2.4.7 started by root, uid 0
Mon Feb 15 17:43:42 2021 daemon.err odhcp6c[1836]: Failed to send DHCPV6 message to ff02::1:2 (Permission denied)

the and here is the /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd77:314b:33e8::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth1.2'
        option proto 'pppoe'
        option username 'password'
        option ipv6 '0'
        option password 'password'

config interface 'wan6'
        option ifname 'eth1.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'

Any ideea would be welcomed

Thanks

root@OpenWrt:~# * opkg_download: Failed to download https://dc502wrt.org/snapshots/r11829/packages/
arm_cortex-a9_vfpv3/telephony/Packages.gz, wget returned 4.
-ash: *: not found
root@OpenWrt:~# *

is the repo up?

I've turned it down. If you need packages I can turn the webserver back on for a while.

I've turned it back on, but will turn it back off tonight.

1 Like

Hi David , Could be possible have access to last publish builds of WRT1200AC and WRT3200ACM
Thanks!

Hi,

Are you turning the web server off permanently or is this just for maintenance reasons? I needed to download git to my router which failed and saw that your website was also off-line, it appears some of us are still using your last build instead of switching to DSA. :slightly_smiling_face:

Yea I was running davidc502, it was flawless. Had months of uptime with zero issues. Switched over to 21.02-rc1 when it was released just to try something new, it's running quite well too no major issues just a few bugs that are being fixed before full release.