Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds

Im puting my two cents in
Make sure the cable is in the switch port and no other cables are conneted. Only the one from pc you are flashing from then flash from factory. With wrt factory image.. I once had somthing like this happen to me with DD-wrt I think it was a verision issue I had two of the same images on both partions I waited to a newer DD-WRT was released then i flashed it on one of the partions. It sounds like you still have the factory image.

1 Like

I've just tried a DD-WRT build also, and same behaviour.

sysinfo.cgi
-----U-Boot Data-----
fw_printenv bootdelay: bootdelay=3

fw_printenv mtdparts: mtdparts=mtdparts=armada-nand:1024K(uboot)ro,256K(u_env),256K(s_env),1m@9m(devinfo),40m@10m(kernel),37m@13m(rootfs),40m@50m(alt_kernel),37m@53m(alt_rootfs),80m@10m(ubifs),-@90m(syscfg)

fw_printenv bootcmd: bootcmd=run nandboot

fw_printenv boot_part: boot_part=1

fw_printenv auto_recovery: auto_recovery=yes

fw_printenv mtdparts_version: 

I guess I must just have a broken partition. :frowning:

@anon68513369 thanks for this. Given I can't get the partition to boot at all, I don't think I can help to try it.

Hey Tim,

This is not specifically a solution to your problem, but a special build with fast openssl tls 1.3 capabilities and amazing fast dnscrypt-proxy2 dnssec .... excellent wifi performance as well as dnsmasq resolving! And with the new 2020 theme, latest trunk, kernel 5.4.82 and all packages from the dc502 images.

So I hope you find a solution to your problems!

Greetings

GJ

The response and resolving times of dnsmasq in combination with dnssec (cloudflare) and with adblock blacklists are absolutely beautiful and amazingly fast even for a consumer fiber connection! And the response stays stable even in peak hours of internet!

I just did 5 extensive tests for my router and the ping, trace route, dnssec, speedtests are so beautifully consistent and fast.

hi,

what do you mean by fast dnscrypt-proxy2 dnsse ?
You mean you've already picked some fast dns servers in Toml config?
and what about DSA ?

My response/resolve times between my dnssec cloudflare or ams dnssec.....is between 4-5ms!

Like I wrote earlier, DSA works if you follow a tutorial with ip link set dev.....I have a separate vlan for my own lan(I share it with my upstairs neighbor).....it works without a hitch! We have a fiber connection with a vlan setting and a separate iptv vlan and a really short dhcp lease time....the router never missed a beat!

So follow the link for DSA,vlan settings
Dsa solution forum openwrt

Why is buffered "?" I see you had the same problem on RC7 :slight_smile:

There is a patch for the cryptodev build issue on 5.10.x.

Great job, thank you!
I will use it for my own build, but with different package set (f.e. i use SmartDNS instead of DNSCrypt), and some of my patches for wifi.

It is possible to help me about how i can to work hostname Iot esp devices without disable WWM ?

I am trying to install OpenWrt Venom wrt32x build for the very first time from the Linksys stock factory-installed web GUI, but get an "invalid firmware" message. I am sure there is a simple step that I am missing - can anyone advise how to get it installed?

I can’t seem to get any image accepted using the GUI. Would doing it from the CLI (using sysupgrade -n -v -F) be a potential workaround?

Apologies, I think I figured it out. For those who might be facing the same problem, it appears that at some point the web gui is no longer looking at the firmware, and is throwing up the "invalid firmware" error message indiscriminately. Some combination of rebooting the router and using a new browser/clearing cookies seemed to do the trick.

1 Like

Hi, im using OpenWrt SNAPSHOT r13342-e35e40ad82 / LuCI Master git-20.144.63033-62ed4e6 on a wrt1200ac v1
I use more tha one isp, i tried loadbalancing but its kinda buggy when i try to redirection traffic from X client to a specific WAN, the simple solution i found its adding the modems/routers without dhcp enable, so i just set manual ip for each client.
now im trying to add another ISP/router to my network using wireless as client, no luck so far, i can connect, wireless without problems, if i add an interface with ip i can ping the new router on network, but if i set manual ip/mask/gateway from another client on my network dont work, what could be the issue?!
Thanks.

the package relayd worked. i can ping the new wireless
using it as protocol for the new wireless client allow me to ping the router, but if i manually set the gateway its not getting internet.

Thanks again.

Hello everyone. I've been following this thread for a long time, but didn't sign up as I didn't feel I could add anything.

Like a few others, I have been plagued by wifi issues even on the latest versions (WRT32X). These normally manifest in disconnections for all devices, with the radios (both 0 and 1) being disabled either individually or at the same time. Usually, these would restart on their own, on occasion they wouldn't. In the worst-case situation, just one of the radios would work, and enabling the other would disable the working one. This didn't seem to be DFS related as the logs didn't have any mention of it. I also locked to channel 36 to ensure. The only way to fix it when the router was in the state was a reboot.

This seemed really weird, as I could factory reset the device / reinstall the firmware, make almost no changes (password / encryption only) and the wifi was effectively unusable at random.

There are around 10 wireless devices, ranging from old Android phones (~8 years old), to Samsung S20s and Amazon Alexa devices across the 2 radios.
To complicate matters further, the router was purchased in the UK, but I moved to Iceland. I believe that some (smart?) devices pass localization information around, which I suspected may be causing an issue. The device reports FR: DFS-ETSI which of course I'm unable to change. I have no idea how or if it's important it is that devices 'match' this in some way - comments welcome. I'm out of the loop with this.

Anyway, I've been slowly changing settings one at a time to see if I could isolate something which would stop the disconnects. This has taken quite a while, as sometimes the wifi would work for a day or so, before the 'death cycle' started.

After many attempts, I seem to have found a solution for me: Disabling WMM Mode on radio 1.
I'm aware this lowers the speed for devices on this radio, but given that I am able to leave WMM Mode enabled on the 5Ghz radio0, then it really doesn't matter for my use case. All devices on the slower radio are older ones anyway.

I'm posting this for a couple of reasons:

  • Maybe this will help others
  • What the heck would cause this? It seems so weird that disabling WMM on radio 1 could have such a massive impact on stability across both radios.

For the first time since moving here, I have stable wifi (1week+) with the following config:

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
        option htmode 'VHT80'
        option country 'FR'
        option channel '36'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option macaddr 'xx:xx:xx:xx:xx:xx'
        option ssid 'MySSID5Ghz'
        option key '*****'
        option disassoc_low_ack '0'
        option encryption 'psk2+ccmp'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
        option htmode 'HT20'
        option country 'FR'
        option channel '5'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option macaddr 'xx:xx:xx:xx:xx:xx'
        option ssid 'MySSID'
        option key '*****'
        option encryption 'psk-mixed+ccmp'
        option wmm '0'

I feel like I'm missing something, but I don't know what :man_shrugging:

Try to change wpad-wolfssl or wpad mini or full....to hostapd-openssl and wpa-supplicant-openssl

This in combination with your find of wmm and setting your 2.4ghz band to legacy....will solve everything!

Specify as much in Luci as possible....so fill in every standard value in the options in general and advanced...like distance, (don't force 40mhz!!!)

I have full 700-877mbit for 6 5ghz devices at the same time! And reconnects within 1 second!!! And my range and speed is better!

Looks at the beginning of the log lines...with 26 .... connected, handshake, authentication within 1 second

1 Like

You don't state device / OpenWrt version so a little supposition here:

  • Re. CC for locale, there is a patch that I have seen some in the EU report success with better behaviour frrom connecting clients.
  • Re. one radio going down when enabling the other, there is a FS and thread on the issue, resolution
1 Like

Thank you both. The device is a WRT32X (Don't know how I forgot to include that!), with the latest Davidc502 build, although I did try the vanilla OpenWRT builds and experienced the same wifi issues. This would have been on 19.07.3 though, not the recent .5 release.

@anon68513369 - Thanks, I will go and read up on this. It looks like the only package that is installed and is close to what you describe is "wpad-basic". Neither "hostapd-openssl" or "wpa-supplicant-openssl" is installed according to opkg. I will install them and do some reading.

@anomeome - Thanks, I've added the model to the post.
I've modified the file in /lib/netifd/wireless/mac80211.sh to match the one reported to work better.
Unfortunately, the patch is a bit beyond me currently, but thank you for the information. I'll add it to the list of things to read up on in the future.

Veth stuff doesnt work with new kernel at least not for me....

Hi all,

I've been using David's OpenWRT build for my WRT3200ACM for some years now as it was the only way to get decent Wireless speeds. This week I decided to try the latest build and got 2 problems:

  • wireless (2.4Ghz or 5Ghz) speeds are terribly slow: 1/10 of wifi speeds with stock firmware (don't have numbers on speeds on older David's build).

  • Some devices can't connect to network, it hangs on "obtaining IP address". So far I can confirm it happens with Android phones, while it works with a Mac and iPhone. Since I also changed my password, I haven't checked if all other devices are having the same problem.

Here's some logs when the Android device tries to connect:

Sun Jan  3 10:57:37 2021 daemon.debug hostapd: wlan0: STA 06:9c:ae:ab:e3:b1 IEEE 802.11: authentication OK (open system)
Sun Jan  3 10:57:37 2021 daemon.debug hostapd: wlan0: STA 06:9c:ae:ab:e3:b1 MLME: MLME-AUTHENTICATE.indication(06:9c:ae:ab:e3:b1, OPEN_SYSTEM)
Sun Jan  3 10:57:37 2021 daemon.debug hostapd: wlan0: STA 06:9c:ae:ab:e3:b1 MLME: MLME-DELETEKEYS.request(06:9c:ae:ab:e3:b1)
Sun Jan  3 10:57:37 2021 daemon.debug hostapd: wlan0: STA 06:9c:ae:ab:e3:b1 IEEE 802.11: association OK (aid 2)
Sun Jan  3 10:57:37 2021 daemon.notice hostapd: wlan0: STA-OPMODE-N_SS-CHANGED 06:9c:ae:ab:e3:b1 2
Sun Jan  3 10:57:37 2021 daemon.info hostapd: wlan0: STA 06:9c:ae:ab:e3:b1 IEEE 802.11: associated (aid 2)
Sun Jan  3 10:57:37 2021 daemon.debug hostapd: wlan0: STA 06:9c:ae:ab:e3:b1 MLME: MLME-ASSOCIATE.indication(06:9c:ae:ab:e3:b1)
Sun Jan  3 10:57:37 2021 daemon.debug hostapd: wlan0: STA 06:9c:ae:ab:e3:b1 MLME: MLME-DELETEKEYS.request(06:9c:ae:ab:e3:b1)
Sun Jan  3 10:57:37 2021 daemon.debug hostapd: wlan0: STA 06:9c:ae:ab:e3:b1 IEEE 802.11: binding station to interface 'wlan0'
Sun Jan  3 10:57:37 2021 daemon.debug hostapd: wlan0: STA 06:9c:ae:ab:e3:b1 WPA: event 1 notification
Sun Jan  3 10:57:37 2021 daemon.debug hostapd: wlan0: STA 06:9c:ae:ab:e3:b1 WPA: start authentication
Sun Jan  3 10:57:37 2021 daemon.debug hostapd: wlan0: STA 06:9c:ae:ab:e3:b1 IEEE 802.1X: unauthorizing port
Sun Jan  3 10:57:37 2021 daemon.debug hostapd: wlan0: STA 06:9c:ae:ab:e3:b1 WPA: sending 1/4 msg of 4-Way Handshake
Sun Jan  3 10:57:37 2021 daemon.debug hostapd: wlan0: STA 06:9c:ae:ab:e3:b1 WPA: received EAPOL-Key frame (2/4 Pairwise)
Sun Jan  3 10:57:37 2021 daemon.debug hostapd: wlan0: STA 06:9c:ae:ab:e3:b1 WPA: sending 3/4 msg of 4-Way Handshake
Sun Jan  3 10:57:37 2021 daemon.debug hostapd: wlan0: STA 06:9c:ae:ab:e3:b1 WPA: received EAPOL-Key frame (4/4 Pairwise)
Sun Jan  3 10:57:37 2021 daemon.notice hostapd: wlan0: AP-STA-CONNECTED 06:9c:ae:ab:e3:b1
Sun Jan  3 10:57:37 2021 daemon.debug hostapd: wlan0: STA 06:9c:ae:ab:e3:b1 IEEE 802.1X: authorizing port
Sun Jan  3 10:57:37 2021 daemon.info hostapd: wlan0: STA 06:9c:ae:ab:e3:b1 WPA: pairwise key handshake completed (RSN)
Sun Jan  3 10:57:37 2021 daemon.info hostapd: wlan0: STA 06:9c:ae:ab:e3:b1 IEEE 802.11: authenticated
Sun Jan  3 10:58:13 2021 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED 06:9c:ae:ab:e3:b1
Sun Jan  3 10:58:13 2021 daemon.debug hostapd: wlan0: STA 06:9c:ae:ab:e3:b1 WPA: event 3 notification
Sun Jan  3 10:58:13 2021 daemon.debug hostapd: wlan0: STA 06:9c:ae:ab:e3:b1 IEEE 802.1X: unauthorizing port
Sun Jan  3 10:58:13 2021 daemon.debug hostapd: wlan0: STA 06:9c:ae:ab:e3:b1 IEEE 802.11: deauthenticated
Sun Jan  3 10:58:13 2021 daemon.debug hostapd: wlan0: STA 06:9c:ae:ab:e3:b1 MLME: MLME-DEAUTHENTICATE.indication(06:9c:ae:ab:e3:b1, 3)
Sun Jan  3 10:58:13 2021 daemon.debug hostapd: wlan0: STA 06:9c:ae:ab:e3:b1 MLME: MLME-DELETEKEYS.request(06:9c:ae:ab:e3:b1)
Sun Jan  3 10:58:13 2021 kern.debug kernel: [ 4478.875956] ieee80211 phy0: staid 2 deleted

I did a clean upgrade (not keeping any configs) and haven't changed anything besides configuring wireless (with new password as stated before).

Here's my /etc/config/wireless:

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
	option htmode 'VHT80'
	option channel '40'
	option country 'DE'
	option log_level '2'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'redacted'
	option wmm '0'
	option encryption 'psk2'
	option key 'redacted'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option htmode 'HT20'
	option country 'DE'
	option log_level '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'redacted'
	option wmm '0'
	option encryption 'psk2'
	option key 'redacted'

and /etc/config/network:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'redacted' # let me know if it's helpful to show it here

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	list dns '1.1.1.1'
	list dns '1.0.0.1'

config interface 'wan'
	option ifname 'eth1.2'
	option proto 'dhcp'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'

I also flashed newest OpenWrt official build, same problem with Android and DHCP.

I'm now back to stock firmware after so many years :frowning:.

My phone won't go any faster my upstairs neighbor....has a speedtest of 780...up and down with a ping of 5ms on wifi!!!