Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds

Thanks for the reply. I was attached by cable to one of the LAN ports, but didn’t seem to get an IP. Is DHCP enabled by default?

Yes. DHCP, no wifi, no default password (it will prompt you to set one on first login).

If that doesn’t get you going, verify davids factory.img sha256 checksum you downloaded, get back to Linksys partition, and reflash the factory.img from there once more.

You want:
If your 1900AC is V1

If your 1900AC is V2

Try to document your leds when you reflash to OpenWrt/Davidc502 - might help if you still have issues.

1 Like

OK, so I confirmed the sha256 and it is correct. I have the V1.

$ openssl dgst -sha256 openwrt-mvebu-cortexa9-linksys_wrt1900ac-squashfs-factory.img 
SHA256(openwrt-mvebu-cortexa9-linksys_wrt1900ac-squashfs-factory.img)= 98d87536cb379e71d1be22c2d704ce58a35d54c15821c59a8c40f764ee19c016

After 3x power cycle, I saw:
power light slow blink, then lan lights on
power light fast blink, then fan spins up
eSATA light constant

It does three loops of that and reverts to the Linksys firmware.

The connections I have are WAN to OpenReach Fibre Modem, and 2 x LAN (Mac mini and Pi).

So, whatever you are flashing is failing to boot, tried three times, and on the fourth reverted to the other partition. I would try a different image. Maybe the recently released 19.x.

1 Like

I had a try with: http://downloads.openwrt.org/releases/19.07.5/targets/mvebu/cortexa9/openwrt-19.07.5-mvebu-cortexa9-linksys_wrt1900ac-squashfs-factory.img and it behaves in a similar way.

I notice that the comments on the data page: https://openwrt.org/toh/hwdata/linksys/linksys_wrt1900ac_v1 talk about renaming the image to the OEM code?

Wee bit difficult without a TTL serial to get an idea. Maybe try flashing OEM from your currently working OEM, yielding OEM on both, then try again from the new OEM, overwriting the one you are currently running. Just trying to get a sense as to some issue on flashing to the other partition. If that does not work I think you need to connect a serial. If it does then your OpenWrt image is suspect, try a different one.


So, I just flashed the factory firmware, and after 3x cycle I get slow flashing power LED. Perhaps that side is corrupted?

Thankfully the other side is booting very reliably!

Im puting my two cents in
Make sure the cable is in the switch port and no other cables are conneted. Only the one from pc you are flashing from then flash from factory. With wrt factory image.. I once had somthing like this happen to me with DD-wrt I think it was a verision issue I had two of the same images on both partions I waited to a newer DD-WRT was released then i flashed it on one of the partions. It sounds like you still have the factory image.

1 Like

I've just tried a DD-WRT build also, and same behaviour.

-----U-Boot Data-----
fw_printenv bootdelay: bootdelay=3

fw_printenv mtdparts: mtdparts=mtdparts=armada-nand:1024K(uboot)ro,256K(u_env),256K(s_env),1m@9m(devinfo),40m@10m(kernel),37m@13m(rootfs),40m@50m(alt_kernel),37m@53m(alt_rootfs),80m@10m(ubifs),-@90m(syscfg)

fw_printenv bootcmd: bootcmd=run nandboot

fw_printenv boot_part: boot_part=1

fw_printenv auto_recovery: auto_recovery=yes

fw_printenv mtdparts_version: 

I guess I must just have a broken partition. :frowning:

@anon68513369 thanks for this. Given I can't get the partition to boot at all, I don't think I can help to try it.

Hey Tim,

This is not specifically a solution to your problem, but a special build with fast openssl tls 1.3 capabilities and amazing fast dnscrypt-proxy2 dnssec .... excellent wifi performance as well as dnsmasq resolving! And with the new 2020 theme, latest trunk, kernel 5.4.82 and all packages from the dc502 images.

So I hope you find a solution to your problems!



The response and resolving times of dnsmasq in combination with dnssec (cloudflare) and with adblock blacklists are absolutely beautiful and amazingly fast even for a consumer fiber connection! And the response stays stable even in peak hours of internet!

I just did 5 extensive tests for my router and the ping, trace route, dnssec, speedtests are so beautifully consistent and fast.


what do you mean by fast dnscrypt-proxy2 dnsse ?
You mean you've already picked some fast dns servers in Toml config?
and what about DSA ?

My response/resolve times between my dnssec cloudflare or ams dnssec.....is between 4-5ms!

Like I wrote earlier, DSA works if you follow a tutorial with ip link set dev.....I have a separate vlan for my own lan(I share it with my upstairs neighbor).....it works without a hitch! We have a fiber connection with a vlan setting and a separate iptv vlan and a really short dhcp lease time....the router never missed a beat!

So follow the link for DSA,vlan settings
Dsa solution forum openwrt

Why is buffered "?" I see you had the same problem on RC7 :slight_smile:

There is a patch for the cryptodev build issue on 5.10.x.

Great job, thank you!
I will use it for my own build, but with different package set (f.e. i use SmartDNS instead of DNSCrypt), and some of my patches for wifi.

It is possible to help me about how i can to work hostname Iot esp devices without disable WWM ?

I am trying to install OpenWrt Venom wrt32x build for the very first time from the Linksys stock factory-installed web GUI, but get an "invalid firmware" message. I am sure there is a simple step that I am missing - can anyone advise how to get it installed?

I can’t seem to get any image accepted using the GUI. Would doing it from the CLI (using sysupgrade -n -v -F) be a potential workaround?

Apologies, I think I figured it out. For those who might be facing the same problem, it appears that at some point the web gui is no longer looking at the firmware, and is throwing up the "invalid firmware" error message indiscriminately. Some combination of rebooting the router and using a new browser/clearing cookies seemed to do the trick.

1 Like

Hi, im using OpenWrt SNAPSHOT r13342-e35e40ad82 / LuCI Master git-20.144.63033-62ed4e6 on a wrt1200ac v1
I use more tha one isp, i tried loadbalancing but its kinda buggy when i try to redirection traffic from X client to a specific WAN, the simple solution i found its adding the modems/routers without dhcp enable, so i just set manual ip for each client.
now im trying to add another ISP/router to my network using wireless as client, no luck so far, i can connect, wireless without problems, if i add an interface with ip i can ping the new router on network, but if i set manual ip/mask/gateway from another client on my network dont work, what could be the issue?!

the package relayd worked. i can ping the new wireless
using it as protocol for the new wireless client allow me to ping the router, but if i manually set the gateway its not getting internet.

Thanks again.