Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds

Is this the preferred builds for linksys wrt routers?
I went to the dc502wrt.org site, but I can't seem to see the functionalities diffs with openwrt official builds.
Could someone kindly show a short summary of the functionality diffs? The UI seems better, that's the only thing I know. Thanks.

No this is not preferred. It includes packages the official does not. Yes, the UI is one of them, but there are many more. Everything you see under "Services" would not be included either, but there are others.

However, if you have a list of your own preferred packages you could install them yourself from the official build.

1 Like

Thanks for the reply David.
Is your latest build in sync with openwrt's latest (19.x)?
I would love to try the UI. If added from the official build, what's the package name for your UI?
thanks,

David builds from the daily Snapshot releases so yes, it is (b)leading edge which comes with the caveat of possible anomalous behaviour from build to build. On the flip side IMHO, David’s builds have been extremely stable.

The UI theme is OpenTomato.

From David’s site:

  1. What are all packages that you include with the build? Short answer - There are a lot of features included, but some of the most popular ones are..

LuCi Gui - Webpage to make configuration changes.
USB Packages - For mounting USB sticks or external hard drives.
Network Shares - SAMBA service that gives network file sharing capabilities.
Dynamic-DNS - allows your router to be reached with a fixed hostname while having a dynamically changing IP address.
UPnP - allows clients in the local network to automatically configure the router.
OpenVPN - VPN service to turn the router into a VPN server or client.

You can find the package build manifest here: https://dc502wrt.org/releases/openwrt-mvebu-cortexa9.manifest

4 Likes

Does anyone here use Softflowd - software netflow exporter on David’s latest build?

It goes into a crash loop when instantiated via procd/init.d, but works fine from CL, rc.local, and custom init script. It worked as advertised on R12570 without a hitch.

Suggestions I’ve found are basically to re-flash and reload packages, and then raise an issue on github if it persists. So, before I re-flash or raise an issue specific only to me on this build I’m wondering if anyone else has experienced the same behaviour.

Note: my dl’d image file checksum is good so I’m confident in it’s integrity.

Latest Kernel 5.4.52 has some mvneta commits that cause a kernel warn:

[   18.963513] WARNING: CPU: 1 PID: 2474 at drivers/net/ethernet/marvell/mvneta.c:3490 0xc0546874
[   18.975570] Modules linked in: pppoe ppp_async pppox ppp_generic ipt_REJECT xt_time xt_tcpudp xt_tcpmss xt_statistic xt_state xt_recent xt_nat xt_multiport xt_mark xt_mac xt_limit xt_length xt_iprange xt_hl xt_helper xt_hashlimit xt_ecn xt_dscp xt_conntrack xt_connmark xt_connlimit xt_connbytes xt_comment xt_TCPMSS xt_REDIRECT xt_MASQUERADE xt_LOG xt_HL xt_FLOWOFFLOAD xt_DSCP xt_CT xt_CLASSIFY wireguard slhc sch_cake nfnetlink_cttimeout nf_reject_ipv4 nf_log_ipv4 nf_flow_table_hw nf_flow_table nf_conntrack_rtcache nf_conntrack_netlink nf_conncount iptable_raw iptable_nat iptable_mangle iptable_filter ipt_rpfilter ipt_ECN ip6table_raw ip6t_rpfilter ip_tables crc_ccitt act_ctinfo act_connmark sch_tbf sch_ingress sch_htb sch_hfsc em_u32 cls_u32 cls_tcindex cls_route cls_matchall cls_fw cls_flow cls_basic act_skbedit act_mirred mwlwifi mac80211 cfg80211 compat ledtrig_heartbeat cryptodev xt_set ip_set_list_set ip_set_hash_netportnet ip_set_hash_netport ip_set_hash_netnet ip_set_hash_netiface
[   18.975650]  ip_set_hash_net ip_set_hash_mac ip_set_hash_ipportnet ip_set_hash_ipportip ip_set_hash_ipport ip_set_hash_ipmark ip_set_hash_ip ip_set_bitmap_port ip_set_bitmap_ipmac ip_set_bitmap_ip ip_set nfnetlink ip6table_nat nf_nat nf_conntrack nf_defrag_ipv6 nf_defrag_ipv4 ip6t_NPT ip6t_rt ip6t_mh ip6t_ipv6header ip6t_hbh ip6t_frag ip6t_eui64 ip6t_ah nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables ip6t_REJECT x_tables nf_reject_ipv6 ifb ip6_udp_tunnel udp_tunnel tun gpio_button_hotplug
[   19.111306] CPU: 0 PID: 2474 Comm: netifd Not tainted 5.4.52 #0
[   19.117262] Hardware name: Marvell Armada 380/385 (Device Tree)
[   19.123217] Function entered at [<c010f528>] from [<c010b4f4>]
[   19.129079] Function entered at [<c010b4f4>] from [<c0733994>]
[   19.134942] Function entered at [<c0733994>] from [<c012b32c>]
[   19.140803] Function entered at [<c012b32c>] from [<c012b3ac>]
[   19.146665] Function entered at [<c012b3ac>] from [<c0546874>]
[   19.152527] Function entered at [<c0546874>] from [<c05469ec>]
[   19.158388] Function entered at [<c05469ec>] from [<c05fdca8>]
[   19.164250] Function entered at [<c05fdca8>] from [<c05fe0ac>]
[   19.170111] Function entered at [<c05fe0ac>] from [<c05fe124>]
[   19.175972] Function entered at [<c05fe124>] from [<c06254e4>]
[   19.181834] Function entered at [<c06254e4>] from [<c0625a44>]
[   19.187695] Function entered at [<c0625a44>] from [<c05d6f4c>]
[   19.193557] Function entered at [<c05d6f4c>] from [<c0244910>]
[   19.199418] Function entered at [<c0244910>] from [<c0244e78>]
[   19.205280] Function entered at [<c0244e78>] from [<c0101000>]
[   19.211141] Exception stack(0xdc95bfa8 to 0xdc95bff0)
[   19.216220] bfa0:                   bec57934 00000000 00000008 00008914 bec57934 bec57928
[   19.224441] bfc0: bec57934 00000000 00000001 00000036 094551d0 b63baf79 b63baf54 08b1dcf0
[   19.232660] bfe0: 08b1dd0c bec57910 08af09a0 b6407938
[   19.238355] ---[ end trace fb714792d0b3bb92 ]---

But ethernet still works fine...

Got a Linksys WRT1900ACS running stock OpenWrt 19.07.2. Planning on upgrading to latest version but perhaps use this custom build. Is there any special considerations I should take into account? A example is that the FAQ recommend using the .img instead of the .bin - I do not have a lot of packages and out of the normal configs in my current installation.

Firstly make a backup of your current router configuration (Always best to have just incase).

Then as your upgrading OpenWRT to another build of OpenWRT you can use the sysupgrade.bin file to upgrade to a new version.

You only need to use the .img file if your flashing from Stock firmware.

I'm currently running build r13059 on a WRT1900ACS, and twice now I've ran into an issue with both the 2.4Ghz and 5GHz radios crashing after heavy load on the 5GHz network while doing a LAN backup via Veeam Windows agent to a router mounted USB hard drive. I've come across forum posts in the past of the WiFi crashing with heavy load on these Linksys routers with this custom firmware, and I'm just wondering if this is still a known issue. I'm contemplating just buying a separate wireless AP and shutting off the WiFi on my router.

It is happening again.... is there any way you could upgrade the dnscrypt-proxy2 version @davidc502

Whats the reason there wasnt a new build since 2 months btw?

If you've read this thread a bit, you would have known that the reason is DSA

Please no stupid short cuts no one knows what they mean, what is a DSA.

Quick question by noob. How much space is left free in WRT1900ACS (shelby) after flashing latest (r13342)?

Many Thanks

Please no stupid remarks, won't get you anywhere in this forum. Good luck with finding your answers.

3 Likes

it is stated

1 Like

Nice. Coming back to the original question: Why no new updates anymore since 2 months? Is the DSA stuff broken since 2 months or what.

You will have ~ 7MB available in /.

1 Like

@RuralRoots - This is an unrelated issue.
@mfka8 - The problem is that DSA uses a different configuration concept which is incompatible to the one used so far. Newer builds using older configuration will have non-functioning ethernet and thus appear to be soft-bricked in some cases.

Verily, it is. It was meant to be flippant as in ‘you can’t build from the snapshot when they aren’t building atm’ when he clearly hadn’t looked in to the direction he had been given re. (DSA).

Shoulda just said:

Workaround

Luci > 
System > 
Scheduled Tasks > 
[paste]30 3 * * * sleep 90 && touch /etc/banner && reboot[end-paste]
Save >
Reboot

Problem solved.

My apologies.