Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds

Hmm, so possibly misinformation or someone misinformed recommending those to me, if stock 18.06.4 and Davidc502 builds are no different than those drivers?

Thank you for the reply!

When these drivers were still being developed, stable releases (and even snapshots) where usually not up to date with development, and using my packages or @davidc502's builds would make a difference.

There have literately been no commits to mwlwifi in 8-9 months, and no useful commits in a year. The open source project has been abandoned by Marvel. In other words, Wi-Fi is not going to improve for these devices moving forward.

Right, now this is a bit unrelated and offtopic from the thread (although semi-related due to Driver related talks and what it's using) but I had opened up a threat on the forums here: WRT32X with 18.06.4 - 2.4GHz dies after a few weeks

And was told to try these drivers, but it was my understanding that they haven't really changed so I was curious and what may or may not be different between those drivers, Davidc502's builds, as well as Stock OpenWRT.

Now based on what @eduperez said above, it seems possible that Stock OpenWRT 18.06.4 may not be using these latest drivers or in the past haven't always been fully up-to-date, although that doesn't say for sure if 18.06.4 is using the latest.

The master gitlog version, the 19.x version, the 18,x version; check that against what you see in the image you are running.

Don't run 18.06 it's just too old. At this point if you are going to run an official OpenWrt then run 19.07 RC1: OpenWrt 19.07.0 first release candidate

Davidc502 is built off Master which is more update to date but potentially less stable.

Done -- And I've saved the config. It should be available for use in the next build.

Thanks for bringing to my attention. This is a good options to have available.

3 Likes

Is there still no easy way to add secure DNS btw? Why does DNSMASQ not support DNS over HTTPS?

I have installed the 19.07 version on asc1900 but why is the latency higher on that than with davidbuild ?

HI Davidc502-, thank you for providing these builds. I bought a wrt32x to replace an overbooked wndr3800 and the wifi now screams with your build on this hardware.

I'd like to customize your build a bit. For my wndr3800, I customized hnyman's builds, here: Build for WNDR3700v1/v2 / WNDR3800 . He provides .config.init files, which are minimalistic requirements to make his build. Copying .config.init to .config and running make defconfig will create a full blown .config ready to build with all dependencies. That proces seems to avoid the menu dependency problem folks ran into above.

Could you help me build the minimal .config.init of your build or give me an idea of what it would be and I can run tests to try to make something work? Any suggestion is appreciated and thanks again for the builds.

Example config.init for wndr3800

I do make a change to the wifi driver that helps 1200ac users with latency, but not aware that it helps the 1900acs. Otherwise, there is no difference between the two.

Glad wifi is working well for you. Generally, I don't recommend the opensource wifi on the wrt series.

Everything you need to build your own custom version of this build will be found in this directory.

https://dc502wrt.org/snapshots/r11398/targets/mvebu/cortexa9/

Is it possible to make the change when i have it installed ?

No, that the change is pre-compiled. However, for example, if you want to use OpenWrt Stable build, as long as it has the same kernel version as the build here, you can download and install it on stable. It works the same way vice versa.

@davidc502
Hi David - Sorry for the delayed response on this.
I finally got some time to run the command you asked me to run.
Before I ran the command, I reset to default settings then I upgraded to the latest build " r11398" and made the following changes
I edited the .toml file and changed the listen_addresses = ['127.0.0.1:5300'] and server_names = ['cloudflare']
Then I restarted /etc/init.d/dnscrypt-proxy restart
Then I edited /etc/config/dhcp and added list dhcp_option '6,192.168.1.1' under LAN and added list server '127.0.0.1#5300' under "config dnsmasq"
and I restarted /etc/init.d/dnsmasq restart

Then when I ran the command "dnscrypt-proxy -config /etc/dnscrypt-proxy2/dnscrypt-proxy.toml -check" and the output was as shown int he screenshot below:

Screenshot%20at%202019-11-11%2017-16-26

Dear Dave,
As always - you are simply the best - and I do not overstate my sentiments regarding how you treat us all whenever we ask you for your assistance and expertise. Together we all make each other better - so I appreciate your thanks for my bringing this to your attention. However, I do count my blessings in that you are dedicated and kind enough to devote your time and effort to this outstanding project of yours which benefits so many. Long Live Davidc502 Builds - Peace My Brother

2 Likes

No, dnsmasq does not support it.

Looks like a firewall rule is keeping dnscrypt proxy from getting out.

Can you ping the following 2 IP's please - 1.1.1.1 and 1.0.0.1

Also, from Windows command line run the following

nslookup cnn.com 1.1.1.1

Upgraded to r11398, still having the collectd errors at boot.


Find another thread regarding this issue:

Tried the suggested fix whitout success, any other idea ? It's not really bothering for now as I just disable collectd but might need it in the future

Sorry I don't have any idea however collects seems to run fine as well as rrd so you can safely ignore the errors.