D-Link DWR-921 random reboots

Hi all,

Can someone help me? I have installed OpenWRT about half year ago, it was kind of random process, since I upgraded alot of packages (?) and afterwards I red that I shouldn't. Nevertheless the device (D-Link DWR-921) was working flawlessly, never rebooted or so. Today I've installed the nevest release leaving the current configuration. And I had a random reboot.
My question is, should I just leave it as it is, or should I reset it to "factory defaults" or something?
I use it as a daily driver, and I stability is my main priority.
Thanks in advance for any suggestions

Best practice is start fresh when making a major upgrade. When you upgraded, if you had "keep settings" checked, the upgrade process attempted to migrate your settings. This doesn't always work flawlessly, as some minor issues can crop up as a result of under-the-hood changes.

You should perform a backup, then reset to defaults. From there, re-create your settings (don't restore) -- you can always use your backup as a reference.

Hopefully that will sort things out, but if not, you'll want to do some more troubleshooting to see if you can figure out what conditions might cause a reboot and if you can repro it on-demand.

Thank you for the reply. Today I had another router reset. I will try to hit the red button "Perform reset" and I'll see if it helps.

That is the one! Be sure to hit that “generate archive” button first.

After some issues, the device is up and running :slight_smile:

I wonder how stable it will be now. Any advices what could I do more? Clear some logs or something?

Just run with it and monitor the performance. If you notice problems, we can investigate further. Otherwise, openwrt is often quite stable.

Had another reboot today morning, no specific activity which I could identify.
What could I do to make it as stable as it was on previous release (few months uptime, not a single reboot)?

Maybe I should install from "factory image" or something?

Funfact: last time I have updated almost all of the packages, then I red I shouldn't do that and that can be harmful. Nevertheless router whas rock solid, not any single issue.

Don’t flash the factory image.

The factory image is for the initial install of OpenWrt from the vendor firmware. It is the same except for the way it is formatted so that the vendor firmware will recognize and install it. If you install the factory image on a router already running openwrt, it may brick the device because openwrt expects the sysupgrade images.

What were/are the specific symptoms you experienced as the router had issues?

Have you looked though the log file for any interesting errors or warnings? The log file is cleared on reboot because it is stored in ram, so you won’t be able to see the events immediacy before the issue, but you might see some things of interest in the logs since the latest boot if there is some recurring / precursor issue.

Do you have the ability to send the logs to a syslog server? This would help catch the events immediately preceding the issue.

Thank you for the reply. The first ever reboot was while downloading some torrent, so this might be some heavy job. But next reboots where just random.
I'm not sure, if it's even possible, but I think that i'v heard some clicking noises from the router. But it doesn't repeat anymore.
As this is an 4G router, I was using some tutorial from another website how to get it running, so I think now I try the "official" way how to enable the modem:


uci set network.wwan=interface
uci set network.wwan.proto='wwan'
uci set network.wwan.apn='<your provider apn>'
uci set network.wwan.pincode='<your sim pin code>'
uci set network.wwan.auto='0'
uci commit network

I have some hosting plan, with domain. Is it hard to enable remote loging?
Also can you tell me what's part mean?

Enable all the ttyUSB interfaces

Shall I "perform" it also?

Update: I have configured the router "the proper way", but it was still unstable.
So I reverted to 19.07.8, and now I'm struggling with autoconnect, even though:

uci set network.wwan.auto='1'

This D-Link is driving me nuts!

One possible scenario that could cause the behavior you are seeing is related to power. The torrent activity would be a period of high utilization, and it is possible that your other reboots are happening under similar circumstances.

Do you have another 12V @ 1A (or higher amperage) power adapter? If so, try replacing the one you are using now and see if that resolved the issue.

20.02.0 -> 5 reboots for two days
19.07.X -> 0 reboots for 7 months and counting

So i'll try 20.02.X in few months. I work from home using this router, so stability is my main concern.

One thing that was working (than I tried 20.02.0, had reboot and went back) is that this command "stopped working":

uci set network.wwan.auto='1'

It just won't. Tried enablning and disabling with no success. It's like it's not there.

config interface 'wwan'
        option proto 'wwan'
        option apn 'internet'
        option auto '1'

I have had the same problem with my router (DWR-921).
The reboot of the router was correlated with the number of active wifi clients.
I changed the wifi transmit power from 20 dBm (default) to 12 dBm. At the same time I changed the mode from 'legacy' to 'N', but I do not think it has any effect on the result.
It solved my problem - no spontaneous reboots.

The problem is probably related to the fact that the power supply adapter can not supply enough power (as @psherman also suggests)

So you're running 20.xx version?

I’m using ver. 21.02.1. I also updated from 19.xx - and I did not notice any reboots with the old version. I do not know if the default Wi-Fi transmit output power has changed, but I have also changed the country code (which might have an impact on the transmit power).

In my case changing coutry code didn't stop reboots.
On 19.XX i have Current power: 20 dBm


I updated the firmware (21.xx), moved the router to another location (country) - far away from the nearest base station, in a house with walls of stone and changed the service provider as well.
The 4g modem and the Wifi radio are having a hard time (needs a lot of power).
So I can’t say that my problem is related to the new firmware.
However, it was clear to me that the number of wifi clients was correlated with the reboot. 3-4 clients (signal lower than -80 dBm) and the router rebooted within a few minutes.
No entry in the syslog and no output on the console.
Unfortunately I do not have access to the router now. But when possible I’ll use an other power adapter (2A) and see if it makes a difference.

1 Like

I've flashed 21.02.1 a couple days ago and had a few reboots as well. All configs are the default. I don't have a SIM card inserted. There seems to be a correlation to the number of wifi clients, if there are any tests I could be doing, I'd be happy to help!

I can't speak to any issues that might be unique to that hardware, but sometimes these types of issues can be related to a power problem. If your power brick is not able to provide enough power, it could cause this exact behavior.

You can stress the router by running speed tests and other traffic intensive activities and see if that causes a reboot or any odd behavior.

Take a look at your power adapter -- many of these types of routers use a 12V DC adapter that can supply current of 1A or so (some may be as high as 3A). Check the specs of your adapter and then look (in your junk drawer) to see if you have an adapter with the same voltage rating but a higher current capability. If it is a power issue, this may resolve the problem.