D-Link DIR 645 Cannot connect in failsafe mode


I have spent several hours trying to connect to the router, in which I turned off DHCP mode. I can get the router into failsafe mode by clicking the blinking button, which then goes into 'rapid blink mode'.

I then connect the utp cable to the router and laptop, and then a new connection pops up on my laptop. I tell this connection I want a static IP,, so I can connect to the router on

I cannot get this to work. I have tried every possible combination of connecting the cable to each of the 5 ports, before or after going into failsafe mode. Whenever I try to ping the router, or try to SSH, or try to access the router by navigating to in the browser, I get either timeouts or destionation host unreachable.

What am I doing wrong, or how can I restore the router?

Kind regards,

You might try this procedure...


I do not know exactly why, but I could connect to the original interface after following the steps in the guide. Not what I expected, but better, so thanks!

Because, if you only disabled DHCP on the router, you only needed to assign a static IP to the computer you were troubleshooting with.

Once you gave the machine a static IP of, you could reach

Consider marking this tread as "SOLVED."

the rescue interface douse not configure the switch on power up & sometimes the switch is left in a state where it wont let communications through
this is made harder if you have a badly configured system where switch is badly configured & won't get reset
what you need to do is wait for the switch do drain of power & hope it comes up in a good state to connect
the best way to do this is remove power for quite a while say 5 minutes between attempts it can take a few goes some times