D-Link DIR-300 B5 - flashed wrong firmware, bootloop

According to this topic:

A friend tried to downgrade u-boot, flashed accidently "dir600b_v2.17_bbox-v1.19.1.bin" into DIR-300 B5 router. Since then router does not work properly.
I got access to emergency web-boot on
But I can't flash a working firmware. Device stucks on boot-loop.

When I try to flash file from openwrt site:
I got message:
Unable to upload the image, please make sure the uploaded file is the correct image."

I have searched for a stock firmware, found this site:
Tried to flash some old firmwares, but without success.
Same with firmware from d-link site: https://media.dlink.eu/support/products/dir/dir-300/driver_software/dir-300_revb_firmware_patch_2.06.zip

I suppose guilty is a wrong U-Boot. Any chance to fix the device?

the fact you were able to flash anything suggests your u-boot isn't a total disaster.

you may need use serial and re-flash the old u-boot (if you can find it. look in the GPL code)

1 Like

Thanks for help, it worked.

1 Like

EGADS, thommay that's some no-frills problem-solvin' right there.

good job.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.