D-Link DIR-2660 A2 Snapshot Builds

Hi! I read this thread on changes in the current revision of the DIR-2660 and saw briefly after that the commit containing the required fixes landed in the main git repository.

This means the adjustments should be contained in the current snapshot builds, is that correct? I was unable to flash today's snapshot build (openwrt-21.02-snapshot-r16297-1c95d78f08-ramips-mt7621-dlink_dir-2660-a1-squashfs-factory.bin) from the Recovery mode -- the recovery light kept blinking and when I eventually decided to restart after an hour or so I was greeted with the vendor firmware.

EDIT: Sorry, I was confused by the release snapshots -- I didn't realize there were Snapshot builds after the release was done and tried flashing the wrong image. I'll report back as soon as I could try flashing the correct image (dlink_dir-2660-a1-squashfs-factory.bin w/ sha 917d91284a461e719d95e9a1d761746c8cbdb04e8e0c0b849a4bb05698ce53ee at the time of writing).

EDIT 2: The behavior is the same unfortunately. Can somebody help me understand why the image won't flash?

the commit was accepted into the Mater branch so not into the 2102 branch
some of the later boot loaders in the DIR-2660-A1 & A2 didn't accept
firmware with the model number fields in the firmware filled in
so current master snapshots have these changes

you will have feed back from the recovery console if the file is accepted for flashing
but the recover console has other problems
in most cases it won't flash from linux via a web browser
I use firefox on windows but even that must be in private browser mode

if your browser is working you will get feed back
you will ether get a message saying firmware file failed
or you will see it saying trying to flash

if you are still having problems let me know what OS & browser you are using ?
also do try private or incognito mode on your browser

1 Like

Hi! Trying to install on DIR-2660 A2 without any luck so far.

Downloaded from here: https://downloads.openwrt.org/snapshots/targets/ramips/mt7621/

Tried with:

Ubuntu - Firefox
Ubuntu - Firefox Private Window
Windows - Firefox
Windows - Firefox Private Window
Windows - Chrome
Windows - Chrome Incognito

In all above cases I did get feedback that the firmware had failed.

was this from the recover interface
or the d-link normal firmware interface ?

just a note should be using the factory image

others have backdated via the normal web interface to V1.04
then via recovery page flashing has worked

1 Like

I was using the normal firmware interface :roll_eyes:

Using the recover interface it worked, installed LuCI and played around a bit...

Decided to go back to the stock firmware for now.
This fails to upgrade or gives timeout by the recover interface, tried multiple releases, no luck so far.
Has maybe something to do with encrypted firmware that the recovery interface doesn't support?

if you need it try this unencrypted version
then you should update normally


That one worked! Thanks!!