D-Link 878 with OpenWrt


Newby here - I purchased a D-Link 878 router for using it with OpenWRT, and it is supported, but for some reason I failed to get it work. I can use the D-Link manual firmware updater GUI, but nothing happens after I get the factory.bin upload Successful! message. I could find official firmware that I can re-flash this way and fix the router but I would like to use OpenWRT and not the official firmware... can someone point me into the right direction, please?

Hardware data page -

See the D-Link Recovery GUI method, and confirm you followed all the steps -

Thank you for your reply! I have used these two linked pages to educate myself, but unfortunately, these are not filling all the gaps in my knowledge in order to successfully install OpenWRT. I was hoping someone could put together some sort of guidance for people like me, who need more detailed info about the steps than these. I am not calling these useless, I rather like to admit that I am unable to utilize every bit of info in these articles in order to succeed.

These are the instructions...

A missed step (or more) can cause an unsuccessful result.

You might read them over a few times...otherwise, I suggest you stick with the stock firmware, if you're unable to follow them.

fair point, I wouldn't disagree if my outcome would be listed on the troubleshooting section. Unfortunately for me, it isn't.
I don't get an error, I don't get interrupted, I get the success message, but nothing happens and the router is not available for connection in any way, unless I put it back into the Recovery GUI mode. I don't see anything on the pages about this outcome. :confused:

You might try temporarily disabling the firewall on your computer.

In some scenarios, it can interfere.

The git-commit instructions (from the hardware data link posted above) mention browser/OS combination issues...


You might try another browser.

1 Like

A1 or R1 version?

Which OpenWrt image exactly did you flash?

How exactly are you trying to connect to your device after flashing OpenWrt?

1 Like

use a windows computer "Linux won't work"
get the openwrt factory image file for you DIR-878-A1
use Firefox in private mode to upload this file via the recover interface

1 Like

Were you using OpenWrt Stable release build or Development Snapshot build?

Snapshots do not include a graphical user interface (LuCi)
Are you saying that the D-Link firmware is still in place?

Version is D-Link DIR-878 A1
The image I have tried to flash is from the article that was posted by OldNavyGuy as well (21.02.2) via the D-Link Recovery GUI, tried it on Windows 10 64bit using latest Firefox browser version with and without the Incognito mode, but the result was always the same. Then I tried it with my 7 yrs old Macbook, using Safari, with the same results.

I believe it is the Stable release but I may be wrong - I used the version the 'official' guide contains linked.
The D-Link firmware was not verifiable, because the router has no other availability than the Recovery GUI itself. Everything else does not respond or work. I could reinstate the official D-Link firmware (v1.30) so it still works with that, but not with the OpenWRT image. It does not respond to ping, it does not show up for ipconfig to show a gateway IP, and also not available via web browser - until I want to use the Recovery GUI, which does work.

this is exactly what I have done, but I got no visible or verifiable results. :frowning:

in the "D-Link Router Recovery Mode" page select the file & then hit Upload
the waning will change from
"If a wrong firmware image is upgraded,the device may not work properly or even could not boot-up again."
to "Do not interrupt the update process,as it may demage the device" & yes "demage" :slight_smile:

and it will say "Device is upgrading the firmware...xx%" counting to 100%
the firmware will finish flashing and boot and you will have a green light at about 60%
and openwrt is installed

after the counting gets to 100% it then says "Upgrade successfully!"

change your interface back to dhcp & you ip to & you will get openwrt page

this was done with only 1 cable plugged into the lan next to yellow wan

1 Like

I'll do it again, because it was 1-2 am when I did the steps, I rather like to just confirm everything as described here. Thanks, I will report back later today!

if even that fails here is a link for an encrypted version
you can flash from the dlink firmware

1 Like

I have tried again, and using your steps above, plus the file you have provided, magically, now it works. :slight_smile: Thank you for your time and for your help! :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.