Custom dns servers not working

I have create separate Guest wlan on 2.4Ghz radio with separate vlan or subnet. When I setup the dhcp server I used openDNS servers under custom dns server. But when I connect to guest wifi and do ipconfig, it shows 172.18.xxx.1 as dns servers and not showing open DNS servers. How to fix this?

Hi,
have a look at interfaces/dhcp-server/advanced
Last line "dhcp-options":

Define additional DHCP options, for example "6,192.168.2.1,192.168.2.2" which advertises different DNS servers to clients.

1 Like

The standard way of operation for OpenWrt is that the router acts as a DNS server for all the clients (so that is what they receive by DHCP).

For guest I don't want the router to act as dns server. I tried the option dhcp-options but I didn't get connected to the guest ssid.

You would add a DHCP Option 6 to the GUEST DHCP config in the LuCI web GUI:

Screenshot%20from%202018-09-26%2010-48-36

Or in /etc/config/dhcp

config dhcp 'guest'                                
        option interface 'guest' 
        option start '100'                 
        option limit '150'                       
        option leasetime '12h'             
        option dhcpv6 'server'                   
        option ra 'server'     
        option ra_management '1'
        list dhcp_option '6,8.8.8.8,8.8.4.4'
  • So, as you're aware, that you will not resolve local hostnames in the guest VLAN/Interface after applying this setting.
  • Also, to apply this, you will have to restart dnsmasq, and obtain new leases for all clients.
1 Like