Cudy WR1300 v3 - 23.05.3 - Add VLANs crashes network adapter

Hi all,

I created at my Cudy WR1300 several new VLANs.
When I'm adding the VLAN 1 as default Untagged and 1 several VLAN 140 all is looking fine.
I want to add 2 more VLANs. When I want to apply the changes in LUCI the network adapter crashes and don't came up again without reverting the preferences.
In system.log is nothing written.
When I change the VLAN filtering option in SSH from 0 to 1 the network adapter crashes and I must restart the router in Failsafe mode and revert this.

Here are my network config

# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fd9f:f265:6dcf::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        option vlan_filtering '0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.130.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.2.1'
        list dns '8.8.8.8'

config interface 'wan'
        option device 'wan'
        option proto 'static'
        option ipaddr '192.168.2.2'
        option gateway '192.168.2.1'
        option netmask '255.255.255.0'
        list dns '8.8.8.8'
        list dns '8.8.4.4'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

config route
        option interface 'lan'
        option target '0.0.0.0/0'
        option gateway '192.168.2.2'

config route
        option interface 'wan'
        option target '0.0.0.0/0'
        option gateway '192.168.2.1'

config device
        option name 'phy1-ap0'

config interface 'Gast'
        option proto 'static'
        option device 'br-lan.140'
        option ipaddr '192.168.140.1'
        option netmask '255.255.255.0'

config bridge-vlan
        option device 'br-lan'
        option vlan '1'
        list ports 'eth0:u*'
        list ports 'lan1:u*'
        list ports 'lan2:u*'
        list ports 'lan3:u*'
        list ports 'lan4:u*'

config bridge-vlan
        option device 'br-lan'
        option vlan '140'
        list ports 'eth0:t'
        list ports 'lan1:t'
        list ports 'lan2:t'
        list ports 'lan3:t'
        list ports 'lan4:t'



I added the eth.0 to the Bridge otherwise VLAN config is crashing also
In first step I created a new bridged device with VLANa. When I want to use this in my LAN adapter network service didin't came up.
Then I created 2 VLANs (1 all ports Untagged, 140 all Ports tagged) and saved this. With this options all is looking fine.

It seems like a bug with luci and vlans. see here https://github.com/openwrt/luci/issues/7196

You don’t need, and should not be using the vlan-filtering option.

With that line removed, do VLANs work as expected?

seen the tiny arrow next to "Save & Apply" ?

Why it should not be used? My understanding was that vlan filtering option must be set.

Of course but I don't want to apply it unchecked. Because if I made any mistake here I must revert it with failsafe mode.

I tested today on my test device. Dlink DAP1325 MediaTek MT7628NN

checked the vlan_filtering enabled at CPU
regarding to this thread https://github.com/openwrt/openwrt/issues/14195#issuecomment-1850517349 I see /sys/class/net/br-lan/bridge/vlan_filtering is set to 1

Old config

cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd5e:4129:8e90::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.130.244'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.130.1'
        list dns '192.168.130.1'
        list dns '192.168.2.1'

config changed

cat /etc/config/network.wrong

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd5e:4129:8e90::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-test.1'
        option proto 'static'
        option ipaddr '192.168.130.244'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.130.1'
        list dns '192.168.130.1'
        list dns '192.168.2.1'

config device
        option type 'bridge'
        option name 'br-test'
        list ports 'eth0'
        option mtu '1500'
        option ipv6 '0'

config bridge-vlan
        option device 'br-test'
        option vlan '1'
        list ports 'eth0:u*'

config bridge-vlan
        option device 'br-test'
        option vlan '130'
        list ports 'eth0:t'

config bridge-vlan
        option device 'br-test'
        option vlan '140'
        list ports 'eth0:t'

config bridge-vlan
        option device 'br-test'
        option vlan '150'
        list ports 'eth0:t'

config bridge-vlan
        option device 'br-test'
        option vlan '128'
        list ports 'eth0:t'

config interface 'mgmt'
        option proto 'static'
        option device 'br-test.128'
        option ipaddr '192.168.128.244'
        option netmask '255.255.255.0'

After this no further connection available. Not with port 22 and also no other connections (ping) are available.
Checked with Wireshark directly at ETH adapter. I only saw UDP and ICMP requests on network but no VLAN tag. I suggest that the VLAN has been stripped by the network adapter. Indipendent of this I think that with this config all traffic should sent via VLAN 1 untagged. I'm totally confused about this at the moemnt

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.