CTRL-EVENT-BEACON-LOSS issue

I noticing the frequent CTRL-EVENT-BEACON-LOSS for the system log. and I'm using OpenWrt 19.07.2, r10947-65030d81f3

and my wifi configuration as below:

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/ar933x_wmac'
	option txpower '14'
	option channel 'auto'
	option country 'CA'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option mode 'ap'
	option key '*******'
	option ssid 'OPWRT_505_N2'
	option encryption 'psk-mixed'
	option network 'lan'
	option disabled '0'

config wifi-iface 'wifinet2'
	option ssid 'OPWRT_505_N1'
	option device 'radio0'
	option mode 'sta'
	option key '*******'
	option network 'wwan'
	option encryption 'psk2'
	option disabled '0'

My network Topology is OPWRT_505_N2<--->OPWRT_505_N1<--->1st level router to ISP.(Connection between router are wireless)

anyone know what's wrong?

Sun Jan  3 15:23:05 2021 daemon.notice wpa_supplicant[1622]: wlan0: CTRL-EVENT-BEACON-LOSS
Sun Jan  3 15:23:06 2021 daemon.notice wpa_supplicant[1622]: wlan0: CTRL-EVENT-BEACON-LOSS
Sun Jan  3 15:23:08 2021 daemon.notice wpa_supplicant[1622]: wlan0: CTRL-EVENT-BEACON-LOSS
Sun Jan  3 15:23:09 2021 daemon.notice wpa_supplicant[1622]: wlan0: CTRL-EVENT-BEACON-LOSS
Sun Jan  3 15:23:11 2021 daemon.notice wpa_supplicant[1622]: wlan0: CTRL-EVENT-BEACON-LOSS
Sun Jan  3 15:23:13 2021 daemon.notice wpa_supplicant[1622]: wlan0: CTRL-EVENT-BEACON-LOSS
Sun Jan  3 15:23:15 2021 daemon.notice wpa_supplicant[1622]: wlan0: CTRL-EVENT-BEACON-LOSS
Sun Jan  3 15:23:17 2021 daemon.notice wpa_supplicant[1622]: wlan0: CTRL-EVENT-BEACON-LOSS
Sun Jan  3 15:23:18 2021 daemon.notice wpa_supplicant[1622]: wlan0: CTRL-EVENT-BEACON-LOSS
Sun Jan  3 15:23:19 2021 daemon.notice wpa_supplicant[1622]: wlan0: CTRL-EVENT-BEACON-LOSS
Sun Jan  3 15:24:48 2021 daemon.notice wpa_supplicant[1622]: wlan0: CTRL-EVENT-BEACON-LOSS
Sun Jan  3 15:24:53 2021 daemon.notice wpa_supplicant[1622]: wlan0: CTRL-EVENT-BEACON-LOSS

I have the same issue between WR740N (Access Point) 2GHz -> Archer C7 v5 (Client) 2GHz Doesn't seem to interrupt the connection and it only occurs while in transfer which got me thinking the link gets hammered and beacons go missing?

I'm faced with the same problem between two TP-Link TL-WR841N (V8 as Client and v10 as the Master)
Here logs for such situation. When it happens on router, there is no Internet on devices connected to Client router.

Mon Mar  1 16:32:32 2021 daemon.notice wpa_supplicant[16240]: wlan0: CTRL-EVENT-BEACON-LOSS
Mon Mar  1 16:32:41 2021 daemon.notice wpa_supplicant[16240]: wlan0: CTRL-EVENT-BEACON-LOSS
Mon Mar  1 16:32:45 2021 daemon.notice wpa_supplicant[16240]: wlan0: CTRL-EVENT-BEACON-LOSS
Mon Mar  1 16:32:55 2021 daemon.notice wpa_supplicant[16240]: wlan0: CTRL-EVENT-BEACON-LOSS
Mon Mar  1 16:33:04 2021 daemon.notice wpa_supplicant[16240]: wlan0: CTRL-EVENT-BEACON-LOSS
Mon Mar  1 16:33:04 2021 daemon.notice wpa_supplicant[16240]: wlan0: CTRL-EVENT-DISCONNECTED bssid=f4:f2:6d:60:59:d6 reason=4 locally_generated=1
Mon Mar  1 16:33:04 2021 daemon.notice netifd: Network device 'wlan0' link is down
Mon Mar  1 16:33:04 2021 daemon.notice netifd: Interface 'wwan' has link connectivity loss
Mon Mar  1 16:33:04 2021 daemon.notice netifd: Network device 'wlan0-1' link is down
Mon Mar  1 16:33:04 2021 daemon.notice netifd: wwan (16259): udhcpc: received SIGTERM
Mon Mar  1 16:33:04 2021 daemon.notice netifd: Interface 'wwan' is now down
Mon Mar  1 16:33:04 2021 daemon.notice netifd: Interface 'wwan' is disabled
Mon Mar  1 16:33:04 2021 daemon.notice netifd: Interface 'wwan' is enabled
Mon Mar  1 16:33:04 2021 daemon.info dnsmasq[789]: reading /tmp/resolv.conf.auto
Mon Mar  1 16:33:04 2021 daemon.info dnsmasq[789]: using local addresses only for domain test
Mon Mar  1 16:33:04 2021 daemon.info dnsmasq[789]: using local addresses only for domain onion
Mon Mar  1 16:33:04 2021 daemon.info dnsmasq[789]: using local addresses only for domain localhost
Mon Mar  1 16:33:04 2021 daemon.info dnsmasq[789]: using local addresses only for domain local
Mon Mar  1 16:33:04 2021 daemon.info dnsmasq[789]: using local addresses only for domain invalid
Mon Mar  1 16:33:04 2021 daemon.info dnsmasq[789]: using local addresses only for domain bind
Mon Mar  1 16:33:04 2021 daemon.info dnsmasq[789]: using local addresses only for domain lan
Mon Mar  1 16:33:04 2021 daemon.info dnsmasq[789]: using nameserver 192.168.1.1#53
Mon Mar  1 16:33:05 2021 daemon.notice wpa_supplicant[16240]: wlan0: SME: Trying to authenticate with f4:f2:6d:60:59:d6 (SSID='WiFi 123' freq=2437 MHz)
Mon Mar  1 16:33:05 2021 daemon.notice wpa_supplicant[16240]: wlan0: Trying to associate with f4:f2:6d:60:59:d6 (SSID='WiFi 123' freq=2437 MHz)
Mon Mar  1 16:33:05 2021 daemon.notice netifd: Network device 'wlan0' link is up
Mon Mar  1 16:33:05 2021 daemon.notice netifd: Interface 'wwan' has link connectivity
Mon Mar  1 16:33:05 2021 daemon.notice netifd: Interface 'wwan' is setting up now
Mon Mar  1 16:33:05 2021 daemon.notice wpa_supplicant[16240]: wlan0: Associated with f4:f2:6d:60:59:d6
Mon Mar  1 16:33:05 2021 daemon.notice wpa_supplicant[16240]: wlan0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
Mon Mar  1 16:33:05 2021 daemon.notice wpa_supplicant[16240]: wlan0: WPA: Key negotiation completed with f4:f2:6d:60:59:d6 [PTK=CCMP GTK=CCMP]
Mon Mar  1 16:33:05 2021 daemon.notice wpa_supplicant[16240]: wlan0: CTRL-EVENT-CONNECTED - Connection to f4:f2:6d:60:59:d6 completed [id=0 id_str=]
Mon Mar  1 16:33:06 2021 daemon.notice netifd: wwan (16464): udhcpc: started, v1.30.1
Mon Mar  1 16:33:06 2021 daemon.notice netifd: wwan (16464): udhcpc: sending discover
Mon Mar  1 16:33:06 2021 daemon.notice netifd: wwan (16464): udhcpc: sending select for 192.168.1.254
Mon Mar  1 16:33:07 2021 daemon.notice netifd: Network device 'wlan0-1' link is up
Mon Mar  1 16:33:07 2021 daemon.notice netifd: wwan (16464): udhcpc: lease of 192.168.1.254 obtained, lease time 3600
Mon Mar  1 16:33:07 2021 daemon.notice netifd: Interface 'wwan' is now up
Mon Mar  1 16:33:07 2021 daemon.info dnsmasq[789]: reading /tmp/resolv.conf.auto
Mon Mar  1 16:33:07 2021 daemon.info dnsmasq[789]: using local addresses only for domain test
Mon Mar  1 16:33:07 2021 daemon.info dnsmasq[789]: using local addresses only for domain onion
Mon Mar  1 16:33:07 2021 daemon.info dnsmasq[789]: using local addresses only for domain localhost
Mon Mar  1 16:33:07 2021 daemon.info dnsmasq[789]: using local addresses only for domain local
Mon Mar  1 16:33:07 2021 daemon.info dnsmasq[789]: using local addresses only for domain invalid
Mon Mar  1 16:33:07 2021 daemon.info dnsmasq[789]: using local addresses only for domain bind
Mon Mar  1 16:33:07 2021 daemon.info dnsmasq[789]: using local addresses only for domain lan
Mon Mar  1 16:33:07 2021 daemon.info dnsmasq[789]: using nameserver 192.168.1.1#53
Mon Mar  1 16:33:07 2021 daemon.info dnsmasq[789]: using nameserver 192.168.1.1#53
Mon Mar  1 16:33:08 2021 user.notice firewall: Reloading firewall due to ifup of wwan (wlan0)
Mon Mar  1 16:37:52 2021 daemon.notice wpa_supplicant[16240]: wlan0: CTRL-EVENT-BEACON-LOSS
Mon Mar  1 16:38:44 2021 daemon.notice wpa_supplicant[16240]: wlan0: CTRL-EVENT-BEACON-LOSS

Hi, I'm having the exact same problem in a client + AP router:

wpa_supplicant[3035]: wlan1: CTRL-EVENT-BEACON-LOSS

I think it's probably because the AP is too far away from the client? It's just a guess, but it was working properly without the warning in my previous router ( 940N) Right now I'm using an Archer C6.

My config looks like this:

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid '****'
        option encryption 'sae-mixed'
        option key '*****'
        option disabled '0'

config wifi-iface
        option device 'radio1'
        option network 'trm_wwan'
        option mode 'sta'
        option ssid '****'
        option bssid '******'
        option encryption 'psk-mixed+aes'
        option key '****'
        option disabled '0'

try setting beacon interval to 2999 on the repeater master AP.

Thanks for the advice, I already did (I increased the beacon interval of the router my OpenWrt device is connected to), I'll see how it goes.