Creating wan interface

Hi guys,
I have a BT Home Hub here with the latest OpenWRT. The problem is that there is no wan interface defined. I added one and set the protocol to static and defined an ip address. I set the device to eth0.1? Is that right?
I’m a bit lost to be honest.
Thanks in advance

Check the "OpenWrt/LEDE Installation Guide for BT Home Hub 5A" from

1 Like

Thank you, that helped me progressing. Now I have the wan port up and running and it gets a valid IP address from my isp router. I can update the software lists and stuff so the internet works on the router. Now the problem is that nothing gets through to the user. Both my laptop and my phone say that there’s an internet connection, but I cannot open any sites. Maybe a problem with the dns or firewall of the router?
Thank you

Edit: It must be the dns, because I manually added the google dns to my phone and now it works. Mmmhhhhh, where could be the error on the router side then?

I looked a bit deeper into the matter and found out that dnsmasq is causing trouble. That’s what I get from the log:

Sat Sep 25 18:16:28 2021 dnsmasq[7223]: 109 query[type=65] from
Sat Sep 25 18:16:28 2021 dnsmasq[7223]: 109 config error is REFUSED

I looked it up and found absolutely no solution for that problem. I thought mmhh maybe there’s something really wrong and so I did a hard reset and back to factory settings, but the problem still persists.

Edit: I’ve found the solution. I had to edit the /etc/dnsmasq.conf file and add a server (server=…). That did the trick. I have no idea why especially me had this problem, but hey, it’s solved. :grinning:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.