marena
February 6, 2023, 6:15pm
1
I'm trying to get my machine to host two separate Wi-Fi networks, one which allows access to the outside internet, and one which only allows internal communication. So far, I have tried to create unique interfaces for the networks, then use firewall zoning rules to not allow forwarding between them. After hours of experimentation in the /etc/config/network, /etc/config/wireless, and /etc/config/firewall files, this has yielded no success.
Eventually, the outside connection will come from PPP, but as of right now it comes from a Wi-Fi connection on the "wwan" interface, configured by LuCI
I think the use of multiple bridges might help, similar to this discussion seen here:
Hi mk24,
Wow, okay, I did not see that being the way to achieve what I wanted, but it worked! Thank you.
For future reference for myself and others who may want to do the same, here is my new configuration:
Interfaces
Interfaces are configured with their own br-wan and br-lan bridges still, to allow WiFi networks to be attached to them.
[image]
Devices
The following devices are present, consisting of the 3 bridges, 2 VLANs for the br-eth and the 3 ethernet ports:
[image]
Bridge br-eth …
How can I configure a system like this?
let's see the config files:
Please copy the output of the following commands and post it here using the "Preformatted text </>
" button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
marena
February 6, 2023, 6:44pm
3
network:
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd37:8453:da23::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0.1'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.2'
option netmask '255.255.255.0'
option ip6assign '60'
config device
option name 'br-vlan'
option type 'bridge'
list ports 'eth0.3'
config interface 'vlan'
option device 'br-vlan'
option proto 'static'
option ipaddr '192.168.1.2'
option netmask '255.255.255.0'
config device
option name 'eth0.2'
option macaddr '0c:cf:89:6f:9b:f8'
config interface 'wan'
option device 'eth0.2'
option proto 'dhcp'
config interface 'wan6'
option device 'eth0.2'
option proto 'dhcpv6'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '1 2 4 6t'
config switch_vlan
option device 'switch0'
option vlan '2'
option ports '0 6t'
config switch_vlan
option device 'switch0'
option vlan '3'
option ports '3 6t'
config interface 'wwan'
option proto 'dhcp'
Wireless:
config wifi-device 'radio0'
option type 'mac80211'
option path 'platform/10300000.wmac'
option channel '1'
option band '2g'
option htmode 'HT20'
option disabled '0'
option cell_density '0'
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt'
option encryption 'none'
config wifi-iface 'wifinet2'
option device 'radio0'
option mode 'sta'
option network 'wwan'
option ssid 'the_ssid'
option encryption 'psk2'
option key 'password'
config wifi-iface 'P'
option device 'radio0'
option mode 'ap'
option network 'vlan'
option ssid 'P'
option encryption 'psk2'
option key 'password'
DHCP
config dnsmasq
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
option nonwildcard '1'
option localservice '1'
option ednspacket_max '1232'
config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv4 'server'
option dhcpv6 'server'
option ra 'server'
option ra_slaac '1'
list ra_flags 'managed-config'
list ra_flags 'other-config'
config dhcp 'wan'
option interface 'wan'
option ignore '1'
config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'
Firewall:
config defaults
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
option synflood_protect '1'
config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
list network 'lan'
config zone
option name 'vlan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
list network 'vlan'
option masq '1'
config zone
option name 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
list network 'wan'
list network 'wan6'
list network 'wwan'
config forwarding
option src 'lan'
option dest 'wan'
config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'
config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fc00::/6'
option dest_ip 'fc00::/6'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'
config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'
config rule
option name 'Support-UDP-Traceroute'
option src 'wan'
option dest_port '33434:33689'
option proto 'udp'
option family 'ipv4'
option target 'REJECT'
option enabled 'false'
config include
option path '/etc/firewall.user'
Your vlan interface the same address and subnet as the main lan. You need to use a different subnet and address... for example, 192.168.2.1
You don't have a dhcp server configured for the vlan interface... you'll probably want one:
config dhcp 'vlan'
option interface 'vlan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv4 'server'
the vlan firewall zone doesn't need masquerading. Turn that off.
Do you need the vlan and lan networks to talk to each other (i.e. vlan > lan, lan > vlan, or lan < > vlan)?
2 Likes
marena
February 6, 2023, 7:02pm
5
Nope!! They just need to be completely separate networks with no common traffic. This worked, thank you!
You're welcome. Glad it worked!
system
Closed
February 16, 2023, 7:04pm
7
This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.