Copy files from router to PC

I'm using a R7800 router and Linux desktop.
I have installed Doublecmd and configured several Linux devices under network.
So I can copy files from my Linux device to my desktop.

But when I try to copy /etc from my R-7800 it says 'error reading file'.
My password is ok and can login and see the directory but can't copy files.

Anybody who has a solution for me?

Thank You very kindly

Grtzz tom

Hi, chek your permissions to data, what the protocol you are use to copy data? sftp is good i'm think

scp is the easiet tool/protocol, as it is built-in into dropbear (the default SSH server in the router).

1 Like

I'm ofcourse logging in as root and using SSH+SFP protocol.
Do I need perhaps the *.pub key en *.pem key?
(if yes, where do I find them? :slight_smile: )

You cannot copy a whole directory like this. I just tried it in WinSCP and gave me an error as well.
Install openssh-sftp-server and connect with SFTP protocol, which works fine.

1 Like

Why not?
scp handles recursive dirs ok, but you need to set parameters just like with "cp".

scp -r user@host:/path/* /targetpath


Maybe you are right, however the only option I could find in WinSCP was for listing.


openssh-sftp-server was installed already

I have no problems to copy /etc from my FB4040 via WinSCP to my local PC. Just via drag & drop, nothing special to be selected.

Tested with scp to dropbear + openssh.


I'm on Linux but I'll try VM Windows.

As usual, the solution is not that dificult.

Filezilla is capable of downloading the files without trouble.
You just have to right-mous-click on the directory and choose download.

Thank you all for your help.

grtzz tom

I stand corrected. I tried it again today with drag 'n' drop and worked. Then I tried to download within the WinSCP and worked as well.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.