Convert WAN port to a LAN port

I'm trying to use a WAN port as part of the LAN in an attempt to expand my wired and wireless network. The device - netgear r6700v2 with ramips.

Most of the documentation out there says to remove the WAN/WAN6 under Network->Interfaces (which I did).

Then in Network->Devices, under br-lan configuation, I see the lan 1-4. Some of the documentation says to add the Ethernet Adapter (wan). This didn't seem to work until I also add the "eth0" which is labeled as the ethernet switch.

Can anyone explain why I need both eth0 and wan?

Could you please post the uci export network ?

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option packet_steering '1'
        option ula_prefix 'fdde:8ddd:0d75::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'
        list ports 'wan'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.2'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.1.1'
        list dns '192.168.1.1'

Ah you have changed it already. What is the original config? Does it exist?
cat /rom/etc/config/network
If it isn't there, do you remember if it had the eth0 or wan as device in wan interface?

/rom/etc/config/network doesn't exist, so it must be generated after inital boot.

I looked at my other devices (also r6700v2... I started to standardize on these... though I wish I had thought about 2.4 ax before choosing this model... would be nice to have), and eth0 isn't associated with wan either.

Do you have the default network config from the other devices?