Connecting Wireless Repeater to OpenWrt Device

Hello Everyone, I am trying to connect wireless repeater to OpenWRT device. I was able to connect tplink as wireless access point however when I connect to the repeater access point my devices cannot obtain IP address. DHCP server is switched off on the repeater and I am able to get IP address from the main router connecting ethernet cable to the repeater and everything is working great. There is no problem connecting to the main router with wifi or ethernet. Problem occurs when I try to connect to the repeater using wifi. Any ideas? I apologise if I am not very clear. If you have questions or would like me to paste any of my settings from my main router(OpenWRT) please let me know. Thank you in advance

can you actually see the wifi signal from repeater ?
How do you connect to it ? How do you connect repeater to main router (wan or lan port) ? Main router IP address ? AP settings, see below

then

openwrt build/snapshot used

etc/config/network (cat etc/config/network)

and

etc/config/wireless (cat etc/config/wireless)

output

ifconfig output

don't know if anything else is needed for a diagnosis ?

Is your repeater also running OpenWrt? If you have OpenWrt on both ends you should be able to use WDS. The problem with an ordinary AP-STA link is that it expects there to be only one possible MAC address at the STA end. This is a problem when you try to bridge several users into the STA. WDS transmits an extra MAC address, that of the final destination of the packet, like a cable does.

@Pippo Yes I can see the wifi from my repeater and can successfully connect to the main router(openwrt). Repeater starts to transmit wifi signal with the same SSID as the main router. But none of my devices can get a IP address when connected to the repeater. Even if I manually input IP address to my devices still no result. However, when I directly connect my laptop to the repeaters ethernet port everything works great.
I am connecting to the main router(openwrt) using wifi. So two devices are connected using wireless repeater. There is no physical connection between the two. Main routers IP address is: 192.168.1.1

So when I ssh into openwrt it is showing the following: BusyBox v1.29.3 () built-in shell (ash) NATCAP 4.0_b201812081014, Bionic

/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd53:0a56:5963::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr 'b0:6e:bf:db:bf:69'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option hostname 'AsusAC1700'

config device 'wan_dev'
        option name 'eth0.2'
        option macaddr 'b0:6e:bf:db:bf:6a'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 0t'

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/40000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT80'
        option disabled '0'
        option country 'CN'
        option txpower 'auto'
        option channel 'auto'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/soc/a000000.wifi'
        option htmode 'HT20'
        option disabled '0'
        option country 'CN'
        option legacy_rates '1'
        option txpower '19'
        option channel '6'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'HomeNet_5G'
        option encryption 'psk2'
        option wpa_group_rekey '0'
        option wpa_pair_rekey '0'
        option wpa_master_rekey '0'
        option key 'Safina2012'

config wifi-iface
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'HomeNet_2G'
        option encryption 'psk2'
        option wpa_group_rekey '0'
        option wpa_pair_rekey '0'
        option wpa_master_rekey '0'
        option key 'Safina2012'

ifconfig output

ifconfig: output: error fetching interface information: Device not found

@mk24 No my repeater is not running OpenWrt. It is using genuine tplink firmware. However, I was able to get it working by changing the mode on my repeater to wireless bridge and I also changed the SSID on the "repeater device" to something different than the main routers ssid. DHCP is off on the repeater so the main router is the only DHCP server. Everything is working with this mode and I can see all the devices in the network. Problems are that new devices are taking ages to get IP address from the "reapeter" and internet is much slower on the repeaters wifi connection that it was before I used openwrt as a firmware. Maybe this is another problem and I need to open new topic.

Udoes

ip a

shows interfaces ?

Sorry misread your first post ! I think people need your tp-link devices configuration too

like the one you posted for your main device

Are You following these

https://www.tp-link.com/us/faq-227.html ??

I don't know about WDS and openWRT some info here:

https://openwrt.org/docs/guide-user/network/wifi/atheroswds

but I believe first of all we need to figure out what are you trying to accomplish: i.e. what kind of

repeater mode are you trying to setup ?

dkQmV

https://www.tp-link.com/us/faq-442.html

and https://www.tp-link.com/us/faq-1324.html more names

and which ones are supported by tp-link firmware

if WDS some more info from forum:

More on Tp-link configuration

Don’t know if it is a good idea to upload config files into strange sites at the end they could contain security related configurations but nevertheless:

http://teknoraver.net/software/hacks/tplink/

http://www.zibri.org/2015/10/tp-link-configuration-file-encrypt-and-decrypt.html?m=1

Don’t know if they apply to your device either...