Connecting to WiFi with SSH

I flashed openwrt to my Netgear EX3700 Repeater. I now need to install the luCI, but I need an internet connection to do that, so I want to connect the repeater to my existing network. I enabled the radio0 and edited the network and wireless file, but I cant connect.

network file

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd1f:1ffd:de99::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device 'lan_dev'
        option name 'eth0'
        option macaddr '14:59:c0:92:23:27'

config interface 'wan'
        option proto 'dhcp'

wireless file


config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT80'
        option disabled '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/10180000.wmac'
        option htmode 'HT20'
        option disabled '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

config wifi-iface
        option network 'wwan'
        option ssid 'NETGEAR**-5G'
        option encryption 'psk2'
        option device 'radio0'
        option mode 'sta'
        option bssid 'a0:40:a0:*********'
        option key 'b*************'

I am sure I typed all my router information in correctly. What do I have to change in order to get this working, do you guys have any ideas?

It won't work because you don't have any network interface wwan

1 Like

Try only one of SSID and BSSID for the client config.

I also don’t see a WWAN interface with an address or a route using it.

I’m not sure why you’re changing the LAN’s MAC address. I would be surprised if that’s the issue though.

The mac address change is pre-configured, I dont know why. How would I create an WWAN interface? I'm sorry I dont know this, my only real networking experience was setting up my nighthawk router with dd-wrt 2 years ago, I am only just now learning to use the command line.

edit: did the first thing that came to my mind and changed the wwan to wan in the wireless file, it's working now.

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.