Connecting TL-WR902-AC to Xfinitiy public WiFi

Thank you for great software, both OpenWrt and Travelmate.

Just finished installing OpenWrt 19.07.8 r11364-ef56c85848 and Travelmate Version
1.5.5 - on August 2021. Followed the instructions found at [OpenWrt Wiki] TP-Link TL-WR902AC v3 and packages/ at master · openwrt/packages · GitHub. It went pretty smoothly but along the way had to hunt down for a few pointers that I hope will help other lay persons like me:

  1. After flashing OpenWrt, do change the static IP of the ethernet port (lan). At the very least make sure it is not the same network as your upstream router.

  2. Activate radio0 ( 2.4 Ghz) in master mode - allows you to connect to the TP device through WiFi. You can now disconnect the ethernet wire and connect with WiFi.

  3. DO NOT put radio1 (5 Ghz) in both master and client mode. I'm sure there are experts out there that can do this but for us mere mortals this leads to ongoing headaches. You can uplink it to your home router to test but remember to disable it before installing Travelmate.

  4. Before installing Travelmate, collect the name of all required packages it depends on, goto system/software in Luci and install them first.

  5. Go ahead and install Travelmate using the instructions given at the linked page given above. When you get to the part about Auto login script, pick the generic-user-pass.login. It works just fine with xfinitywifi.

  6. Lastly, if you're using the same versions of OpenWrt and Travlemate that I am, and now I'm quoting from another post on this forum, "Most probably "Rebind Protection" is enabled in your dnsmasq configuration ... options for you in order to move forward:

disable the rebind protection (for testing), after that the connection to the captive portal should work. (in LuCI: Network => DHCP and DNS => Rebind Protection)

add your captive portal domain to the domain whitelist (in LuCI: Network => DHCP and DNS => Domain Whitelist)..."

I chose to add to the Domain whitelist.

Now you are ready to connect to xfinitywifi. If you intend to uplink the TP-WR902-AC to your home router again, you have to disable xfinity WiFi SSID in network/wireless and enable the SSID to your home router.

1 Like

I was able to install openWRT to my TP travel router but am having issues getting internet access after connecting to xfinitywifi. Would you mind explaining how to install Travelmate in the device? The instructions on the Travelmate website dont explain very well.

opkg update; opkg install travelmate luci-app-travelmate

Then follow the documentation from the Travelmate thread and git hub

That's what I don't get, where do I run that command? Do I ssh into the router or is there another way?

Yes, SSH into the router. Or you can do it via the LuCI web interface > System > Software. (Update lists... and then you can filter by Travelmate > Install...)