Connecting Router to a WPA2-Enterprise Network?


So I installed OpenWrt on my Netgear r7800. I have visited the page, where you can edit things and I put in my password. So far so good.

Now I want to use this Router as an Client Bridge: The Router recieves the wifi signal and passes it through an ethernet port.

For that, i need certain packages to download. This is when i realised, that my Router has no connection to the internet.

I wanted to connect it through wifi, but there is no option for WPA2-Enterprise networks (or at least, I didnt find it). (Also, the Encryption is specified as "WPA2 802.1X (CCMP)".

I scan the radio0, find my network, klick on "Join Network" and then there is this window:

If you need further information I am happy to provide you with them.


Fresh to OpenWRT myself, but what I already can tell, you need to replace the versions of wpad or hostapd with their full versions first. Pre-installed version is only with WPA2-PSK.

Delete the preinstalled package, install the full one, then reboot ... of course, you need a working internet connection first. There may be other ways I don't know.

... this applies to x86 and Linksys WRT1200AC version of OpenWRT, for your router that may be the same?

The basic install does not support 802.1X. You will need a temporary connection to the Internet by other means to install the necessary packages, in particular replacing wpad-basic with the full version.

One reasonably simple way is to set a smartphone to hotspot mode (WPA2-PSK encryption, which is supported) and use it as the WAN.

@Seraphin, x86 builds don't ship with any WiFi related packages, because if there is wifi hardware on an x86 machine at all, it will vary.

1 Like

which packages do I need specificly? "wpad-full"?

So, I tried to get Access to the packages with the hotspot of my smartphone. I do get a connection, but I still have an error if I do "update List":

and here is my connection:

It's not properly connected to the Internet. Go to Network, Interfaces, edit WAN, physical settings, and select the wifi client instead of the Ethernet port. Make sure the "Bridge" box is not checked.

1 Like

I did as you say, but it still doesnt work. Does it have something to do with "Mode: Client"?

It looks like you used the "Join Network" button. I don't like that button; it creates a new "wwan" network which is unnecessarily complicated.

Suggest starting with default settings. Go to wireless and configure your client manually. You need the SSID (the network name the phone is broadcasting), encryption type (PSK2 CCMP), and the key. BSSID can be left blank. Choose "wan" for the network. Make sure to enable the radio overall. Double check on the wan physical page that the wlan client is the only thing in a non-bridged network. The main status page should show you have an "IPv4 Upstream" with 192.168.42.X if the phone is Android.

1 Like

I added the Network (which was given) (SSID: Switch):

This is everything you see in "Edit":

I didn't understand the sentence "Double check on the wan physical page that the wlan client is the only thing in a non-bridged network." cause it seems like I've already done that, but im not sure.

Did I create the netwrok wrong manually?

It's not linked. For everything modern, use PSK2 not PSK.

Okay, I fixed that with the encryption. The other part is still a guessing game to me. I try so many things, but nothing seem to work:

  • I created a connection manually with "Add"
  • I put "Switch" as the SSID (what the wifi is called)
  • put it as "wan"
  • useed PSK2 Encryption
  • put in the password correctly (I checked)
  • Put it as Client

And i checked the interface settings and tried different wifi connections.

And what do you mean its not linked :frowning:
How can I connect this more, than it already is?

I just connected to another hotspot, cause my Smartphone hotspot was f'd up. That solved it :).
Now I just dowloaded "wpad", rebootet the system and bahm: I was able to log into WPA2 Enterpise, lets f'ing go ^^

This topic was automatically closed 0 minutes after the last reply. New replies are no longer allowed.