Connecting old devices via WiFi

Hi everybody,

After years of stalling, I finally installed OpenWrt (22.03.2) on my Linksys 3200ACM and I am loving it.
The migration was almost perfect (though a little lengthy): OpenVPN, DMZ, and almost all of my over 100 devices are working perfectly, using LAN, Wifi 2.4 and 5.0. I kept the old SSID and Key, so all devices were just popping up after I created the static leases and enabled the wireless connections. And my question here is about the "almost", of course.

I still use an old Palm TX that was working fine with the stock Linksys firmware set up like this:

but now it doesn't connect. I tried all the options available on the GUI with no success, even some combinations of options, and nothing.

It just says "Connection failed", and doesn't even get to the IP address part. I tried using tcpdump but the issue seems to happen before the TCP part gets involved.

Any ideas? I really like my old Palm and would hate not to be able to synchronize it using WiFi

802.11b concurrency has been disabled by default in recent releases, as this causes a significant performance degradation relative to 802.11g and up (this can be changed in configuration). Beyond this, mwlwifi is known not to be great at interoperability with other vendors' wifi chipsets (worst with Espressif esp8266/ esp32 wireless in many IoT devices). But without closer debugging and knowing about the specs of this Palm TX, it's mostly guess work.

1 Like

Any suggestion on how I can get debug info from the handshake?

UPDATE
I forgot to post my current config:


Everything else is using the default options.

If I remember right, you also need to disable wmm mode to get mwlwifi to work with older devices (right below your screenshot area in general setup).

1 Like

Which implies dropping throughput of the interface to 54 MBit/s and disabling 802.11n/ac features/ performance - while it helps with interoperability, that wouldn't be a price I'd be willing to pay.

1 Like

It is disabled.

I only use 2.4 for devices like light switches, thermostats, and things like that, that don't require too much band. Oh, and my Palm TX, of course :slightly_smiling_face:.
For high throughput, I use 5.0 and I have another router with a different configuration just for wireless cameras, so they don't interfere with my regular work. The problem is that this other router is in the basement, too far from where I use my Palm, otherwise, I could use it instead of the 3200.

It's not a direct answer to your question, but if you still have old device(s) you need to connect, why not buy an old 802.11b AP specifically for that purpose? I'm sure you can find some for like $10 in most metro areas. Surely would beat wasting time troubleshooting WRT3200ACM wifi.

1 Like

Check to see if you enabled 802.11r (fast transition) on your 2.4 band. Some devices bug out with FT. For example, some ring security cams will not connect to a band using FT.

1 Like

Not a bad piece of advice. I'll take a look around.

It's disabled. This is one of the options I tested first because I saw somewhere that it could cause issues. Just as a note, none of my other devices had any problem with this option checked except the air purifier, which lost connection but returned when I unchecked it.

1 Like

I wouldn't exactly take the 802.11b AP literally here, semi-recent QCA or Mediatek based APs (n/ac/ax) will already do (just about anything but Marvell wireless).

1 Like

I think I have an old AP stuck somewhere in the basement. I'll take a look there first and see if I can manage without buying new stuff. But thanks again for the tip.