Connected to Wifi no internet but using hotspot from phone can

network config

config interface 'lan'
option type 'bridge'
option ifname 'eth0' 
option force_link '1' .
option proto 'static'
option ipaddr ''
option netmask ''
option ip6assign '60'

config interface 'wwan' 
option proto 'dhcp' 
option peerdns '0'
option dns '' ## Google DNS servers

config interface 'vpnclient'
option ifname 'tun0' 
option proto 'none' 

firewall config

i was trying a new project and i followed this tutorial :

but i have been having trouble having it to connect to my home Wifi(wireless ofc)
so i tried using my hotspot and it works as it should have with a Wifi connection.

please do help how can i overcome this matter. Thanks in advance

Using LuCI it's very easy: Just go to Network -> Wireless and click on "Scan".
It's usually better to follow tutorials on the OpenWrt Wiki, not from some random external site:

1 Like

yeah i managed to connect to the wifi but the problem is there is no internet.
im unable to ping , result is unreachable.
opkg update also fails.

is this a dns problem? because i already specify the DNS.

note : when using my phone's hotspot it went normally can opkg update and all.

That's easy to verify: Try to ping your travel router, if this works try to ping If this also works it's DNS. If not, there might be a routing problem.

Did you use the same IP address range in your home WiFi and the newly set up router? If yes, that's not going to work, you need different subnets.

well my home wifi is
the rasp_Pi router is

so i should change the netmask of the new router??

No, that's fine, that's different subnets.

this is the result.

could you please elaborate. im kinda new in networking stuff

okay... this is weird, now it works after some tinkering on the network and power on/off 2 times

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.